WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache: Slider doesn't work anymore (11 posts)

  1. ThomasvdW
    Member
    Posted 1 year ago #

    Hello everybody,

    After my website became very slow (loading times over 14 seconds), I installed W3 Total Cache and my website became a lot faster (4 seconds). But now the image slider on the homepage doesn't work anymore. It keeps loading, but nothing is shown. It's a theme from Elegantthemes, here: Professional.

    This is my website: webguideict.com (Text in Dutch.)
    What can I do to fix the image slider?

    Regards,
    Thomas

  2. ThomasvdW
    Member
    Posted 1 year ago #

    When I turn of W3 Total Cache the photo's in the slider appear again, so it's an option in W3, can someone help me?

  3. yosh
    Member
    Posted 1 year ago #

    I've noticed that the minify engine in W3TC doesn't play nice with the javascript in some sliders. You can manually manage your minify settings in W3TC, and add all the other javascript on your pages except the slider. Leave those as-is. This has solved this problem for me in the past while still getting most of the benefits of the plugin.

  4. wizard247
    Member
    Posted 1 year ago #

    I have exactly the same problem with a Revolution Slider and Avada Theme from ThemeFusion.

    What settings can I tweak to prevent this? I know I can set the Home Page not to be cached, but this is just where I need to speed it up as it has the Revolution Slider on it.

  5. thecjmnetwork
    Member
    Posted 1 year ago #

    Just exclude the revolution slider js file.

    Step 1
    Head to the menu item: "Performance" > "Minify"

    Where it says "Never minify the following JS files:" add the js file: [your url]/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.revolution.min.js?ver=3.6

    Click "Save all settings"

    I'm not totally sure whether the location of the file may be different, but you can find it using Firebug or similar developer tools that can display all script files.

    Step 2
    Head to the menu item "Performance" > "General Settings"

    Under "Minify" change the "Minify mode:" option to "Manual" and save all settings.

    That's it - you should be good to go. It worked for me.

  6. carras
    Member
    Posted 10 months ago #

    When you have Minify mode "manual", do you have to put all css and js URLs manualy?

    Is there a Semi-Automatic option? I just want to add that url you (thecjmnetwork) said?

  7. Jeewan
    Member
    Posted 10 months ago #

    @thecjmnetwork Thank you for the advise, this worked for me.

  8. elmalak
    Member
    Posted 10 months ago #

    @thecjmnetwork.
    Thank you for the tip, I tired it with Responsive Slider and it worked great!

  9. thecjmnetwork
    Member
    Posted 10 months ago #

    @carras

    I believe you have to include all of the scripts and css files you want to minify when using the Manual option. It's not ideal, but you should be doing that anyway considering automatically minifying js and css files is bound to break one of your plugins or themes.

    You can use Firebug or something similar to easily grab all of your script and style urls.

  10. carras
    Member
    Posted 10 months ago #

    Thanks @thecjmnetwork

    I did that. As you say not ideal but working.

    I also tried to make js asyncronious but didn't work either.

  11. ssent1
    Member
    Posted 8 months ago #

    @thecjmnetwork Your solution and step-by-step directions worked perfectly.

Topic Closed

This topic has been closed to new replies.

About this Topic