WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache Problems!!! (6 posts)

  1. jasongraham6
    Member
    Posted 3 years ago #

    Hi,

    After installing and activating W3 Total Cache on WP 3.1.3, I opened the Settings > General page, and saw four HUGE red warning messages:

    The first message at the top says:

    "Disk enhanced page caching is not active. To enable it, add the following rules into the server configuration file (/home/content/.htaccess) of the site above the WordPress directives . Or if permission allow this can be done automatically, by clicking here: "

    Permissions had been set to 777 on .htaccess, wp-content (and all sub-dir's). I tried the auto-install option and also pasting the code manually. BUT still I get error message:

    "The page cache rules could not be modified. Please create an empty file in /home/content/.htaccess and run chmod 777 /home/content/.htaccess to resolve this issue".

    .htaccess is there and has 777 permissions, so that makes no sense at all.

    The other error messages on the settings page are:

    "Browser caching is not active. To enable it, add the following rules into the server configuration file (/home/content/.htaccess) of the site . Or if permission allow this can be done automatically, by clicking here: . "

    AND

    "Minify is not active. To enable it, add the following rules into the server configuration file (/home/content/w/h/a/what9710/html/wp-content/w3tc/min/.htaccess) of the site . This can be done automatically, by clicking here: ."

    AND

    "The required directives for fancy permalinks could not be detected, please confirm they are available: Creating and editing"

    The other messages on there, which are not errors, are:

    "/home/content/w/h/a/what9710/html/wp-content is write-able. When finished installing the plugin, change the permissions back to the default: chmod 755 /home/content/w/h/a/what9710/html/wp-content. "

    AND

    "Preview mode is active: Changed settings will not take effect until...."

    Which does not make sense.

    All other plugins are disabled.

    Can anyone help, I've been at this for nearly a full day now without any sleep, I'm desperated to get it working.
    I'm also concerned because I submitted a bug report to the author, filling out all the fields including my admin username and password, and I haven't had any reply...

    Any help at all is very welcome!!!

    Thanks!

    J

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. jasongraham6
    Member
    Posted 3 years ago #

    UPDATE:

    This was a error being caused by somthing other than W3TC. It was a new blog, so I just backed up my content and reinstalled WP, which resolved my issue. I also recieved a reply from Frederick.

    I can't believe how good this plugin is! Well worth the initial hassle!!

  3. Frederick Townes
    Member
    Posted 3 years ago #

    Sorry for the trouble. I'm glad you figured it out.

  4. ktcolors
    Member
    Posted 2 years ago #

    I am having the exact same issue. Literally.

    You mentioned the issue was not the actual plugin. Can you elaborate on what else I should be looking into? I just upgraded WordPress so I don't think that's the problem.

    Really frustrated!

  5. Frederick Townes
    Member
    Posted 2 years ago #

    @ktcolors did you try to deactivate other plugins temporarily (re-activating them one-by-one) until something breaks) and even switch to the twentyeleven theme temporarily to see what the problem is?

  6. designsbyjf
    Member
    Posted 2 years ago #

    Frederick, I tried this and am having the same issue. I deactivated all plugins and still had the problem. What gives?

Topic Closed

This topic has been closed to new replies.

About this Topic