WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache Prevents RSS Updating (15 posts)

  1. richards1052
    Member
    Posted 3 years ago #

    I wonder if anyone else has noted that when you use W3 Total Cache and set it to cache your feed, tags & categories, it prevents RSS readers like Google Reader, Feedburner, Feedblitz from properly updating your feed?

    I've disabled cacheing for the feed but that also disables caching for things I want cached like tags, categories, etc.

  2. Frederick Townes
    Member
    Posted 3 years ago #

    This is a known issue that affects some users you can disable feed caching for now.

  3. richards1052
    Member
    Posted 3 years ago #

    The only problem there is that this will also disable caching for tags, categories & comments, which I do want cached. Is there any chance you could make the feed cache a distinct setting in future releases so you don't have to lose the functionality of the other cache features?

  4. Frederick Townes
    Member
    Posted 3 years ago #

    The next release fixes this issue. I don't plan on decoupling those items.

  5. richards1052
    Member
    Posted 3 years ago #

    Thanks. Fixing the issue avoids any need to decouple the items.

    I am curious though why w. w3tc activated viewing my feed using a browser feed reader shows the updated feed while viewing it through a commercial feed reader like GOogle, Feedburner, Feedblitz doesn't show the updated feed.

  6. Frederick Townes
    Member
    Posted 3 years ago #

    Browser cache settings?

  7. richards1052
    Member
    Posted 3 years ago #

    I don't think Chrome allows you to change any cache settings so I'm using whatever the default is. Same with Firefox, I've accepted default settings. Is there any particular thing I need to look for in my browser settings that would govern display of RSS feeds?

  8. Frederick Townes
    Member
    Posted 3 years ago #

    I don't understand the question. W3TC can tell your browser to cache pages/feeds/posts for any period you'd like. That was my point.

  9. richards1052
    Member
    Posted 3 years ago #

    Not sure what in my browser cache settings would've enabled it to properly update my blog feed. I suppose that's possible.

  10. Frederick Townes
    Member
    Posted 3 years ago #

    You can always disable feed caching if you have a doubt.

  11. richards1052
    Member
    Posted 3 years ago #

    I did disable it but that also disables caching of tags, categories, etc. which I don't want to disable. Is there a way to ONLY disable feed caching? I don't think so, but let me know if I'm wrong.

  12. richards1052
    Member
    Posted 3 years ago #

    I note there's a new update for the plugin & you mentioned earlier the next one would address the RSS updating issue. Can you tell me if that's true & I should reactivate that cache feature & test it?

  13. Frederick Townes
    Member
    Posted 3 years ago #

    I didn't address this issue in the 0.9.1.2 release. Unfortunately there's no way to disable of only feeds right now.

  14. coplan
    Member
    Posted 3 years ago #

    Using the latest version (as of this writing) and even the disabling of feed caching still seems to cache feeds - or at least it doesn't permit the feeds to update until I clear the cache. Is this a bug?

  15. Frederick Townes
    Member
    Posted 3 years ago #

    No it's not a bug, but there's not enough controls right now. The development version does have them: http://wordpress.org/extend/plugins/w3-total-cache/download/

Topic Closed

This topic has been closed to new replies.

About this Topic