WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache "Page Cache URL rewriting is not working.." error (5 posts)

  1. illestxren
    Member
    Posted 2 years ago #

    I've recently installed the W3 Total Cache Plug-in.. everything was fine except I came across this error message..

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    and.. it was preventing my blog posts to cached (I tested it with a website speed tester..)

    So I goggled, and landed on this thread..
    http://wordpress.org/support/topic/page-cache-url-rewriting-is-not-working?replies=119

    It is now closed and no one seems to have a real solution.. So I decided to come on here and tell you guys how I fixed it..

    I have another wordpress blog and I installed W3TC on that one and that error message did not appear. So all I did was copy the .htaccess code from the working blog and pasted into the one that is not working with a few edits..

    Here is the code from the working blog..

    [Code moderated as per the Forum Rules. Please use the pastebin]

    Copy that code into your non-W3TC working blog's .htaccess and look for "yourwebsite.com" lines (there should be 2) and replace it with your website's name.. Ex. Your website is yahoo.com you would replace "yourwebsite.com" with "yahoo.com".. Save everything and now go configure your W3TC Settings and it should work..

    I really hope this helps!

  2. illestxren
    Member
    Posted 2 years ago #

  3. Gwyneth Llewelyn
    Member
    Posted 2 years ago #

    Oh cool! I never bothered to check .htaccess in those cases, but it should have been obvious... this error appears once in a while just after upgrading W3TC, then mysteriously disappears again, so I haven't really looked into it. Next time I know where to look for :)

    Thanks!

  4. chandlerwhite
    Member
    Posted 2 years ago #

    Interesting. I just got the message after adding my first CNAME from MaxCDN.

  5. jmyette
    Member
    Posted 2 years ago #

    I also had this error message in 0.9.2.4. In my case the solution has been to fix my main .htaccess file in order for W3TC rules to be before WordPress rules.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags