WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] W3 Total Cache Minify URL rewriting error (13 posts)

  1. jaypster
    Member
    Posted 3 years ago #

    Upgraded to the latest version of W3 Total Cache - 0.9.2.1 and on my dashboard I got this error:

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    Checked with my hosting provider and Apache on my server supports/allows .htaccess files.

  2. AstroGremlin
    Member
    Posted 3 years ago #

    I previously reported that turning off CDN (or CND or whatever it is) fixed problems with W3 Total Cache and the abseve of Theme settings. But, although my site once again looked normal when viewed while logged in to WordPress, the site Theme was not loading properly when coming in logged out (that is the way a user would see it).

    I turned off Minify and it now the Theme looks normal. Although now with two things turned off, wondering if W3 Cacheing is doing much.

  3. Mike McKoy
    Member
    Posted 3 years ago #

    I'm getting the same error. Don't know why i'm using phpopcode with no issues and of course my server does allow .htaccess. I'm on a centos 5 63bit server.

    Thoughts? Anyone been able to fix that error?

  4. gideond
    Member
    Posted 3 years ago #

    Same thing here. I was setting up a new site and when I installed the W3 Total Cache Plugin everything seemed fine for a day or so, then I started getting this error. I have W3 installed on another site on the same server with no such error.

  5. Mike McKoy
    Member
    Posted 3 years ago #

    Has the author of the plugin responded?

    Has anyone reverted back to the old version? Can we do that safely?

  6. awpcp
    Member
    Posted 3 years ago #

    Broken here too. Had to turn off Minify CSS and JS to fix it. Hopefully this will be fixed quickly!

  7. Brian
    Member
    Posted 3 years ago #

    Same here. I have always had Manual Minify selected, so switching it from Auto isn't going to work since its not on Auto.

    I tried reverting to the previous version except the first time I get a 500 Error everywhere. I removed the random 'core' the downgrade adds to .htaccess and then my site works again. Except all my Minify files got removed and even uploading my settings backup didn't work at all. The minify URLs are clearly in the settings backup except uploading them doesn't work.

    I'm going to try it again. My theme is a bit messed up without minify since I included a lot of files that wasn't in my theme files

    Update: Just tried again with the old version 0.9.1.3 and my settings for minify still refuse to restore. Guess I'll go through adding them again by manually reading the settings backup.

    Hope this gets fixed soon.

  8. Mike McKoy
    Member
    Posted 3 years ago #

    WE'RE ALL GOING TO DIIIIIEEEEE!

    AIYEEE!

  9. vorsta
    Member
    Posted 3 years ago #

    After upgrade a lot of problems.... "It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration." "The required directives for fancy permalinks could not be detected, please confirm they are available...", maybe someone can help?

  10. Brian
    Member
    Posted 3 years ago #

    @vorsta I experienced the same problems when I upgraded. I read that switching to Manual mode for Minify fixes things but I always had it on Manual mode (Enter URLs in manually) so this wasn't a solution for me.

    I just downgraded the plugin and everything (mostly) went back to normal. Downgrading took me a while though and caused a series of problems, including 500 errors, missing URL settings for minify, etc... To bypass the issues, you should either disable Minify completely or attempt to downgrade.

    I'm going to hold off on upgrading until I notice a newer version available and can confirm that these errors are fixed. I don't want to waste tons of time reverting an upgrade again.

    It should be fixed in the next version according to the Twitter account: https://twitter.com/#!/w3edge/status/71126092286660608

  11. kw2
    Member
    Posted 3 years ago #

  12. frg
    Member
    Posted 3 years ago #

  13. harvest316
    Member
    Posted 3 years ago #

    read down to the bottom of frg's page. The addition from martinlbb is what you want!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic