WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache Messed Up My Site's Home Page Help! (8 posts)

  1. Infoliker
    Member
    Posted 1 year ago #

    Hey,

    I installed W3 Total Cache last night on my site and followed the Godaddy support suggestions for settings. This morning I get these 3 messages on the W3 general settings page

    "It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration."

    "Preview mode is active: Changed settings will not take effect until preview mode is or . any changed settings (without deploying), or make additional changes."

    "/home/content/38/10170538/html/wp-content is write-able. When finished installing the plugin, change the permissions back to the default: chmod 755 /home/content/38/10170538/html/wp-content."

    And my home page and members area are all messed up. The home page slider looks partially loaded as you can see here:
    http://infoliker.com

    Is there anything I need to do before just uninstalling the plugin?

    Thanks,
    Zac

  2. Willie Jackson
    Member
    Posted 1 year ago #

    You seem to be conflating those messages with a misconfiguration.

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    The current version of W3TC sometimes reports false negatives, you have to test to see if page caching is working:

    1. View source in a logged-out browser
    2. Scroll to the bottom of the page and find the W3TC HTML output timestamp
    3. Refresh the page and check the timestamp to see if it changed

    If the timestamp changes, the page is not being cached. If it doesn't, it is.

    Preview mode is active: Changed settings will not take effect until preview mode is or . any changed settings (without deploying), or make additional changes.

    This is pretty self-explanatory. It just reflects your settings.

    /home/content/38/10170538/html/wp-content is write-able. When finished installing the plugin, change the permissions back to the default: chmod 755 /home/content/38/10170538/html/wp-content.

    This is unrelated to W3TC and is actually doing you a favor by letting you know that your wp-content directory is writable. You can fix this via FTP.

    And my home page and members area are all messed up. The home page slider looks partially loaded as you can see here:
    http://infoliker.com

    Sounds like you have minify enabled and one or more of your scripts (it's usually JS) are breaking. Consider disabling minify and configuring it manually.

    Is there anything I need to do before just uninstalling the plugin?

    You can deactivate and remove W3TC through the dashboard like any other plugin. Can I help get it dialed in properly on your site?

  3. Infoliker
    Member
    Posted 1 year ago #

    Thanks Willie,

    I just uninstalled and fixed everything it fouled up. My site is extremely customized with special features and functions. I had to spend all day yesterday fixing everything.

    This is likely a great plugin for most sites, and advanced developers etc. as seen by the reviews, but I think I'll just stick to a cache plugin that doesn't rewrite as this one does.

    Cheers,
    Zac

  4. Willie Jackson
    Member
    Posted 1 year ago #

    I maintain that you were probably one checkbox (minify) away from your site not being broken, but understood. Glad you got it fixed.

  5. Infoliker
    Member
    Posted 1 year ago #

    Willie,

    I agree. At least that's when the problems arose. Could I suggest for the rest of your users that you add some instructions to that effect to save others hours of headache....

    Cheers,
    Zac

  6. Willie Jackson
    Member
    Posted 1 year ago #

    Future versions of W3TC will certainly make this process more seamless, but a basic understanding of Web Performance Optimization (at least) is required to make the most of a Web Performance Framework like W3TC.

  7. Infoliker
    Member
    Posted 1 year ago #

    Of course.

    That's why I ended up with quick cache, it has a message right on top that says to just leave as is, (default settings) and you're good to go, unless you're a developer and then feel free to customize below.

    Might take a look at your w3tc later. I'm just too busy to wrap my brain around it now, and my developers are killing me with current projects....:)

    Thanks,
    Zac

  8. Biggie
    Member
    Posted 10 months ago #

    I had the same issue and I can confirm I was able to fix it by simply un checking minify =)

    Very glad I found this thread.

    However my requests went from 50 to 122 after disabling minify. Only one plugin was messing up I'd love to get some guidance on how to manually configure minify to get the maximum benefit.

Topic Closed

This topic has been closed to new replies.

About this Topic