WordPress.org

Ready to get started?Download WordPress

Forums

Shadowbox JS
W3 Total Cache, MaxCDN & Shadowbox JS not working (8 posts)

  1. aljuk
    Member
    Posted 3 years ago #

    I've been trying for several days to get shadowbox to play nicely with max cdn / w3tc without success. I've read every thread I could find about getting shadowbox working with caching plugins and cdns and tried every solution described.

    I've methodically worked through many combinations of running assets from the web server and via the cdn, and am stuck.

    If anyone has managed to get shadowbox-js running with max cdn / w3tc and happens to read this thread, please advise. Thanks.

    http://wordpress.org/extend/plugins/shadowbox-js/

  2. Matt Martz
    Member
    Plugin Author

    Posted 3 years ago #

  3. aljuk
    Member
    Posted 3 years ago #

    Hi, thanks for the reply, but as I mentioned above, I've already been through those threads without success.

  4. aljuk
    Member
    Posted 3 years ago #

    From those threads:

    "In short this is a W3TC issue as it is mistakenly assuming that anything in the uploads dir should use the cdn hostname" - I don't think this is the case. Files to be included from the uploads directory have to be manually specified.

    "Either that or instead of using a push style CDN such as cloudfront/S3, use a pull style CDN." - Mine's a pull style.

  5. Matt Martz
    Member
    Plugin Author

    Posted 3 years ago #

    Please provide a link to your site that shows the functionality not working.

  6. aljuk
    Member
    Posted 3 years ago #

  7. Matt Martz
    Member
    Plugin Author

    Posted 3 years ago #

    The problem does not appear to be CDN related:

    http://cdn.costablancaconnect.com/wp-content/uploads/shadowbox-js/c312c9414e598bbd10da29d5eef306d5.js?ver=3.0.3

    That file is pulling without issue from your CDN.

    The problem seems to be a plugin incompatibility. The meebo code that is running on your site also seems to be attaching to the images. I would try disabling meebo and testing again.

  8. aljuk
    Member
    Posted 3 years ago #

    Hi, thanks for having a look.

    It's been running perfectly during 6 months of development, up until engaging the cdn. If I disable the cdn, it works fine. The other plugins work with the cdn or without, and with shadowbox or without. The only combo that fails is shadowbox with the cdn engaged.

    It's not related to the Meebo bar, which was the first possibility I explored.

    Much as it would appear on the surface to not be a compatibility issue with the cdn (since the shadowbox cache is being pulled) I have a hunch it's more complex than that, and that that's where the problem lies.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic