WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] inconsistent / not working - WPMU? (4 posts)

  1. simplistik
    Member
    Posted 4 years ago #

    I'm currently trying to run this plug-in on a WPMU site. The site is setup on a virtual server, so I have APC running. So I'm feeding all the pages and database caching through APC. However, I get very very inconsistent debugging information.

    1. It only shows debug information on the home page
    2. The home page shows:
      <!-- W3 Total Cache: Page cache debug info:
      Engine:             apc
      Key:                w3tc_65a12d8ad523696a28266807e817a5b8_page_6666cd76f96956469e7be39d750cc7d9_gzip
      Caching:            enabled
      Status:             cached
      Creation Time:      0.003s
      Header info:
      X-Powered-By:       W3 Total Cache/0.8.5.2
      Last-Modified:      Fri, 07 May 2010 15:44:04 GMT
      Vary:               Accept-Encoding, Cookie
      Pragma:             public
      Expires:            Fri, 07 May 2010 16:44:04 GMT
      Cache-Control:      max-age=3588, public, must-revalidate, proxy-revalidate
      Etag:               2cf2d8fce2d364a02c401f393b82ab0d
      Content-Encoding:   gzip
      X-Pingback:         http://site.com/xmlrpc.php
      Content-Type:       text/html; charset=UTF-8
      -->

      all other pages show:

      <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/
      
      Minified using disk
      Page Caching using disk (enhanced) (user is logged in) ...

      you can see right away that something is funky cause:
      a. it's not outputting all the debug information (if it's supposed to)
      b. it says it's using disk caching when I specifically told it to use APC (as seen on the homepage)

    Other things to note, I am using the development version (as I saw you recommended that a few times), I've done a complete uninstall and a clean install and I've also tried to use the disk methods. And it will only write the homepage to the pgcache folder. With W3Cache activate I'm not able to activate any other plugins site wide. I have to disable it and re-enable it so I can activate other plugins.

  2. Frederick Townes
    Member
    Posted 4 years ago #

    Site wide activation is not supported. I will need access to your server to further debug this issue. Can you submit a bug submission report via the support tab?

  3. Russell Heimlich
    Member
    Posted 4 years ago #

    I have the exact same problem. Unfortunately this is one a live site, not a dev one so I have to revert back to WP Super Cache. Any insight into why only my homepage would be cached would be greatly appreciated.

  4. Frederick Townes
    Member
    Posted 4 years ago #

    A conflict with your directives. Cannot be sure without looking at your site.

Topic Closed

This topic has been closed to new replies.

About this Topic