WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
W3 Total Cache error Page Cache URL rewriting (5 posts)

  1. bdalte
    Member
    Posted 12 months ago #

    I got the following error:
    W3 Total Cache error: It appears Page Cache URL rewriting is not working. Please verify that the server configuration allows .htaccess
    Unfortunately disk enhanced page caching will not function without custom rewrite rules. Please ask your server administrator for assistance. Also refer to the install page for the rules for your server.
    Technical info

    Is there anything i can do through cPanel?

    thanks

    http://wordpress.org/plugins/w3-total-cache/

  2. HoneyTrek
    Member
    Posted 5 months ago #

    bump, getting the same error, recently.

  3. leslie1019wp
    Member
    Posted 5 months ago #

    Many webhosts don't make Enhanced Disk Caching available in certain hosting environments, ie Shared Hosting or Managed WP Hosting. VPS or Dedicated may afford additional opportunities.

    First, contact your host at make it's available. If it is, they can install it for you to the server (if you have managed hosting.)

    If not, you can see if an OpCode cache is available, or you will have to use Basic Caching.

  4. juniorbra
    Member
    Posted 2 weeks ago #

    I have the W3 installed in 5 websites. In one of them, the site works fine from any browser, but when I'm trying to access it through a "page loading test" site (e.x. pingdom.com, websiteoptimization.com, uptimerobot.com) the site always reports Forbidden 403 error!

    When I change on "Page Cache Method" from "Disk: Enhanced" to "Disk: Basic" the 403 Error stopped showing up.

    Any idea to enable "Disk: Enhanced" and stop with the Forbidden 403 Error?

  5. juniorbra
    Member
    Posted 2 weeks ago #

    Just an update to help someone having the same issue... I've fixed the problem following the steps below :)

    In public_html/wp-content/cache/page_enhanced/www.mysite.com there were 2 files, _index.html.old and _index.html_gzip.old. There was also a public_html/wp-content/cache/page_enhanced/www.mysite.com/.htaccess folder and inside it there were 2 files, _index.html and _index.html_gzip.

    So I renamed .htaccess folder to .htaccess_old and also the files inside to _index.html.old and _index.html_gzip.old.

    Then I renamed the _index.html.old and _index.html_gzip.old from inside public_html/wp-content/cache/page_enhanced/www.mysite.com to _index.html and _index.html_gzip.

    So the problem was fixed and I was able to enable page cache disk enhanced mode.

Reply

You must log in to post.

About this Plugin

About this Topic