WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
W3 Total Cache Error: Files and directories could not be automatically created t (28 posts)

  1. hardyakka
    Member
    Posted 1 year ago #

    Since the latest update of W3 Total, I have received the error as per topic title. Full text of error reads:

    FTP credentials don't allow to write to file /home/xxxxx/public_html/.htaccess
    W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.
    Please execute commands manually [button: view required changes]
    or use FTP form to allow W3 Total Cache make it automatically. [button: update via FTP]

    Viewing the required changes, I get:

    Edit file /home/xxxxx/public_html/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

    The trouble is that when I looked in .htaccess, the above mentioned strings do not appear to exist. When I pressed the "update via FTP" button, I did not get a form to fill in my FTP details; just a blank line appeared (not a field) and nothing else happened.
    W3 Total was working prior to the update and I had made no changes following the update.
    If I deselect "Remove write permissions from .htaccess and wp-config.php" in Better WP Security, the error message disappears. I do not want to deselect this feature of Better WP Security and W3 Total had no problem with this setting prior to the update.
    I would appreciate if anyone had an insight into the cause of the error message and how I might be able to resolve the situation. As it is I am running W3 Total with the error and I don't know what impact it is having on performance or security.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. hardyakka
    Member
    Posted 1 year ago #

    Another thread has just started (no solutions yet) which seems to focus on the same error type/message as the one I mention here.
    http://wordpress.org/support/topic/new-update-didnt-workw3-total-cache-error-files-and-directories-could-not-b?replies=3

  3. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Can anyone having this issue please submit a bug submission form from the support tab of the plugin or reach out to me directly?

  4. Exponom
    Member
    Posted 1 year ago #

    Hi, I've got the same issue when Better WP Securiry function "Remove write permissions from .htaccess and wp-config.php" is activated.

    Turning this on will set the unix file permissions to 0444 on these files and turning it off will set the permissions to 0644.

    W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.

    Edit file /mysite.com/.htaccess and remove all lines between and including # BEGIN W3TC Page Cache and # END W3TC Page Cache markers.

  5. organicjar
    Member
    Posted 1 year ago #

    Hi!
    I'm getting the same error.
    ANY SOLUTIONS YET?

  6. Richard Bland
    Member
    Posted 12 months ago #

    Same error with no solutions yet :-(

  7. Taubin
    Member
    Posted 12 months ago #

    I'm having the same issue. I've submitted a bug report through the plugin support page as requested. Hopefully it helps get this resolved.

  8. timocouckuyt
    Member
    Posted 11 months ago #

    Any solution on this issue?

  9. jherrero7
    Member
    Posted 11 months ago #

    I tested the plugin on several websites I manage. Does not work properly on any of them. I tried it in a web bouncy castles but not working properly.

  10. timocouckuyt
    Member
    Posted 11 months ago #

    A client of mine just reported this issue being the cause of a conflict with the qtranslate slug plugin. This might help :-)

  11. Dries Vints
    Member
    Posted 11 months ago #

    People who are having problems with this. I've solved it by making the .htaccess file temporarily writable.

  12. tomdkat
    Member
    Posted 11 months ago #

    Has anyone experienced this issue since upgrading to W3 Total Cache 0.9.3? 0.9.3 is supposed to address this issue, apparently.

    Peace...

  13. dm5k
    Member
    Posted 11 months ago #

    Having the same issue since 0.9.3

  14. Taubin
    Member
    Posted 11 months ago #

    Same thing here, I had posted a bug report to the dev, and he stated it should be fixed with the most recent update, however the most recent update is the one that broke this for me.

  15. davidpmurphy
    Member
    Posted 10 months ago #

    I fixed my issue by deselecting "Remove write permissions from .htaccess and wp-config.php" under the "Tweeks" tab in Better WP Security plugin setting options.

    Hope this helps someone.

  16. nickzee
    Member
    Posted 10 months ago #

    @davidpmurphy that worked for me. Thank you!

    @bit51

    Is there anyway to leave "Remove write permissions from .htaccess and wp-config.php" on and allow W3TC to do it's thing? Adding the exclusion didn't allow it to write to wp-config.

    Thank you!

  17. wpgeekster
    Member
    Posted 8 months ago #

    Please correct me if I'm wrong. Once w3 total cache writes to the .htaccess it would very rarely need to change. So it seems that if you deselect "Remove write permissions from .htaccess and wp-config.php" in the Better WP Security Plugin and then configure w3 total cache to write thee rules to the .htaccess file, then you can re-select the "Remove write permissions from .htaccess and wp-config.php" again. Then if w3 total cache reports the error, then it doesn't matter because the rules have already been written to the .htaccess file. Unless of course you need to change the configuration again, then you would just have to deselect the "Remove write permissions from .htaccess and wp-config.php" file to write the new rule and reselect when done.

    Is that correct or am I misunderstanding? In other words does w3 total cache need write permissions to .htaccess and wp_config on a permanent basis?

    Thanks

  18. graphics616
    Member
    Posted 7 months ago #

    Has anyone found a solution to this problem? I do not want to disable "Remove write permissions from .htaccess and wp-config.php" in Better WP Security, in order to have no error message, and I do not want to look at a permanent "Error" message at the top of the W3 Total Cache page as wpgeekster suggests. Is there a real fix for this problem?

    I am using the Better WP Security version 3.6, and W3 Total Cache version 0.9.3, along with WordPress 3.7.1.

    Thanks all.

  19. esmi
    Forum Moderator
    Posted 7 months ago #

    @graphics616: If you require assistance then, as per the Forum Welcome, please post your own topic.

  20. graphics616
    Member
    Posted 7 months ago #

    I apologize esmi. I was under the impression that I was supposed to try to find my answers in the existing posts. I will post my version of the same question in a fresh post. I did not see an answer in the previous responses to this question and hoped to have a response from someone here without rehashing old territory.

  21. Widjojodharmo
    Member
    Posted 6 months ago #

    Deactive the better wp security and just then follow this instruction http://www.youtube.com/watch?v=59GRP6M-1AE to edit the .htaccess. Delete the script in .htaccess and copy paste the script below:

    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTPS} =on
    RewriteRule .* - [E=W3TC_SSL:_ssl]
    RewriteCond %{SERVER_PORT} =443
    RewriteRule .* - [E=W3TC_SSL:_ssl]
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteRule .* - [E=W3TC_ENC:_gzip]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} =""
    RewriteCond %{REQUEST_URI} \/$
    RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|w3tc_logged_out|wordpress_logged_in|wptouch_switch_toggle) [NC]
    RewriteCond "%{DOCUMENT_ROOT}/bismillah/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" -f
    RewriteRule .* "/bismillah/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache core

    Don't forget to setting the permalink on wp as see on http://www.youtube.com/watch?v=LVteYk-rG-A

    and re-activated the better wp security... its working!

  22. Noer Pangripto
    Member
    Posted 6 months ago #

    after installed w3 total cache i feel my website loading page getting faster. its below 5 second. its a great plugin. may be you can visit my website http://www.batikriau.com

  23. Mitesh Ganatra
    Member
    Posted 5 months ago #

    Folks,

    Need to add the following line in "wp-config.php" that will resolve the issue:
    /** Enable W3 Total Cache */ define('WP_CACHE', true); // Added by W3 Total Cache

    Kind regards,
    http://miteshganatra.com

  24. daklists
    Member
    Posted 3 months ago #

    Added this line below but I am still having issues:

    /** Enable W3 Total Cache */ define('WP_CACHE', true); // Added by W3 Total Cache

    I have Deactivated and Deleted W3 Total Cache and then re-installed.

    Any other ideas?

    Thanks for the info!

  25. Se7enTime
    Member
    Posted 3 months ago #

    Try to Deactivate iThemes Security, and Activate Again, and Voila! Error Message has gone . . .

    *me

  26. sixthlife
    Member
    Posted 3 months ago #

    ok

  27. negocioscadiz
    Member
    Posted 2 months ago #

    Gracias por el post,me habeis aclarado algunas dudas en la que tenia en mi web , saludos.

    mi web http://negocioscadiz.net

  28. daklists
    Member
    Posted 2 months ago #

    Se7enTime, thanks for the post. That did the trick!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic