WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
W3 Total Cache doesn't seem to be speeding up my site (5 posts)

  1. mv5869
    Member
    Posted 2 years ago #

    My wordpress site runs on the Suffusion them and I am using W3 Total Cache to reduce the load on the hosting servers. Does anyone have any suggestions for how to optimise it? I want to be able to serve static pages to most users, without any php calls.

    I really don’t know if Total Cache is working. It shows up in the source code, but my page still takes 7 seconds to load. See http://tools.pingdom.com/?url=http://www.liverpoollatest.co.uk/&treeview=0&column=objectID&order=1&type=0&save=true

    What are the best ways to reduce the load using W3 Total Cache?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. tgeorge
    Member
    Posted 2 years ago #

    In the General tab of W3TC, enable "Page cache", "Minify" and "Browser cache". In the same tab, disable "Database cache" and "Object cache". I believe those are safe settings.

    Ping tools are not the best tool to analyze speed problems. Try "Google Page Speed"

    http://pagespeed.googlelabs.com/

    which should give you specific suggestions. Image optimisation for example is important (it's not related to W3TC).

  3. johnflufin
    Member
    Posted 2 years ago #

    Depending on your W3TC settings and theme related files, it's possible you may not see much if any improvement.

    Also keep in mind that the default W3TC settings disable page cache and I think minify for logged in users (click "Preview" on the General page to preview settings while logged in).

    Also, also make sure that your W3TC settings have been deployed to the live site so users can take advantage (click "Deploy" on the General page). Upon activating W3TC for the first time, I'm pretty sure W3TC is in preview mode and the settings won't take affect until you deploy them. BTW, I usually disable preview mode to avoid this problem but doing so means you're making live changes so do so at your own risk. I only do this if I'm confident in the settings I'm using or updating.

  4. photon-x
    Member
    Posted 2 years ago #

    I too use Suffusion,
    I also find that setting Page Cache to Basic helps on my site.

    BTW, you've got quite a lot on your home page; you might try using the Excerpts settings in Suffusion to reduce how much must be loaded on the Home page.

  5. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    @tgeorge +1

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic