WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache Custom file list "Source file not found" (7 posts)

  1. esmandau
    Member
    Posted 1 year ago #

    I'm using the latest version of W3 Total Cache plugin on my WP installation. Everything is working except that when i try to put a folder or file on the "custom file list" box, it always pop up an error that says "Source file not found".

    The path is correct, there's no reason for it to show that.

    Any clues? Somebody has this problem?

  2. Robin-wedding-photographer
    Member
    Posted 1 year ago #

    Same problem here. Any solution?

  3. Frederick Townes
    Member
    Posted 1 year ago #

    Could you post the paths you added to the custom file list?

    They should be from docroot and one per line. similar to what is in the textarea by default.

    Also which CDN are you using?

  4. esmandau
    Member
    Posted 1 year ago #

    I'm using Amazon Cloudfront.

    i was trying to do so with several plugins... but i change to a more robust theme and dont need them anymore.

    Thanks anyway for the help.

  5. sliceofpie
    Member
    Posted 1 year ago #

    I'm having the same (or similar) issue with custom files --

    This is the path I put in the "Custom file list":
    wp-content/uploads/userphoto/*

    When attempting to do "Custom files export", w3tc successfully finds all the files in this folder, and lists the correct paths, but says "Source file not found" next to each. I've messed with chmoding, chowning, etc, and it does not appear to be a permissions problem. I am using Rackspace Cloud Files, and uploading attachments and theme files, etc, are working perfectly (thank you!)

    wp-content/uploads/userphoto/1.jpg Source file not found.

    Any tips? Thanks!

  6. Fahim Mahmood
    Member
    Posted 1 year ago #

    i am having the same problem any update on this issue ?? In my case i have following bucket directory:

    mybucket/foldername/wp-content
    mybucket/foldername/wp-includes

    It uploaded the themes or attachment files in their respective folder but when i uploaded the custom files it created a new folder on my bucket root so it becomes like

    mybucket/wp-content/

    i don't know why it doesn't uploaded the custom files to the same wp-content folder where theme files and uploads are stored.

    that was the reason when i open my website it try to access the plugins from
    mybucket/foldername/wp-content/plugins

    which is not correct because it uploads the plugins files to

    mybucket/wp-content/plugins

  7. AllenPayne
    Member
    Posted 1 year ago #

    I'm having the same problem and it's driving me crazy. I've been trying to make it work for hours.

    When i open the Custom Files Export page the total number of files is displayed correctly but when i click on the Start button it says "Source file not found" next to each.

    Did anyone find a solution????

    I would really appreciate your any help. Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic