WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache cause to comprehensive google map stop working (20 posts)

  1. alex80ks
    Member
    Posted 2 years ago #

    both plugins are latest and when i activate minify option for js in total cache plugin my map wont load so anyone have solution?

  2. Turismo in
    Member
    Posted 2 years ago #

    Same problem, who can help us?

  3. ditler
    Member
    Posted 2 years ago #

    Same problem here. The map stay in the circling "L O A D I N G" state

  4. alex80ks
    Member
    Posted 2 years ago #

    Guess nobody from plugin developers didnt show up :P
    I have solved problem but you ppl can try as i did...
    HTML minify settings: Enable
    Inline CSS minification checked
    Inline JS minification checked
    Don't minify feeds checked
    Line break removal checked

    or turn of html xml minify

    those two should be solve problem as i did.

  5. ditler
    Member
    Posted 2 years ago #

    The first did not work for me. The latter, turning off HTML/XML Minify, is not an option. Does anybody know a Maps Plugin, that works with Total Cache?

    Thank you

  6. alex80ks
    Member
    Posted 2 years ago #

    then try step two...
    turn on manual and add all scripts for minifying then remove one and return it until you find right one.

  7. alex80ks
    Member
    Posted 2 years ago #

    i will try to help a bit to see what i have removed from minify on manual

  8. alex80ks
    Member
    Posted 2 years ago #

    JS and CSS only checked fields are Enable and nothing more...
    JS script all embeded in head and just http://connect.facebook.net/sr_RS/all.js embeded ater body...
    CSS try to remove this script wp-content/plugins/rpx/files/stylesheet.css and i think that should work...by the way im using buddypress...

  9. alex80ks
    Member
    Posted 2 years ago #

    and i excluded my child theme style.css also...i hope that will be helpfull :)

  10. Frederick Townes
    Member
    Posted 2 years ago #

    So did people manage to resolve this?

  11. ditler
    Member
    Posted 2 years ago #

    don't know, i just banned google maps altogether, so at least for me it is no problem anymore

  12. Frederick Townes
    Member
    Posted 2 years ago #

    Anyone else?

  13. alex80ks
    Member
    Posted 2 years ago #

    ditler you can mail me credentials to fix that if is possible :) i fixed for me maybe i can for u

  14. ditler
    Member
    Posted 2 years ago #

    thank you, maybe you can post it here for the future or for Frederick - I on my part do not need it, I banned the maps for performance reasons and lack of usage.

  15. alex80ks
    Member
    Posted 2 years ago #

    running away from the problem isnt solution :) need to be patient and try all solutions :) i was thinking about that problem.Ussualy there is some plugin also that makes problems.I haved with better wp security first then i tested all possibility and find solution then i posted here then i added totac cache and i go manually adding and removing scripts until i found solution.it need time an persistance but can be possible :)

  16. kennytheecat
    Member
    Posted 1 year ago #

    My maps were not working either. The solution for me was just unchecking Inline JS minification in the minify section

  17. quoidautre
    Member
    Posted 1 year ago #

    Hi,
    For me, it's work fine when I disable "JS minify settings:" in the minify section.

    Disable just the "inline js minification" doesn't work.

    Fabrice

  18. classius
    Member
    Posted 1 year ago #

    After playing around with W3 Total Cache settings for a while this is how I got the comprehensive google map plugin to stop getting stuck on loading:

    General Settings
    - Enable Manual Minify mode

    Minify - General
    - Disable Rewrite URL structure

    Minify - HTML & XML
    - Enable ALL HTML minify options

    Minify - JS
    - Enable JS minify settings (first thickbox only)
    - Add theme scripts to JS file management
    IMPORTANT: delete any Jquery scripts from list!

    Minify - CSS
    - Enable CSS minify settings (first thickbox only)
    - Add theme style sheets to CSS file management

    Save all settings and enable minify in general settings.

    See it in action here: http://vibesandscribes.ie/locations

  19. dragonmac
    Member
    Posted 1 year ago #

    Same problem with
    WP Minify
    This plugin uses the Minify engine to combine and compress JS and CSS files to improve page load time.
    Version 1.2.0 | By Thaya Kareeson

    Only Setting was for Minify HTML,
    CSS and JS where off

  20. Michael Ecklund
    Member
    Posted 1 year ago #

    Upgraded both plugins to latest versions.

    Dashboard -> Performance -> Minify -> Rewrite URL structure (UNCHECK) -> Save all settings.

    Remember to empty "page cache" afterwards.

    I had the same problem... Map is displaying / functioning correctly again.

Topic Closed

This topic has been closed to new replies.

About this Topic