WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache - Cached Files Output with Bizarre encoding (5 posts)

  1. roborracle
    Member
    Posted 1 year ago #

    I've searched high low for a solution to my problem, but there doesn't seem to be anything that helps. I've looked at Stack Overflow, the forums on WordPress.org, among other places to no avail.

    I'm trying to get W3 Total Cache set up and working, and after working on it for a week now, I can't seem to find the root of why all the pages that are cached using this plugin are output in some bizarre format completely breaking and disabling my theme.

    I can't even get past this to see what else is broken to see if this plugin is even working.

    My CDN is Rackspace Cloud Files and I can confim that those files do NOT have the same bizarre encoding that the output files have.

    The site is hosted on Rackspace Cloud Sites as well (and I know they recommend WP Super Cache against W3 Total Cache. WP Super Cache was not an option due to bugs with their recommended CDN plugin).

    Does anyone have any ideas on this? Have you had the same issue? What was your resolution?

  2. wetchman
    Member
    Posted 1 year ago #

    Same issue here. I'll be watching to see if anyone has input as well.

    I don't have a site of much importance running with this, but I disabled the plugin and things work fine now. It's on DreamHost's basic shared plan.

    My site uses a Headway Themes theme that I configured. While I'm not doing anything with Headway anymore, the site worked fine and lets my client do what they wanted to do. I wonder if Headway or the theme has anything to do with the garbage being output.

    What theme are you using? Custom? Purchased? Part of a framework or stand-alone?

  3. M Asif Rahman
    Member
    Posted 1 year ago #

    What you guys mean by garbage output? Could you show us live links or screen shots and are you using Minify? What kind of setting you are using? Also server environment is also another matter we need to understand. is it Apache or something else?

  4. cbkerndter
    Member
    Posted 1 year ago #

    I had the same problem an could narrow it down to page cache (advanced) switching to basic resolved the problem for me

  5. robnalexpress
    Member
    Posted 1 year ago #

    See this thread. If it's the same issue, there's a temporary fix:

    Add:

    AddDefaultCharset utf-8

    to your htaccess file in the wp-content/cache/page_enhanced folder.

    Rob

Topic Closed

This topic has been closed to new replies.

About this Topic