WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: W3 Total Cache] - 500 Internal Server Error.. (7 posts)

  1. ezzal
    Member
    Posted 4 years ago #

    Hi, fredericktownes
    First of all thanks for your support on W3TC.I like it a lot !

    My site is : Ezzal - Free Online Games
    I was using the W3 Total Cache Beta version with WordPress 3 that I got from your mail.

    And just today I noticed the new version notice, so I tried to upgrade it automatically and It asked me to overwrite the .htaccess file. So I did..
    but now I'm getting "500- Internal Server Error" all around my site.
    Then I tried to change the .htaccess back to default and used Disk Cache for page cache and it works normally.
    It shows error only when I use "Disk Enhanced" method.

    I tried to edit the contents of .htacess manually too.. same problem.

    Can you please help me to solve this ? I used "Disk Enhanced" method without any problem with the "beta" version.. so I want to use the "Enhanced" method again.I know that my server supports it. I use a VPS from http://www.vps.net

    Please help.

    Thank you.

    I noticed this block in htaccess is giving error (used for Enhanced mode ?)

    # BEGIN W3TC Page Cache
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteCond %{HTTP_USER_AGENT} (iPhone|iPad|iPod|Android|BlackBerry9530|LG-TU915 Obigo|LGE VX|webOS|Nokia5800) [NC]
        RewriteRule .* - [E=W3TC_UA:_touch]
        RewriteCond %{HTTP_USER_AGENT} (2.0 MMP|240x320|ASUS|AU-MIC|Alcatel|Amoi|Audiovox|AvantGo|BenQ|Bird|BlackBerry|Blazer|CDM|Cellphone|DDIPOCKET|Danger|DoCoMo|Elaine/3.0|Ericsson|EudoraWeb|Fly|HP.iPAQ|Haier|Huawei|IEMobile|J-PHONE|KDDI|KONKA|KWC|KYOCERA/WX310K|LG|LG/U990|Lenovo|MIDP-2.0|MMEF20|MOT-V|MobilePhone|Motorola|NEWGEN|NetFront|Newt|Nintendo Wii|Nitro|Nokia|Novarra|O2|Opera Mini|Opera.Mobi|PANTECH|PDXGW|PG|PPC|PT|Palm|Panasonic|Philips|Playstation Portable|ProxiNet|Proxinet|Qtek|SCH|SEC|SGH|SHARP-TQ-GX10|SPH|Sagem|Samsung|Sanyo|Sendo|Sharp|Small|Smartphone|SoftBank|SonyEricsson|Symbian|Symbian OS|SymbianOS|TS21i-10|Toshiba|Treo|UP.Browser|UP.Link|UTS|Vertu|WILLCOME|WinWAP|Windows CE|Windows.CE|Xda|ZTE|dopod|hiptop|htc|i-mobile|nokia|portalmmm|vodafone) [NC]
        RewriteRule .* - [E=W3TC_UA:_mobile]
        RewriteCond %{HTTPS} =on
        RewriteRule .* - [E=W3TC_SSL:_ssl]
        RewriteCond %{SERVER_PORT} =443
        RewriteRule .* - [E=W3TC_SSL:_ssl]
        RewriteCond %{HTTP:Accept-Encoding} gzip
        RewriteRule .* - [E=W3TC_ENC:.gzip]
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{REQUEST_URI} \/$
        RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register|mail)\.php|wp-.*\.php|index\.php|submit-a-game|contact-us) [NC,OR]
        RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
        RewriteCond "/home/ezzalco/public_html/wp-content/w3tc/pgcache/$1/_index%{ENV:W3TC_UA}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" -f
        RewriteRule (.*) "/wp-content/w3tc/pgcache/$1/_index%{ENV:W3TC_UA}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache

    Compatibility check shows this
    ===============================

    Server Modules & Resources:
    PHP Version: 5.2.9
    PHP Timezone: Not set
    Web Server: Apache
    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: OK (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Mimetype
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected
    WordPress Resources
    /home/xxxx/public_html/wp-content: Write-able
    /home/xxxx/public_html/.htaccess Write-able
    
    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off

    This is the htaccess code block that I before (beta version)

    # BEGIN W3TC Page Cache
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{REQUEST_URI} \/$
        RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register|mail)\.php|wp-.*\.php|index\.php) [NC,OR]
        RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
        RewriteCond %{HTTP_USER_AGENT} (2\.0\ MMP|240x320|ASUS|AU-MIC|Alcatel|Amoi|Audiovox|AvantGo|BenQ|Bird|BlackBerry|Blazer|CDM|Cellphone|DDIPOCKET|Danger|DoCoMo|Elaine/3\.0|Ericsson|EudoraWeb|Fly|HP\.iPAQ|Haier|Huawei|IEMobile|J-PHONE|KDDI|KONKA|KWC|KYOCERA/WX310K|LG|LG/U990|Lenovo|MIDP-2\.0|MMEF20|MOT-V|MobilePhone|Motorola|NEWGEN|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Novarra|O2|Opera\ Mini|Opera\.Mobi|PANTECH|PDXGW|PG|PPC|PT|Palm|Panasonic|Philips|Playstation\ Portable|ProxiNet|Proxinet|Qtek|SCH|SEC|SGH|SHARP-TQ-GX10|SPH|Sagem|Samsung|Sanyo|Sendo|Sharp|Small|Smartphone|SoftBank|SonyEricsson|Symbian|Symbian\ OS|SymbianOS|TS21i-10|Toshiba|Treo|UP\.Browser|UP\.Link|UTS|Vertu|WILLCOME|WinWAP|Windows\ CE|Windows\.CE|Xda|ZTE|dopod|hiptop|htc|i-mobile|nokia|portalmmm|vodafone) [NC]
        RewriteRule .* - [E=W3TC_UA:_mobile]
        RewriteCond %{HTTP_USER_AGENT} (iPhone|iPad|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800) [NC]
        RewriteRule .* - [E=W3TC_UA:_touch]
        RewriteCond %{HTTPS} =on
        RewriteRule .* - [E=W3TC_SSL:_ssl]
        RewriteCond %{SERVER_PORT} =443
        RewriteRule .* - [E=W3TC_SSL:_ssl]
        RewriteCond %{HTTP:Accept-Encoding} gzip
        RewriteRule .* - [E=W3TC_ENC:.gzip]
        RewriteCond "/home/amint/public_html/wp-content/w3tc/pgcache/$1/_index%{ENV:W3TC_UA}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" -f
        RewriteRule (.*) "/wp-content/w3tc/pgcache/$1/_index%{ENV:W3TC_UA}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache

    AND I noticed this sometimes in the error log.. maybe 3-4 times per day with beta release and now more often.

    [23-Jul-2010 11:52:41] PHP Fatal error:  Allowed memory size of 33554432 bytes exhausted (tried to allocate 266990 bytes) in /home/xxx/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 223

    Please tell me about that too.

  2. ezzal
    Member
    Posted 4 years ago #

    I didnt change any Mobile user agents settings because I don't use them for now..

    And I tried to remove these lines from public_html/.htaccess

    RewriteCond %{HTTP_USER_AGENT} (iPhone|iPad|iPod|Android|BlackBerry9530|LG-TU915 Obigo|LGE VX|webOS|Nokia5800) [NC]
        RewriteRule .* - [E=W3TC_UA:_touch]
        RewriteCond %{HTTP_USER_AGENT} (2.0 MMP|240x320|ASUS|AU-MIC|Alcatel|Amoi|Audiovox|AvantGo|BenQ|Bird|BlackBerry|Blazer|CDM|Cellphone|DDIPOCKET|Danger|DoCoMo|Elaine/3.0|Ericsson|EudoraWeb|Fly|HP.iPAQ|Haier|Huawei|IEMobile|J-PHONE|KDDI|KONKA|KWC|KYOCERA/WX310K|LG|LG/U990|Lenovo|MIDP-2.0|MMEF20|MOT-V|MobilePhone|Motorola|NEWGEN|NetFront|Newt|Nintendo Wii|Nitro|Nokia|Novarra|O2|Opera Mini|Opera.Mobi|PANTECH|PDXGW|PG|PPC|PT|Palm|Panasonic|Philips|Playstation Portable|ProxiNet|Proxinet|Qtek|SCH|SEC|SGH|SHARP-TQ-GX10|SPH|Sagem|Samsung|Sanyo|Sendo|Sharp|Small|Smartphone|SoftBank|SonyEricsson|Symbian|Symbian OS|SymbianOS|TS21i-10|Toshiba|Treo|UP.Browser|UP.Link|UTS|Vertu|WILLCOME|WinWAP|Windows CE|Windows.CE|Xda|ZTE|dopod|hiptop|htc|i-mobile|nokia|portalmmm|vodafone) [NC]
        RewriteRule .* - [E=W3TC_UA:_mobile]

    and now it works.
    But I'm not sure whats wrong.. Am I doing something wrong ?

    using these lines from old beta version also not giving any errors..

    RewriteCond %{HTTP_USER_AGENT} (2\.0\ MMP|240x320|ASUS|AU-MIC|Alcatel|Amoi|Audiovox|AvantGo|BenQ|Bird|BlackBerry|Blazer|CDM|Cellphone|DDIPOCKET|Danger|DoCoMo|Elaine/3\.0|Ericsson|EudoraWeb|Fly|HP\.iPAQ|Haier|Huawei|IEMobile|J-PHONE|KDDI|KONKA|KWC|KYOCERA/WX310K|LG|LG/U990|Lenovo|MIDP-2\.0|MMEF20|MOT-V|MobilePhone|Motorola|NEWGEN|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Novarra|O2|Opera\ Mini|Opera\.Mobi|PANTECH|PDXGW|PG|PPC|PT|Palm|Panasonic|Philips|Playstation\ Portable|ProxiNet|Proxinet|Qtek|SCH|SEC|SGH|SHARP-TQ-GX10|SPH|Sagem|Samsung|Sanyo|Sendo|Sharp|Small|Smartphone|SoftBank|SonyEricsson|Symbian|Symbian\ OS|SymbianOS|TS21i-10|Toshiba|Treo|UP\.Browser|UP\.Link|UTS|Vertu|WILLCOME|WinWAP|Windows\ CE|Windows\.CE|Xda|ZTE|dopod|hiptop|htc|i-mobile|nokia|portalmmm|vodafone) [NC]
    RewriteRule .* - [E=W3TC_UA:_mobile]
    RewriteCond %{HTTP_USER_AGENT} (iPhone|iPad|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800) [NC]
    RewriteRule .* - [E=W3TC_UA:_touch]

    This is what i get from Debug Info.

    <!-- W3 Total Cache: Minify debug info:
    Engine:             disk
    Theme:              xxxxx
    Template:           index
    --> 
    
    <!-- W3 Total Cache: Object Cache debug info:
    Engine:             disk
    Total calls:        1520
    Cache hits:         1520
    Cache misses:       0
    W3TC Object Cache info:
        # |    Caching (Reject reason)     |     Status      |     Source      | ID:Group
        1 |            enabled             |     cached      |   persistent    | is_blog_installed:default
    
    .......................
    a list here......
    ...........................
    
    --> 
    
    <!-- W3 Total Cache: Db cache debug info:
    Engine:             disk
    Total queries:      30
    Cached queries:     1
    Total query time:   1.521
    SQL info:
    xxxxxxxx---- some query lists here xxxxxxxxxxxxxxxxxxxxxxxx
    
    --> 
    
    <!-- W3 Total Cache: Page cache debug info:
    Engine:             disk (enhanced)
    Key:                _index.html
    Caching:            enabled
    Status:             cached
    Creation Time:      0.004s
    Header info:
    X-Powered-By:       PHP/5.2.9
    Last-Modified:      Fri, 23 Jul 2010 03:39:44 GMT
    Vary:               Accept-Encoding, Cookie
    Expires:            Fri, 23 Jul 2010 04:39:44 GMT
    Pragma:             public
    Cache-Control:      public, must-revalidate, proxy-revalidate
    Etag:               7caf0bdb3027e0f5ed58a0c777e3de69
    Content-Encoding:   gzip
    -->
  3. ezzal
    Member
    Posted 4 years ago #

    Ok.. now I got it working by removing all user agents list in W3TC settings panel..
    I think I got the hint after reading this from the settings page
    "Specify the user agents for this group. Remember to escape special characters like spaces, dots or dashes with a backslash. Regular expressions are also supported."

    Don't know why those characters are not escaped in default installation, and it worked before without any problems.
    (Maybe because I used a development version and Upgraded)
    A fresh re- / installation may have no problems.
    Hope this helps someone else who is having same problem.

    Anyways frederick, please reply and confirm I'm in the correct way now.
    Now I've used all non edited default htaccess files from W3TC and only deletede the user agents list.

  4. robertstaddon
    Member
    Posted 4 years ago #

    I believe I had the same problem. I traced it back to the fact that the automatic upgrade did not upgrade the advanced-cache.php, db.php, and object-cache.php files in the wp-content directory. When I manually upgraded these, the plugin began escaping characters correctly in the .htaccess file.

  5. thatruth2006
    Member
    Posted 4 years ago #

    Having same issue, as soon as I activate this plugin I get a content encoding error, even after I turn off browser caching. Also, I noticed the the plugin has its own wp-content/directory and it has two copies of advanced-cache.php, db.php, and object-cache.php, is that a correct installation?

  6. blau
    Member
    Posted 4 years ago #

    thatruth2006: the installation process should copy wp-content/plugins/w3-total-cache/wp-content/* to wp-content/

    You can do it manually if you want.

  7. Frederick Townes
    Member
    Posted 4 years ago #

    I noticed the the plugin has its own wp-content/directory and it has two copies of advanced-cache.php, db.php, and object-cache.php, is that a correct installation?

    Yes those files exist there to be copied to the actual wp-content/ directory in your site.

Topic Closed

This topic has been closed to new replies.

About this Topic