WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Voting
Voting on popup (18 posts)

  1. SlickVicENT
    Member
    Posted 11 months ago #

    Voting on popup is not working for me... the only way I can get it to work is by inserting tag <?php echo nggv_imageVoteForm($image->pid); ?> in the gallery.php template then voting is available on thumbnail and the first 2 pics on popup while going through pics. I have tried nextgen 1.9 and 2.0 and its the same.

    I have spoke to Shauno about this but we got cut off on what to do next when I explained what I have done so far. The last we left off was take out tag from template if I dont want it to show up for thumbnails. I did that and voting doesnt come up on popup.

    Now what?

    http://www.SlickVicPhotography.com

    http://wordpress.org/plugins/nextgen-gallery-voting/

  2. shauno
    Member
    Plugin Author

    Posted 11 months ago #

    Hey man

    Sorry about that last thread, it turned into a free for everyone's questions, and yours got lost. I'm not in front of my dev machine right now, but I will have a look at this as soon as I get a chance.

    I know I had a temp login to your site at one point, is that still active? Just in case everything is correct on my test installs, and I need to check conflicts on your site directly?

  3. SlickVicENT
    Member
    Posted 11 months ago #

    Yup still active...

    Yup thats my fault... I should of known better to continue asking questions on a thread that wasn't mine.

  4. shauno
    Member
    Plugin Author

    Posted 11 months ago #

    I've found the problem with voting in the popup. It is because NGG have changed the markup structure of that template, and the voting plugin was using the old structure to figure out the image id. There is a quick fix for now:
    Change line 46 of the gallery template from:
    <div id="<?php echo_h('ngg-image-' . $i) ?>" class="ngg-gallery-thumbnail-box" <?php if ($style) echo $style; ?>>

    to this:
    <div id="<?php echo_h('ngg-image-' . $image->pid) ?>" class="ngg-gallery-thumbnail-box" <?php if ($style) echo $style; ?>>

    I see the new NGG markup does have the image id elsewhere, so I will try patch NGG Voting Premium to find the new markup, and release an update at some point.

    Hope that helps!

  5. SlickVicENT
    Member
    Posted 11 months ago #

    And I assume I should remove the tag <?php echo nggv_imageVoteForm($image->pid); ?> from the gallery.php template?

  6. SlickVicENT
    Member
    Posted 11 months ago #

    Is this change in 1.9 ? or 2.0 ?

  7. SlickVicENT
    Member
    Posted 11 months ago #

    I disabled all my galleries after this change

  8. SlickVicENT
    Member
    Posted 11 months ago #

    I tried putting back to original and still galleries are not there

  9. SlickVicENT
    Member
    Posted 11 months ago #

    I made the change on both 1.9 and 2.0 and still no bueno... I even inserted tag <?php echo nggv_imageVoteForm($image->pid); ?> and I have the same issue with thumbnails and just a few popups with voting capabilities and then it disappears

    I'm leaving nextgen 2.0 active not going back to 1.9 for now.

  10. shauno
    Member
    Plugin Author

    Posted 11 months ago #

    NGG V2 is fine, you just need to make sure you are editing the correct template (they have gone crazy with the folder structure in v2).
    My user on your site doesn't seem to to have permission anymore, can you just grant the access again. Please also just let me know which page you are using to test, so I can check it out.

  11. SlickVicENT
    Member
    Posted 11 months ago #

    Shauno I just gave you admin rights

    I updated the index.php in nextgen V2 on line 46 like you stated above

  12. SlickVicENT
    Member
    Posted 11 months ago #

    Oh wow admin rights wouldnt matter because the files have to be updated in cpanel.... shucks

    Well anyway you should have access to login and see whatever you need to see and tell me what I should change or whats wrong

  13. SlickVicENT
    Member
    Posted 11 months ago #

    sent you an email with index.php so you can see what it looks like after the update you mentioned above

  14. shauno
    Member
    Plugin Author

    Posted 11 months ago #

    Ok, I'm an idiot :) I see you've been saying it works fine, until you remove the voting tag from the template. You have to have the voting tag in the template for the popup voting to work. I think I might have said you didn't in another thread, but re-looking at the code now, you definitely need to have the voting tag in the template.

    The good news is, you can add the following rule to your CSS, and it will hide the voting in your template, but still show it in the popup:

    .ngg-galleryoverview .nggv_container {
        display: none;
    }

    Sorry again for the confusion man, my mistake.

  15. SlickVicENT
    Member
    Posted 11 months ago #

    Ok I put it in the css and thumbnails don't have voting capabilities but I still have the problem where voting disappears after the 2 photo on popup view. I have to close popup view and reopen every 3rd photo for voting to popup again. Why is this?

  16. shauno
    Member
    Plugin Author

    Posted 11 months ago #

    I see that only happens when I use Chrome on your site. It works fine in FireFox. It seems to be fine on my test installs, but let me test a bit more and see if I can see what's happening.
    I will let you know once I know more

  17. SlickVicENT
    Member
    Posted 11 months ago #

    Awesome... you the best!! Thanks for all the help.

  18. shauno
    Member
    Plugin Author

    Posted 11 months ago #

    Hey man
    I'm trying to find the issue, but I cannot replicate it at all. Your site also seems to work fine on my FireFox, but some some random reason, Chrome just won't call the ajax to get the voting form after the 2nd time.
    Please reactivate my admin rights, so I can add some debug code directly on your site (I will keep it as discreet as possible, to not disrupt your legit site users).

Reply

You must log in to post.

About this Plugin

About this Topic