WordPress.org

Ready to get started?Download WordPress

Forums

WP-PostRatings
[resolved] Voting multiple times using refresh (11 posts)

  1. azazure
    Member
    Posted 1 year ago #

    With version 1.72 a user can vote repeatedly by using the refresh button. Even leaving the page or logging out will still allow a user to vote again once they return to the post. How do I correct this? Thanks!

    http://wordpress.org/extend/plugins/wp-postratings/

  2. amacrae@macrae.net
    Member
    Posted 1 year ago #

    I've found this to be true under Safari and Firefox.

  3. azazure
    Member
    Posted 1 year ago #

    Yes, I was using Firefox - I didn't think it might be specific to the browser. I love the plugin, but this is kind of a big deal so hope there's a fix or work-around.

  4. Artem Gordinsky
    Member
    Posted 1 year ago #

    I have the same issue when logging method is set to "username".

  5. Artem Gordinsky
    Member
    Posted 1 year ago #

    Turns out, it's just a misplaced/mistyped variable in the check_rated_username function in wp-postratings.php file. Simply replace $rating_userid with $user_ID at the end of the line beginning with "$get_rated =...".

  6. m0ngr31
    Member
    Posted 1 year ago #

    Thanks! That solved a problem I was having.

  7. azazure
    Member
    Posted 1 year ago #

    Thank you, thank you! It works.

  8. Artem Gordinsky
    Member
    Posted 1 year ago #

    You're welcome, guys!

  9. Lester Chan
    Member
    Plugin Author

    Posted 11 months ago #

    Thank you Artem!

    Thank you @akinadebowale for bringing this up to me, fix it in 1.74 (will waiting for more bugs reports/fixes before releasing it)

    GitHub Issue: https://github.com/lesterchan/wp-postratings/issues/9
    Changeset: https://github.com/lesterchan/wp-postratings/commit/d9eadb96045a081261e34774e04e838b636bd00c

  10. jardokraka
    Member
    Posted 11 months ago #

    Unfortunately, this solution doesn't work for me, pls see my report here.

  11. jardokraka
    Member
    Posted 11 months ago #

    v1.74 has fixed this for me, thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.