WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Voting
[resolved] Voting Does Not Register and Opens Image (7 posts)

  1. coolbaboon2013
    Member
    Posted 1 year ago #

    At some point in the last few weeks the voting mechanism stopped working. I have tried deleting and reinstalling, searching support, and verified the settings are correct.

    1. Choosing a numerical value does not update, no vote is cast. I have set these to visible, yet do not even see a vote cast in admin, nextgen gallery images...

    2. It is very easy to open an image instead of cast a vote, one has to hold down the mouse button while selecting the voting number. Even then it sometime opens the image instead of casting a vote.

    These are true for me in both Firefox and Chrome, here is the site:

    http://www.purplepelicanphotography.com/

    http://wordpress.org/extend/plugins/nextgen-gallery-voting/

  2. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    From the FAQ:

    Do not put inside the <a> tag that wraps the image in some of the templates, or the link will conflict with the voting process.

    Guess where you have the voting tag? :)

  3. coolbaboon2013
    Member
    Posted 1 year ago #

    Thanks, this fixes the merging of image and voting, yet the votes do not register on the website or via the admin page for nextgen gallery image voting

  4. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Oh, I see. It looks like a recent update has broken the drop down voting type. I will get a fix out ASAP, but in the mean time, I suggest you use the star rating type.

    Sorry about that, I completely missed the drop down voting while testing that new feature release.

  5. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, I had a quick look to see what went wrong, and it looks like I missed something pretty simple with the drop down voting type. I have added a fix to the 'development version'. Please can you download the dev version from under the 'Other Versions' heading on this page: http://wordpress.org/extend/plugins/nextgen-gallery-voting/developers/.

    Please install that on your site and let me know if it sorts it out? It's getting late in my timezone, so I'm heading to bed. Tomorrow I will check the feedback and push out a new release for everyone.

    Thanks for the feedback, and sorry about the issue.

  6. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    I've released version 2.4.1, with the fix. Please let me know if it solves your issue, or if there are other problems.
    Thanks

  7. coolbaboon2013
    Member
    Posted 1 year ago #

    No worries, thanks shauno! This fixes the issue!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic