WordPress.org

Ready to get started?Download WordPress

Forums

visual/html toggle no longer works in 3.3 (46 posts)

  1. davidbick01
    Member
    Posted 2 years ago #

    Since installing 3.3 I've lost the visual/html toggle on everything. Deactivating all extensions makes no difference. I'm new to this, and stuck
    I've read the troubleshoot post and seen nothing to help.

  2. Did you flush your cache?

    Try a different browser?

  3. sffandom
    Member
    Posted 2 years ago #

    My admin accounts are able to use all functions in WordPress 3.3. The other accounts apparently cannot get anything to work in the dashboard. Anyone can read the articles but Editor-level users cannot post, set preferences, change attributes for articles, etc.

    Have tested this with different browsers, logging out and logging back in, etc.

  4. sffandom
    Member
    Posted 2 years ago #

    For what it's worth, the logged in editors cannot see the new dashboard header/toolbar. I have even tried upgrading an editor to Admin status and it's not helping. The user cannot log out, change Screen Options, Edit Profile, etc.

    The left-side navigation works fine. You can click on anything and the screen changes. But the WP 3.3 dashboard is not there.

  5. sffandom
    Member
    Posted 2 years ago #

    Okay, the issue seems to be resolved by following the directions posted here by user "lewatson".

    1) Switch theme to Twenty Eleven
    2) Edit a post (displays as white pane with red underlines)
    3) Clear cache (press F5)

    Visual editor, tabs and buttons returned at this point in edit post mode.

    4) Switch back to original theme.
    5) Edit post.

  6. davidbick01
    Member
    Posted 2 years ago #

    This routine certainly seems to help. I am on a Mac, and it worked for me when I ran this using Firefox, but the problem remains the same using Safari. I re-ran the whole routine using Safari and no apparent success.

  7. Delete everything in the Safari cache folder. This should be in ~/Library/Caches/Safari/

  8. davidbick01
    Member
    Posted 2 years ago #

    Thanks, but makes no difference. Firefox still works OK.

  9. Kunsang
    Member
    Posted 2 years ago #

    I had the same issue, after I installed the "Use Google Libraries" Plugin as described here everything worked again!

  10. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    I had the same issue, after I installed the "Use Google Libraries" Plugin as described here everything worked again!

    That is because installing Google Libraries forces the cache to clear.

  11. Kunsang
    Member
    Posted 2 years ago #

    I had the same issue, after I installed the "Use Google Libraries" Plugin as described here everything worked again!

    That is because installing Google Libraries forces the cache to clear.

    As far as I know WordPress doesn't have a cache that could be cleared unless you have a cache plugin.

    Also I had many JS errors and now they are gone.

  12. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    If you had js errors perhaps google libraries reinstalled a bad file. It forces the browser cache to clear which for some reason has been a big problem all of a sudden. Glad you got it working though. It seems there are several solutions to the problem.

  13. Kunsang
    Member
    Posted 2 years ago #

    Yes, I think the jquery library was broken but I cleared the browser cache many times before, tried different browser/os combinations and that didn't help.

    I'm also very happy that I got it solved. The Problem occured as I migrated from my local webserver to the live server and I spent the last three days reading through forums and trying to figure it out.

  14. As far as I know WordPress doesn't have a cache that could be cleared unless you have a cache plugin.

    Not WordPress, your browser :/

    See WordPress changed from jQuery 1.6.something to 1.7.1. Now a browser is supposed to go "Oh! That changed! Lemme update my local cached version!" Except for some reason, they're not.

  15. Kunsang
    Member
    Posted 2 years ago #

    Yea thanks, i got that :)

  16. Okay, just making sure.

    I was able to fix the problem by using the following recommendations mentioned above:

    1. Install "use Google Libraries" plugin.
    2. Activate "Twenty Eleven" Theme.
    3. Clear browser cache.
    4. try the tabs, and everything worked.
    5. Switch back to my usual theme, everything still worked!

    I hope this helps.

    From the other thread, David, I understand that did NOT help.

    So we're stuck on JUST Safari... Are you on Snow Leopard? If so, have you rebooted, and UNchecked 'keep apps open'?

  17. mediabaron
    Member
    Posted 2 years ago #

    I noticed that I loose the Visual/HTML tabs when I'm in a lower bandwidth environment. Same for both Safari/Chrome on Mac OSX Lion. So when I'm mobile on an air card I loose it, when at home on broadband it's there. Or maybe it's just the carrier, AT&T? I've had similar problems before with other aspects of visiting a WordPress site from the client side when on my CDMA air card.

  18. lernerleben
    Member
    Posted 2 years ago #

    I just tried the "use Google libraries". It made no difference. Firefox doesn't work for me, either. I am a Mac user. Also tried the browser cache thing. No joy.

    My issues seem to be not just the missing visual editor but also the plugins, incoming links and WordPress blog links throwing up a simple pie out of memory error. Increasing memory to 64m solved the plugins problem but not for incoming links and WordPress blog.

    My problem is not "Life threatening" so am not going to mess my site up by switching off all my plugins. I would recommend to anyone to make a mirror of your site and database and create a new subdomain to test it. That way you can play with the test site until you find out exactly what the problem is and your normal site is left alone. Unless someone finds a solution in the meantime, I will do just that over Christmas.

    My last WordPress version that worked just fine was 3.2.1. The automatic upgrade to 3.3 was when the problems started. Ergo, my first task with my test site will be to try to revert to 3.2.1. If that doesn't work, then I will go for other options.

  19. I noticed that I loose the Visual/HTML tabs when I'm in a lower bandwidth environment.

    mediabaron ... Wow. I wonder if you just nailed something.

    See, I know that comcast recently had a case of the galloping stupids and goobered up SVN so no one could pull plugins from it. I wonder if this is related that a provider is caching.

  20. dwastak54
    Member
    Posted 2 years ago #

    Ok I found a temporary work around. Not a good one but it works. Seems there is a problem with the .htaccess file. If I rename the .htaccess file to 'htaccess' (without the dot) the visual editor works but in order for the edit to work I have to rename the htaccess file back to .htaccess. So I'm guessing this is a wordpress problem in that I know WordPress needs to write to the .htaccess file in particular to edit the permalinks. Is there an easy way to downgrade to 3.2? I know I can just copy my wordpress files from an older version but I think there is some database stuff that happens with 3.3 so I'm not sure this can be done without making some changes to the database.

  21. lernerleben
    Member
    Posted 2 years ago #

    Tried a test version of my site and swopped the wp-admin 3.3 for wp-admin 3.2.1 and it didn't work. In fact it got even worse. Returned to original state without problems.

    The missing visual editor problem in my case is not consistent. Some pages/posts are fine, others only the whited out html pane is available, others I get an "out of memory" error and for one or two I get absolutely nothing, just a white page. However, all pages are available on the public site as before. The problem is only confined to the admin. I believe that certain pages/posts have been "corrupted".

    Removing the dot from the htaccess file is not the right way as it contains (at least in my case) the rewrite_module command.

  22. lernerleben
    Member
    Posted 2 years ago #

    Tried deactivating plugins and then reactivating them one by one.

    Interestingly, the visual editor returned. I then reactivated the first one (Ajax events plugin). Visual editor there.

    The next on the list was Akismet. Then it stopped working. NO attempt to remove folder, clear cache, deactivate all again made any difference. In the test site now ALL pages/posts are missing the visual editor. Just as well it's only the test site.

    Found other posts in which they say set the language in wp-config if it is not set (or set to default ENglish), messing round with the tinymce.js config file. None of them work.

  23. lernerleben
    Member
    Posted 2 years ago #

    Just noticed that all new posts/pages have the visual and HTML editor. It seems only old posts/pages are affected. Hope it holds.

  24. Sebaztian
    Member
    Posted 2 years ago #

    Are there any news on this?

    I'm using a fresh install of 3.3.1 with a new database and the 2 standard plugins after I experienced issues like no visible words in the visual editor or no access to the visual editor at all, and no window for featured image etc.

    It sounds like a javascript problem since all javascript things have issues, but I've tried everything that was suggested here:

    1. unchecked the profile thing that says disable visual editor, which was never checked, so I checked and then unchecked it after
    2. installed google libraries plugin as well as hotfix 0.8
    3. switched themes and cleared cache
    4. updated chrome
    5. cleared browsing and cleared cached on mac under library/cache about 30 times

    I'm starting to become really desperate since I've spend now 4 work days on fixing this issue which affects all of my wordpress installations and I have no idea what to do anymore.

    Any help or advice is highly appreciated!

  25. davidbick01
    Member
    Posted 2 years ago #

    Have you tried using Firefox Sebaztian? The issue remains for me only under Safari.

  26. lernerleben
    Member
    Posted 2 years ago #

    Hi Sebaztian,

    I have experienced problems and all of the solutions offered didn't work. What DOES WORK for me is to change the WordPress language define settings in the wp-config.php file. My problem was that my install language was defined as German and it caused problems. The moment I defined the language as English (or any other language apart from German), the problem went away. As far as I know, there is no language defined in the usual wp-config and so the system defaults to ENglish (I could be wrong).

    Go into the wp-config file and insert:
    define ('WPLANG', 'xx_XX');

    changing xx_XX to the language you want. If there are problems change it to ENglish (en_EN)

    You can see your language setting here:
    http://codex.wordpress.org/Installing_WordPress_in_Your_Language

    According to sources, WordPress is aware of this and is looking into it.

    Hope it works for you!

  27. Sebaztian
    Member
    Posted 2 years ago #

    Hi guys! Thanks so much for your suggestions. I've tried safari, firefox and chrome and also the language thing in the config file on my previous attempts. It just didn't fix anything which is so incredibly frustrating. Not only can't I click on visual anymore, the whole button bar is gone. When clicking on featured image within the edit post window it opens a new window and not the pop up with the dark background.

  28. mediabaron
    Member
    Posted 2 years ago #

    Empty your cache by going to menu Safari>Empty Cache.

    I just had this problem yesterday where the Visual/HTML tabs wouldn't show-up. I Emptied my cache and it came back.

  29. lernerleben
    Member
    Posted 2 years ago #

    Hi Sebaztian,

    Shame it didn't work.

    Do you have the possibility of rebuilding your site and only installing WP 3.2.1. Basically, the problem only arose with 3.3 onwards. Unfortunately, it's too late for me to go back to 3.2.1 (I tried, it didn't work, I think the database had been updated). But my problems are not as big as yours.

    If you could export your pages/posts through WP (but not the settings) and save your images, then create a new folder for the WP install and create a new MySQL database, download 3.2.1 from WP (release archive, look for 3.2.1 just before "3.3.IIS", don't download a beta) and manually install everything, then rebuild your website, it should work. You might have to reinstall all your plugins, perhaps you could just ftp them over?

    A pain, I know.

  30. lernerleben
    Member
    Posted 2 years ago #

    Yeah, try what media baron says first. When you changed your language settings did you reset your browser settings (clearing my safari cache didn't help, resetting everything did)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags