WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "Visual" tab not working in content editor... (13 posts)

  1. s8fagan
    Member
    Posted 1 year ago #

    WIthin the WordPress dashboard under Pages, I'm trying to update some content/text. The view is in "Text" right now and when I try clicking the "Visual" tab, nothing happens. I have WordPress updated and all, my text and coding show in the "Text" section but I'm not good at using it that way!

    What do I need to do to resolve the issue? Thanks!

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. s8fagan
    Member
    Posted 1 year ago #

    Thanks for replying Esmi! I tried your suggestions but that didn't do it. I only have Jet Pack and Hello Dolly running for plugins, I deactivated those, same issue. I then switched to the original theme and I have the same issue editing content there too.

    So still stuck...

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try adding define('SCRIPT_DEBUG', true);to the bottom of your wp-config.php file (just before the require_once line).

  5. s8fagan
    Member
    Posted 1 year ago #

    I'll give that a try Esmi.

    I saw on this page someone suggested installed Google Libraries. I'm not exactly sure what that does but I followed the suggestion and now it works! Is that a simple fix or not a good way to do it?

    http://wordpress.org/support/topic/visual-editor-not-working-after-35-automatic-upgrade

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    That's more usually a solution to a WordPress 3.3 or 3.4 issue but it's worth a shot.

  7. s8fagan
    Member
    Posted 1 year ago #

    Tried that Esmi and received:

    Parse error: syntax error, unexpected ',' in /home/s8fagan/public_html/studio324.org/wp-config.php on line 175

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    You made a mistake adding that line. Remove what you added & try again.

  9. s8fagan
    Member
    Posted 1 year ago #

    You were right, forgot to copy in the "define". Thanks for your patience, I'm a noob to this stuff! I was good with html about 13 years ago but never advanced past that! Ha!

    Anyway, I turned off the Google Libraries bit, pasted in the above, and now the "Visual" tab is working just fine! Thanks!

    Why in the world did that fix it?!

    Thanks again Esmi!

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    Why in the world did that fix it?!

    It's an issue with some servers. In many cases because the server is using mod_pagespeed with a rather restrictive configuration which means that the server cannot parse concatenated javascript. As WP serves concatenated javascript by default (to improve site performance), this causes the site to start acting strangely. The line I gave above forced WP to run in debug mode which means it stops serving concatenated javascripts in favour of human-readable versions.

    Glad to hear that it worked for you.

  11. s8fagan
    Member
    Posted 1 year ago #

    Dang. You're good! Ha!

    Thanks again!

  12. utahman1971
    Member
    Posted 1 year ago #

    This was exactly what I was looking for. Thanks!

  13. carolaword
    Member
    Posted 10 months ago #

    :D Great!!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic