WordPress.org

Ready to get started?Download WordPress

Forums

Visual Rich Editor Not Appearing (20 posts)

  1. brainstorm_indy
    Member
    Posted 8 years ago #

    I have checked the options and made sure that the visual rich editor checkbox is selected (and toggled it to make sure) but my post and edit pages do not show the visual rich editor. I don't get any of the edit tools to show up...in fact, until I saw a post in the forem regarding another issue (with a jpg of the screen) I didn't realize I was missing some critical navigation elements. I have tried to reload the files from the .zip up to my FTP site, but with no luck.

  2. brainstorm_indy
    Member
    Posted 8 years ago #

    Follow-up. I discovered that my wp-includes folder did not transfer across. Once that was in the proper place, everything shows up fine.

  3. storyleader
    Member
    Posted 8 years ago #

    My wp-includes folder is present, but no Visual Rich Editor shows. I'm using Mac OS X. Is this a Windows-only feature?

  4. What browser? Safari? IIRC, it doesn't work with Safari. Try Firefox.

  5. stepheneb
    Member
    Posted 8 years ago #

    I do not get a Visual Rich Text editor using Firefox 1.5 running on MacOS X 10.4.4

    I have WP 2.0.1 installed.

  6. Thad Allender
    Member
    Posted 8 years ago #

    You must enable Javascript.

  7. resiny
    Member
    Posted 8 years ago #

    ugh. you're better off without it

  8. kris_f
    Member
    Posted 8 years ago #

    I have two installations of WP-2.0.2. In one of them the tinyMCE editor appears and in the second one it does not.

    I verified that the wp-includes directory is present and readable. I used the same Firefox browser to test each one, and I verified that the checkbox in my profile for using the rich editor was checked.

    I debugged and solved the problem as follows:

    I used Firefox's Javascript Console to see where the Javascript was breaking: line 1 of the output of tiny_mce_gzip.php. That output was an error message (from the PHP interpreter) rather than Javascript:

    Call to undefined function: file_get_contents() in /var/www/html/wp-includes/js/tinymce/tiny_mce_gzip.php on line 67.

    That error led me to discover that PHP versions older than 4.3 do not support file_get_contents(). I checked the version running on the failing instance and it was 4.2.2.

    Every other function of WordPress was working fine. Only the rich editor was failing to load. It could be fixed by upgrading PHP, but in case that's not possible, it can be worked-around by adding the following near the top of tiny_mce_gzip.php:

    @ require_once('../../functions.php');

    That library (by including functions-compat.php) contains a compatibility function to replace file_get_contents().

  9. ertz
    Member
    Posted 8 years ago #

    Well, seems that i can't enable the rich text editor... It used to work fine, and now all the sudden doesn't work at all. I have JavaScript enabled (using Firefox 1.5). I already tried kris_f's fix with no luck. I'm running WP 2.0.2, I also tried third party WYSISYG editors, such as EditorMonkey which also didn't work (TinyMCE and FCKeditor both failed to load).
    I'm running PHP 4.3...
    I've checked the logical options under my user profile and Options >> Writing...

    Any help would be appreciated

  10. ertz
    Member
    Posted 8 years ago #

    Not sure what did it, but after i disabled the option "Users should use the visual rich editor by default" that's inside Options >> Writing, and enabled the one in my Profile and Personal Options all went ok... The weird thing is that the rich text editor stop loading by itself, i don't remember changing any options that could make the WYSIWYG editor stop working...

  11. ertz
    Member
    Posted 8 years ago #

    missing once again... weird, huh?

  12. mikeall
    Member
    Posted 8 years ago #

    I am having the same problems. I didn't do anything to make it stop and have tried all these options described - all to no avail.
    I have a few sites with WP 2.02 and browse with various web browsers on OSX.
    very annoying as I have to hand code all the links and photos etc.

    Also the Contact Form plugin nolonger works.

  13. simplycolin
    Member
    Posted 8 years ago #

    I've spent about 3 hours trying to find the reason why the Visual Rich Editor wouldn't work on a new install of v2.0.2 on my remote server, and then it clicked: I was attempting to upload text via Safari running on Mac OSX (10.4 update). No sign of the editor icon bar at all, which seemed odd because I'd already used it several times. I'd previously been using Firefox on the Mac!

    I can confirm that the VRE works on the following:

    Internet Explorer (Windows XP)
    Mozilla Firefox (Windows XP)
    Mozilla Firefox (MacOSX)

    It doesn't work on:

    Apple Safari (MacOSX)

    I don't have other browsers, so I don't know how it behaves. Hope that helps!

  14. tela
    Member
    Posted 8 years ago #

    I had the same problem too. The visual rich editor wouldn't appear on a new install of v2.0.2. It didn't work on Firefox, neither IE.
    Kris_f's post hint me to check Firefox's Javascript Console. I didn't get the same error than Kris_f though. In my case it stated:

    illegal character in tiny_mce_gzip.php on line 223
    tinyMCELang['lang_bold_img'] = \"bold.gif\"

    Illegal character pointed to the double quote.

    I retrieved this line in wp-includes/js/tinymce/langs/en.js:

    I used single quotes instead of double quotes. I actually changed for these 3 items:


    tinyMCELang['lang_bold_img'] = 'bold.gif';
    tinyMCELang['lang_italic_img'] = 'italic.gif';
    tinyMCELang['lang_underline_img'] = 'underline.gif';

    That solved my problem. Hope it can help somebody else too.

  15. cyberzeroun
    Member
    Posted 8 years ago #

    I enthusiasticly began a migration from MSN Spaces to WordPress a few days ago.

    Everything was wonderful, until this evening, since the tiny_mce_g_zip.php stop downloading in Iternet Explorer - the status bar below displays dowonloading status with the file name.

    If I refresh, then a blank screen appears.

    My blog being hosted on wordpress.com, I feel powerless to solve the issue my myself. And there was no configuration change on my PC.

    I unchecked the «Use the visual rich editor writing» option, in my profile, as a work around.

    But I would like to continue using that feature.

    Anyone has a clue why it would stop suddenly? Thank you!!!

  16. tansywhisper
    Member
    Posted 8 years ago #

    Well I think each of us has an independant reason why it has turned off, but it's most likely a plugin that we installed. In my case it was the Link Indications Plugin Once I disabled that all was well. The plugin was entering an internal link class into a link that was causing the script to fail.

    Thank you guys for suggesting the JavaScript Console. It had totally slipped my mind but it also explained everything for me.

  17. Michael_
    Member
    Posted 8 years ago #

    Just have seen this topic via referrer.
    In the meantime the issue with TinyMCE is solved in the Link Indication Plugin. I was having an ob_start issue and the solution of Otto solved this problem as well (http://wordpress.org/support/topic/58626).

  18. everysandwich
    Member
    Posted 8 years ago #

    Just in case my minor progress helps. In Safari, I still have nothing, not eve3n quicktaqs. In Firefox I had quicktags but no rich text editor. However, when I called up a stored draft, the rich text editor miraculously opened. I'm glad, because the miles of entries in the javascriipt console were intimidating to me. Anyway, if you have a draft and you're working with Firefox, give it a whirl. Sadly, it didn't work for me in Safari.

  19. billredmond
    Member
    Posted 8 years ago #

    I've had the exact opposite experience, actually. I'm not able to get the visual editor to display under FireFox 1.5 (all JavaScript enabled) for Mac OS X yet Safari works perfectly, even with EditorMonkey plugin.

    I also have a PC and everything on that side seems to be working. Any thoughts as to why only one browser version wouldn't work?

  20. billredmond
    Member
    Posted 8 years ago #

    Update: FireFox had a plugin called "SiteAdvisor" that was interfering; disabling this solved the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.