WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Visual Editor works only if the user is an administrator! (5 posts)

  1. ronald311
    Member
    Posted 2 years ago #

    Hello,

    I'm having an issue with the Visual Editor when I'm trying to create/edit a page: it seems something related with the role of the user because as an "administrator" there's no problem at all but as an "editor" the textarea is apparently empty, I can't enter any text (it seems blocked) and the options "Visual" and "HTML" are not displayed. When I change the role of the user from Editor to Administrator, the visual editor works fine.

    I've tried with "Use Google Libraries" plugin without success. Maybe is the PHP version (I have 5.3.15) or my server doesn't have the right settings? I also unchecked the option "Visual Editor " in the user settings and the problem remains.

    Another issue I'm having with some plugins like "Advanced Access Manager" is that after activation, my website crash and give me "error 500" until I remove the plugin via FTP.

    This is a fresh installation of WordPress 3.4.1 in a new server (LAMP with Centos) and the only change I made was to the httpd.conf file by adding these lines to make the permalinks work correctly:

    <Directory /var/www/html/>
    AllowOverride All
    </Directory>

    I'll appreciate any help about this...thanks!

  2. ronald311
    Member
    Posted 2 years ago #

    What a stupid thing: I changed the value of the "memory allowed" variable in php.ini from 16M to 128M and now everything is working...sorry about this newbie mistake!

  3. pedromvprg
    Member
    Posted 1 year ago #

    Hey, I have the same problem and your solution didn't work for me.
    Also, I don't see how php memory values may have been related with this issue.

    Shouldn't it be disabled for all the users then? Admin included?

    I have no idea what else to do.

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    You're more likely to receive help if you create your own thread.

  5. pedromvprg
    Member
    Posted 1 year ago #

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic