WordPress.org

Ready to get started?Download WordPress

Forums

Visual editor white text without tinyMCE (10 posts)

  1. AWKampen
    Member
    Posted 1 year ago #

    Well, it's taken me several months of looking for a solution, but now, finally, I accept that I simply can't figure this one out. But my intensive search for an answer has tought me a few things about this problem, I just can't seem to put the pieces together. I hope someone here can! Well, here goes:

    The problem:
    When one of my users wants to post something, the editor doesn't show the text. Well, it does, but the text is white.
    - The WYSIWYG tab is selected
    - The HTML tab doesn't work
    - The text, which I can see if I select it, shows me the HTML code

    I have found many possible solutions for this, from changing my .htaccess file to adding a line to the WP-Config file. I've tried finding the plug-in responsible (and even found some, though it wasn't always the same one!). Nothing helped.

    I did find a few other clues though:
    - This only happens to (all of) my users, but not to the Admin. When the Admin logs in, the editor is there, functioning as it should (and yes, the users checked their profile for the editor checkbox!).
    - When I copied the site and the database to another host, the problems had miraculously disappeared. When I imported it offline to a WAMP-server, the problems were also gone!
    - I originally made my site offline with the WAMP-server and all was fine. It went haywire, as soon as I had uploaded it.

    I have contacted my hosting and they use: PHP version 5.3.15, which is one of the newest, for as far as I know.

    My question: What is going on here! It doesn't seem to make any sense!

    I hope someone out there can put the pieces together and help me out.

    If you want to see the problem in action, just go to my site: http://www.blocnoot.nl and register as a new user. Then try to create a new page and you'll see what I mean.

  2. AWKampen
    Member
    Posted 1 year ago #

    Just adding a little bit more information:

    - The 'Screen options' tab, in the top of the screen doesn't do anything
    - Most extra fields that should be on the editor-page (and available under the 'Screen options' tab) simply aren't there!

  3. AWKampen
    Member
    Posted 1 year ago #

    Well, nobody seems to have read this, but my problem remains. I decided to check out which plugins could cause this problem. Quite a few, appearantly. I'll list them here:

    - Co-Authors Plus
    - Fast Secure Contact Form
    - Front-end editor
    - Get Recent Comments
    - Google Analytics Dashboard
    - Subscribe to Comments Reloaded
    - User Role Editor

    I am using the 'Admired' theme and my hosting is running on PHP Version 5.3.15.

    Please, someone, respond! My entire site seems to be falling apart!

  4. AWKampen
    Member
    Posted 1 year ago #

    I couldn't wait, so I decided to try and find alternative plugins for my site. That worked, although several of those plugins still managed to cause a white screen.

    So it's not really a solution, but a workaround.

    I would still like to use some of those plugins though, so if you've got any suggestions, I'd still love to hear them!

  5. craighwk
    Member
    Posted 1 year ago #

    I am having the exact same problem after updating my WordPress. I uninstalled TinyMCE but the problem remains. I re-added it back and it didn't make any difference.

    My symptoms match yours exactly. White lettering in the editor (can't see the text unless I highlight it). Word count does not change, and the extra fields at the bottom of the post page are missing.

    Since I deleted TinyMCE and the problem remains, could you possibly say what other Plugins were messing things up, or was it just TinyMCE?

  6. AWKampen
    Member
    Posted 1 year ago #

    I posted a list of seven plug-ins that messed things up for me. Just scroll up a little! ;-)

  7. craighwk
    Member
    Posted 1 year ago #

    Dang I am blind. Thank you. I don't think I have any of those installed, but I'll check.

  8. AWKampen
    Member
    Posted 1 year ago #

    I somehow think it's not about the plug-ins though. That doesn't make sense, since my site (including all of those seven plugins!!!) does work on a different hosting.
    So I guess it must be something else. A setting in PHP of maybe the MySQL???
    But I hardly know anything about that, which is why I'm posting here, hoping somebody else will! :-(

  9. craighwk
    Member
    Posted 1 year ago #

    I just renamed my plugins folder to plugins.hold, and my editor is still unusable. I can't even type in the box now. :( I think you're right, it's not a plugin problem.

  10. craighwk
    Member
    Posted 1 year ago #

    AWKampen: Try adding:

    define('SCRIPT_DEBUG', true);

    to wp-config.php

    This fixed my problem!

Topic Closed

This topic has been closed to new replies.

About this Topic