WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Visual Editor (TinyMCE) not showing up on 2.9.2 (Linux) (28 posts)

  1. DougJoseph
    Member
    Posted 4 years ago #

    I downloaded the ZIP file for WP 2.9.2 to my Windows PC. I then unzipped it using WinRAR. I get 753 files. I uploaded them all to the Linux server via FTP.

    Yet I cannot see the Visual (TinyMCE) editor.

    I am logging in as Admin.

    I do not have visual editor disabled in my user profile.

    Any ideas?

  2. DougJoseph
    Member
    Posted 4 years ago #

    I have done the following with no luck:

    1. Disabled all plugins.
    2. Used the auto-upgrade feature to reinstall 2.9.2.
    3. Deleted the browser cache for this site (I use the latest Firefox)

    Also, perhaps not coincidentally, I just now tried to turn on Gears (Turbo), and I get an error that pertains to tinymce/plugins/...

    Here is the full error message:

    Turbo: Gears Status

    Gears is installed and enabled on this computer. You can disable it from your browser’s Tools menu.

    If there are any errors try disabling Gears, reloading the page, and re-enabling Gears.

    Local storage status: Error: Download of 'http://wvupci.com/wp-includes/js/tinymce/plugins/fullscreen/fullscreen.htm?ver=327-1235' failed, status code 404.

  3. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    I then unzipped it using WinRAR. I get 753 files.

    Did you retain the folder structure? Have you tried:

    - switching to the default theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    - increasing your available memory?

  4. DougJoseph
    Member
    Posted 4 years ago #

    I found this page with info that indicates I should have a js page at:

    [your site]/wp-includes/js/tinymce/tiny_mce_config.php

    It says that page should display as text if I browse to that URL.

    I get "Error 404 - Not Found" if I try that, and I also cannot find such a file inside my WP files using FTP, and I also cannot find it in the original Zip file of WP 2.9.2

    Anyone know anything that could shed some light on this? Thanks!

  5. DougJoseph
    Member
    Posted 4 years ago #

    ESMI:

    Did you retain the folder structure?

    I retained the folder structure. I pasted it all up via FTP at a single motion. I took note of the file count to make sure all files made it onto the Linux server.

    Have you tried:

    - switching to the default theme to rule out any theme-specific problems?

    It's a new install and I've never left the default theme yet.

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    I can try deleting all the plugins. Will try that next.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    I refreshed the whole install via the auto-upgrade feature. If the above plugin delete does not fix things, I will move to manually deleting and replacing wp-admin and wp-includes folders from a fresh download of WordPress

    - increasing your available memory?

    I am on a hosted Linux server on GoDaddy.com, and I have several WP installs working great on the same hosting and this has never been a problem. I don't know how to increase my available memory in this scenario, and I am not sure I am allowed to do so.

    Thanks for your tips. I will report back! :-)

  6. DougJoseph
    Member
    Posted 4 years ago #

    FOUND THE PROBLEM! FIXED IT!

    Thanks for your help.

    Here was the issue.

    One of the plugins, called WP Secure, placed an .htaccess file into the wp-includes folder.

    That file's settings were preventing certain files from being accessed, and thus both the visual editor on the post page, and the Gears option (Turbo), were being blocked.

    As soon as I deleted the .htaccess file, the problem went away.

    Ideally, I would like to have both proper security, and not lose core functionality. I simply don't know enough about how to edit an .htaccess file to get anywhere with that.

    Thanks again for your help!

  7. DougJoseph
    Member
    Posted 4 years ago #

    PS: Now, even after the problem is found, and all is working fine, this page:

    [WP Site] /wp-includes/js/tinymce/tiny_mce_config.php

    Still does not exist. Must have been applicable to an older version.

  8. ricoslist
    Member
    Posted 3 years ago #

    Doug,

    I spent hours troubleshooting this same problem - then finally found your post, deleted the .htaacess file created by WP-Secure in the wp-includes folder - and problem solved - THANK YOU!

  9. DougJoseph
    Member
    Posted 3 years ago #

    Glad to have been a help.

  10. jkrpublic
    Member
    Posted 3 years ago #

    Sounds like I'm following in the footsteps of others (looking for that tiny_mce_config.php file, re-uploading files etc) but I do not have a plugin called WP-Secure and there is no .htaaccess file.

    After working on this for hours I uploaded a completely fresh install onto a different web-site (2.9.2). I have added nothing on the site -- no posts, no plugins. I have deleted ALL plugins (there are two that are not active on install which are now removed). I have cleared my cache in both Firefox 3.5.5 and Safari 4.05.

    The visual editor tab is visible. It even shows as highlighted when you go to the edit page but there are no buttons and it shows up with the buttons that show on the HTML tab. Clicking on the html tab keeps the screen identical and flipping back to the Visual tab leaves you with a text box with no buttons whatsoever except for the video, audio, media buttons.

    Any ideas?

  11. DougJoseph
    Member
    Posted 3 years ago #

    I read your post. Don't know the answer. Just wanted to let you know it's not being ignored. I just don't know enough to help. Sorry.

  12. editguy
    Member
    Posted 3 years ago #

    I've upgraded to 3.0 and I'm having this problem. I have no .htaaccess file to delete. All plugins are deactivated, cache has been cleared, default themes have been tried. I've tried the solutions that seemed to work for people on older versions of WordPress, but no luck on my end.

    I had this same Visual Editor problem a couple months ago, and I ultimately changed hosts to Hostgator and the problem seemed to go away. That is until I upgraded to 3.0.

    I've seen pages of posts of similar issues with different solutions that seemed to work for some people. It looks like this is a problem that has gone on for more than a year with no set solution.

    It looks like all the users of WordPress are doing their best to help each other figure out this problem, which is awesome, but the developers aren't paying attention.

  13. Razorblade
    Member
    Posted 3 years ago #

    Same problem,
    upgraded to 3.0 from 2.8.x, html editor is not working, I don't see the switch button at all, is there any configuration to enable?

  14. Pappito
    Member
    Posted 3 years ago #

    Hi,
    same problem here. But, with a twist.

    After upgraded to 3.0 the editor lost the buttons.

    The strange thing is, all the buttons are working well under win+ff or win+ei8 but no buttons under mac+ any browser (ff, safari, camino, chrome). How could it be?

    It is really hard, 'cause I am usually working on my post at home (workplace for work) but after the upgrade I have to stay at my workplace and use windows if I want to write a post. I am not happy.

    The whole upgrade went seamlessly and the face of my blog is still the same.

    I've tried everything but the thing is - it is working under win xp so I don't want to mess up with the config files or php. (and I am not a programmer )

    I had this wp upgrade and Mac OS X update as well (to 10.6.4).

    Now, all I suppose to say: help, please.

    Thank You

  15. kimsclicks
    Member
    Posted 3 years ago #

    Well, my problem is a slight bit different. I have 3.0 wordpress or whatever the newest is. I have had this site up for 3 months with (go daddy) I uploaded a small site to my host account (go Daddy) and went to do some editing on my site and clicked on recommended reading and got an whoops message. Go daddy no help they say that the server trying to find the file but it is not there??? Also when I write a new post publish it want to take a peek at it and I get a error message. I can see the post if I click on my site name but no other way. I am finding I cannot link to my pages anymore either I keep getting error messages.. Can anyone help me??????
    Frustrated Kimberly
    http://www.1clickfindit.com problem site

  16. kimsclicks
    Member
    Posted 3 years ago #

    Oh yeah and my gravatar is not working anymore

    sorry I forgot to add that problem to my post.

    Kimberly
    from 1clickfindit

  17. IanB22
    Member
    Posted 3 years ago #

    Here's another cause of losing the TinyMCE (Visual) editor toolbar in some circumstances and how to fix it.

    Background
    I have a site running several plugins, including the widely used 'cforms' along with 'Job Manager'.

    My problem was that the Visual editor toolbar disappeared entirely within Job Manager after replicating the site to live (and when all worked perfectly on the dev server). The regular WP Posts and Pages Visual editor continued to work fine.

    My Fix
    cforms > Global Settings > WP Editor Button Support > Check 'Fix TinyMCE error support'. While cforms says 'Select in case you experience a TinyMCE editor error caused by other plugins.' In this case cforms being Active was disabling the Visual editor toolbar within Job Manager. Strange but true.

    I hope this saves someone else all the hours it's taken me to find it!

  18. kimsclicks
    Member
    Posted 3 years ago #

    Hello all I know you all should remember me I just have constant issues.
    Oh well I remember reading somewhere in this Forum about Akismet putting comments in spam. Well I finally have people commenting on my site and that darn Akismet is putting it in spam. How the heck can I fix this issue??

    Thanks
    Kimberly
    http://www.1clickfindit.com

  19. samiotis
    Member
    Posted 3 years ago #

    I have the same visual editor problem. I did have wp secure installed and was very happy when I was reading this post... at first. I removed the .htaccess file but no flowers. Then I kept reading on and found the cforms hint, to turn on the problem fixer tool in cforms options, yet again no flowers.

    So I reinstalled wordpress 3.01 from the admin section and again no flowers. I turned off all plugins and refreshed all my browser cache pages and tried different browsers but yet... again no flowers. Now I'm running out of options. The site in question is http://superfoodinfos.com/ and I'd love to have my visual editor back.

    @Kimberly - Besides that you're in the wrong threat here and you won'tget as many answers as you wish for; here my suggestion, Akismet is working well to remove spam but it will remove nice comments too when people use keywords in the name field instead of their name. These guys are spammers and the job of akismet is to remove spam; so everything works correctly.

  20. edwardbeckett
    Member
    Posted 3 years ago #

    @DougJoseph

    Thanks for posting your solution. I too had errors with TinyMCE's buttons not appearing for the visual editor and it was directly related to having an .htaccess file in the includes directory. However, my .htaccess file was there simply to make a statement in the directory to increase WordPress memory limits for the directory. If you hadn't posted the solution ... I might not have figured this out for quite some time.

    Thanks again

    EB

    Edward Beckett - Florida SEO

  21. tracelemental
    Member
    Posted 3 years ago #

    re: .htaccess - when I do a search, it says there is a .htaccess in the /includes directory however I cannot see if for the life of me.

    Any other way to view files rather than cpanel file manager? It appears you cant delete unless you click on the file.

  22. tracelemental
    Member
    Posted 3 years ago #

    all good, found the "show hidden files" option for file manager

    yes removing the .htaccess file worked for me as well

  23. samiotis
    Member
    Posted 3 years ago #

    Unfortunately I'm still having the same problem.Now in 3.04 but still no flowers. My visual editor doesn't seem to exist on this website.

  24. visar.uruqi
    Member
    Posted 3 years ago #

    It's your lucky day folks I have finally found the answer
    go edit your wp-config.php and add this line

    define('CONCATENATE_SCRIPTS', false );

    It should work fine.

    For greater explanation look the thread:
    Reference:

  25. kristingcs
    Member
    Posted 3 years ago #

    I tried that and it did not work for me. Im currently running 3.1 on a test server. Anyone else have any other suggestions?

  26. Chase Adams
    Member
    Posted 3 years ago #

    Have you all tried navigating to wp-includes » js » tinymce on the server side, deleting everything in that folder and copying and pasting what's in a freshly downloaded version of WordPress into it?

  27. guppydas
    Member
    Posted 3 years ago #

    Friends,

    Here is what worked for me. I upgraded cForms to the latest version and it all worked fine.

    Now many of you may not have cForms installed. However what I think is the problem is, with any other plugin that uses AJAX or Java scripts and interacts or tried to modify the TinyMCE will result in UI of editor messing up.

    I have a feeling nothing much to do with .htaccess files as much.

    Hope this helps.

  28. samiotis
    Member
    Posted 3 years ago #

    @guppydas
    Thanks for that! Now it works, but...
    It didn't work when I removed the .htaccess file as DougJoseph mentioned, so I put it back where it was, it also didn't work at first, when I updated cforms to 11.7.3 but when I removed the .htaccess file after updating cforms it WORKED! After 5 month. Thank you all for the ideas! I consider this threat as solved.

Topic Closed

This topic has been closed to new replies.

About this Topic