WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editor Tab not showing - How i fixed it (11 posts)

  1. stefanb
    Member
    Posted 1 year ago #

    I'm using WordPress 3.4.1 on a blog and had the problem that my visual editor was not working - no HTML/Visual Editor Tabs showed up.

    Because I could not find a solution (it had nothing to do with profile-setting, plugins, cache, theme, tinymce, etc.) and I saw that some users in the forums had the same problem and the solutions for plugin/cache/theme related problems did not help I thought I might type up what caused my problem and how I fixed it.

    The data in my installation is very old - the first admin users where added 2007.

    I found the problem when a new user (two weeks old) told me he could switch between visual and html editor without a problem.

    Well, maybe it might have had something to do with the visual editor setting in the user profile, but switching the option there on and off didn't change anything.

    My solution was to look into the MySQL tables. In the 'user_meta' table i saw that the new user had a meta_key called 'rich_editing' with the value of 'true'. The old admin users did not have this key. So i added a new key rich_editing = true for the old users and i instantly saw the tabs to switch between visual and html editor.

    Hope this helps some. If you don't know how to edit stuff in your mysql database or if this is not the solution to your problem I can't really help you, sorry. I just wanted to share this solution for this particular cause of problem.

  2. Luisg
    Member
    Posted 1 year ago #

    I install wordpress 3.4.1 today and it is clean of any thing.
    is this the code you are referring to
    <?php if ( rich_edit_exists() && !( IS_PROFILE_PAGE && !$user_can_edit ) ) : // don't bother showing the option if the editor has been removed ?>
    <tr>
    <th scope="row"><?php _e('Visual Editor')?></th>
    <td><label for="rich_editing"><input name="rich_editing" type="checkbox" id="rich_editing" value="false" <?php checked('false', $profileuser->rich_editing); ?> /> <?php _e('Disable the visual editor when writing'); ?></label></td>

    What is with the ( don't bother showing the option if the editor has been removed ) how do I know if the visual editor is install

    I have change the false to true and is not working,

  3. Sabinou
    Member
    Posted 1 year ago #

    Stefanb, I thank you sincerely for taking the time to report your solution, I met that issue twice, the third time it happens in another blog, I'll try your idea :)

    @Luisg : this is a phpmyadmin thing, regarding data stored in the database and loaded (if avail) by the wordpress engine.

  4. Luisg
    Member
    Posted 1 year ago #

    Stefanb Yes in the wp-admin folder in the user-edit.php file, good luck, my still not working, if any one has an other solution please post.

  5. darrylholland
    Member
    Posted 1 year ago #

    My visual and html editor aren't working.I'm unable to edit my post.How can fix this problem?

  6. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Please post your own topic.

  7. richdlin
    Member
    Posted 1 year ago #

    Wow, I've looked at a ton of threads trying to figure out the issue and this was the one that fixed it for me. THANKS!!!!

  8. DLo978
    Member
    Posted 1 year ago #

    stefanb, this was the exact solution to my problem. Not only are you a genius for troubleshooting this, it was extremely thoughtful and helpful of you to post this magnanimously. Cheers!

  9. Andy Keith
    Member
    Posted 1 year ago #

    We just had the same problem with one of our WordPress web design clients. It appears to have been a plugin conflict because the Visual tab started working again after we applied all the available updates to the plugins installed on the site. So it's worth ensuring everything is up to date before starting any more time-consuming fixes.

  10. StAugPhotoArt
    Member
    Posted 1 year ago #

    This fix is much too simple! I looked through all the various forums and found a multitude of solutions. Some so complicated I didn’t even bother to check them out. Then . . . .
    I looked on the WP Dashboard sidebar under Users; and double clicked on Your Profile. At the top of the Profile page is Personal Options, Visual Editor. If you uncheck the box for: Disable the visual editor when writing, it will correct the problem. Don’t forget to update Profile at the bottom of the page.
    Much too simple for a Forum!

  11. DLo978
    Member
    Posted 1 year ago #

    Hey stAugPhotoArt, I think the problem you dealt with is different from what has been discussed in this thread. The solution you suggest only works if there is a record in the user_meta table to begin with. In certain cases, such as a migration of older installations of WordPress, that record doesn't exist and requires manual creation... hence the need for this thread to cover that specific situation.

    Even if this did work, I have a multi-site blog with hundreds of users and it would not be feasible to manually check off that box. The solution suggested in paragraph 6 of the original post helped me to fix the problem across the board in a few mins.

Topic Closed

This topic has been closed to new replies.

About this Topic