WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editor problem ( 2.6.3 ) (29 posts)

  1. StoraX
    Member
    Posted 5 years ago #

    Hello ,

    i have this problem . Before , i have a host on Lunarpages . Now , i have a VPS and load my backup new VPS . But i have a problem about this . i have a screen shot :
    http://img186.imageshack.us/img186/7640/abcul3.jpg

    My server administrator program is LxAdmin ... what is the problem ? this problem based on php rules ?

  2. tazme
    Member
    Posted 5 years ago #

    What's is the problem? You are not getting Visual editor?

    Did you look at your Dashboard>Profile? It may be disabled over there.

  3. StoraX
    Member
    Posted 5 years ago #

    Yeap , im not getting visual editor . For exam i have NextGEN Gallery . And this plug-in's button not showing on visual editor . I attach a file imageshack.us ... You can see it first message ...

    And i look at my Dashboard . Its normal . Its screen : http://img231.imageshack.us/img231/2749/dasdsadsatm6.jpg

  4. complaintbucket
    Member
    Posted 5 years ago #

    I wonder if there is a plugin that is not operating correctly? I had the same problem and I think I disabled all my plugins and activated them again one by one. It was a awhile back and I am sorry for the memory lapse.

  5. tazme
    Member
    Posted 5 years ago #

    Take a look at wp-includes/js/tinymce. Try overwriting with new files of tinymce.

  6. tazme
    Member
    Posted 5 years ago #

    Do you have "disable visual editor" plugin? This may cause probs?

  7. StoraX
    Member
    Posted 5 years ago #

    @ complaintbucket
    yes , i have read somethig about your say . i do it . But not working . i delete my wp files from my vps . And re-upload them . And i delete plug-in files . Now , Everything is new ; like new wp site ...

    @ tazme
    im try . But , not working . For exam , add media buttons is working . Wenn i push add an image or a video button , its work ...

  8. StoraX
    Member
    Posted 5 years ago #

    No , now , i have not any plug-in . Only wp files located my server .

  9. tazme
    Member
    Posted 5 years ago #

    Ok. In that case, no idea. :( Sorry about that.

  10. StoraX
    Member
    Posted 5 years ago #

    Still not working . Any idea ?

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Are you getting any javascript errors in your browser error console?

  12. StoraX
    Member
    Posted 5 years ago #

    No , i have no js errors ... i try Firefox , chrome and ie 7

  13. StoraX
    Member
    Posted 5 years ago #

  14. StoraX
    Member
    Posted 5 years ago #

    Opsss ... i found i error : http://i37.tinypic.com/x6lmop.jpg

  15. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    That indicates that you are missing some files or they have the wrong permissions or something.

    Reupload WordPress, and make sure ALL the files are there and that they have correct permissions (644 for files, 755 for directories).

  16. StoraX
    Member
    Posted 5 years ago #

    I say above : " i delete my wp files from my vps . And re-upload them . And i delete plug-in files . Now , Everything is new ; like new wp site ... " After , i delete tinymce files and re-upload ... But this is not working .

    Google chrome says : Uncaught SyntaxError: Unexpected string http://www.hdwarez.com/wp-includes/js/tinymce/tiny_mce_config.php?ver=20080811 (line 15)

  17. rndavis
    Member
    Posted 5 years ago #

    I had the exact same problem after activating NextGen Gallery. When I disable it the plugin, my visual editor works again.

    Does anybody have a fix for it?

  18. cyberbuilder
    Member
    Posted 5 years ago #

    My problem was similar. It seemed to have happened out of nowhere. I don't know what I did to cause it but I got frustrated trying to fix it. I was running TinyMCE Advanced plugin and disabled it to no avail. Finally I just decided to abandon TinyMCE altogether and replace it with Dean's FCKEditor For WordPress plugin instead. It's a little different but quite nice once you start working with it. Maybe I'll find a fix for TinyMCE later but for now I have to get BACK TO WORK!

    Hope it helps you get back to work too!

  19. timclark
    Member
    Posted 5 years ago #

    I get this on my screen and I know other people also but I have not had any one who is able to help, I am wondering whether to go to the 2.7 from my 2.6.3.

    also I get this come up when I view the source code on the above page.
    /wp-includes/js/jquery/jquery.schedule.js?ver=20'></script>
    <script type='text/javascript'>
    /* <![CDATA[ */
    wpAjax = {
    noPerm: "You do not have permission to do that.",
    broken: "An unidentified error has occurred."
    }
    /* ]]> */

  20. StoraX
    Member
    Posted 5 years ago #

    i upload wp 2.7 beta2 and editor is working ... im waiting wp 2.7 ... i don't solve my problem :(

  21. timclark
    Member
    Posted 5 years ago #

    i upload wp 2.7 beta2 and editor is working ... im waiting wp 2.7 ... i don't solve my problem :(

    StoraX Sorry do you mean that you used 2.7 beta2 and it did solve the issue?

    Please clarify..Thank you

  22. StoraX
    Member
    Posted 5 years ago #

    Hmmm , now , i don't use wp 2.7 beta2 ...

    Yesterday ; I upload wp 2.7 beta2 to http://www.site.com/test . And i install it , my editor worked . im waiting wp 2.7 ...

  23. discojing
    Member
    Posted 5 years ago #

    i had this error with 2.6 as well and i fixed it by changing the permissions for every file in wp-includes to 644 and every folder to 755.

    fixed ^__^

    i had this error with earlier versions and had other methods for fixing it.

  24. timclark
    Member
    Posted 5 years ago #

    Hey I really appreciate the help,
    I could not change my file permissions they stay the same no matter what I did, I called the hosting company Fasthosts and they told me it is not possible and I would have to move to a different package back up my database and re upload it.
    I did tell them I was using wordpress in the first place so I am not that happy with them, What I do not understand is that It worked fine on 2.6.2 prior to going to 2.6.3.

  25. DolnaM
    Member
    Posted 5 years ago #

    Thanks cyberbuilder. I went from 2.6 to 2.6.3 and still had the same exact problem. I had no editor loading in pages and posts. Only HTML, where the HTML code showed up invisible.
    I tried everything loaded different editors and none of them worked except Dean's FCKEditor For WordPress. Now I have an editor! - If you have the issue give it a try. http://wordpress.org/extend/plugins/fckeditor-for-wordpress-plugin/

  26. timclark
    Member
    Posted 5 years ago #

    I have managed to solve the issue with 2.6.3.

    I checked all file permissions 755 folders 644 files
    I deleted wp-includes and wp-admin
    I reloaded from a new download of 2.6.3 did not use one I already had.
    cleared all cache on pc.

    Done and working fine.

    P.s I have tried all the above including reloading tinymce, changing file permissions, remove js cache, don't bother as it dont work.

  27. WizardRegis
    Member
    Posted 5 years ago #

    I had the same problem. I tried to deactivate some plugins and it seems it's NextGEN gallery that made the problem for me, once deactivated the editor works fine again.

  28. desertmagic
    Member
    Posted 5 years ago #

    I had the same problem, with the exact same error. I checked my new WordPress install and compared it with an older install that I had updated to 2.6.3.

    It appears that the new install is missing the wp-includes/js/tinymce folder, along with several other js folders. I'm not sure why these folders were not uploaded with the first install, but it happened twice, because I reinstalled WordPress the first time the tinymce didn't work.

    I uploaded the tinymce file, and the subfolders didn't upload. So I went in and uploaded those too. So try uploading just those missing folders in the js file and make sure the subfolders upload too.

  29. pummyjr
    Member
    Posted 4 years ago #

    I had th same problem in 2.8.4. I thought that with 2.8.5 it will be gone but i thought wrong.
    I've tried timclark's method of setting permissions, deleting and re-uploading fresh wp-admin and wp-includes but no luck. It still doesn't work.
    So far the only thing that helped was Dean's FCKEditor For WordPress plugin.
    Hope that in the near future someoane will save us :))
    I forgot to thell that nextGen started the problem in the first place fo me too.

Topic Closed

This topic has been closed to new replies.

About this Topic