WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editor Not Working: Mimicking HTML editor / blanking out / no tool bar (7 posts)

  1. achellios
    Member
    Posted 2 years ago #

    I've found what appears to be a core-code problem with the TinyMCE plugin packaged in WordPress 3.2.1. Below are the problem details and a work-around that restores the Visual Editor on the three blogs I manage.

    The WordPress backend at http://yoursite.org/wp-admin/post.php?post=2&action=edit calls two javascript files which return 404 File Not Found errors:

    http://yoursite.org/wp-includes/js/tinymce/langs/en.js
    http://yoursite.org/wp-includes/js/tinymce/themes/advanced/langs/en.js

    This occurs only when editing a post or creating a new one. The second file is also missing its parent folder, /wp-includes/js/tinymce/themes/advanced/langs/.

    The workaround is to "restore" these files by copying a similar one into the appropriate folders. Steps are as follows:

    1. Copy /wp-includes/js/tinymce/langs/wp-langs-en.js and rename the copy en.js
    2. Create this folder: /wp-includes/js/tinymce/themes/advanced/langs/
    3. Copy your new en.js to the folder you created.

    When you're finished, you should have en.js files in the two locations listed above. With these in place, the WP visual editor will begin functioning normally again. I was able to duplicate this in two WP 3.2.1 installs using few plugins and an entirely customized theme.

    Administrators, please let me know if there's a better place to paste this workaround or to give the developers a heads up.

  2. kbarncat
    Member
    Posted 2 years ago #

    I'm out of state, so not able to check things like I'd like to - but I am very excited about what you've discovered and plan to follow up soon as I get home. Thanks achellios. Maybe this will clear up some of the function problem I have since we got our editor back on line. Mostly.

  3. kbarncat
    Member
    Posted 2 years ago #

    Scrub the last comment. I went ahead and checked it out. I did find the files you pointed out, and I did find the

    http://yoursite.org/wp-includes/js/tinymce/themes/advanced/langs/en.js

    missing. However - my journey with this problem is documented at

    http://wordpress.org/support/topic/321-visual-editor-broken-personal-topic?replies=30

    And in that account, I explain how we had to replace the WP-options file before anything would work after upgrading. I got the functionality of the editor back, except that I could no longer insert Flickr codes into the html (insert all photos, one after another, then save draft to lock in the html) then go to the visual side, place a cursor on the after side of a photograph and use the return key on the keyboard to create a space for copy between the top photo and the following one. I have been working this way for years in WP, and suddenly no longer could.

    Looking at your fix, I was hoping (though I couldn't really see how this would help) that I might restore than functionality to my mostly working editor. But what I found is that, not only did the fix not change anything - I was already working with a mostly functional editor EVEN THOUGH THE LANGS FILE was missing.

    There is evidently something so flakey about the TINYmce code that any number of small things can break its functionality. So while your fix has worked for you, and others have found other things - like the extra colon thing - the problem may still persist for others because their combination of oddities just happen to break the dang thing, too. The editor needs editing.

  4. achellios
    Member
    Posted 2 years ago #

    Unreal...sorry this didn't help with your Flickr code situation. If you hit a brick wall, hit me up; I do development work on the side and could take a look for you.

  5. Andrew Martin
    Member
    Posted 1 year ago #

    Dude,

    I'm STILL seeing this issue on latest WP. I have to keep adding back in the langs file every time I upgrade WP. What the heck is causing this, and is there any hope they'll ever fix it?!

  6. Andrew Martin
    Member
    Posted 1 year ago #

    Any word on this?

  7. geghna
    Member
    Posted 1 year ago #

    . Copy /wp-includes/js/tinymce/langs/wp-langs-en.js and rename the copy en.js
    2. Create this folder: /wp-includes/js/tinymce/themes/advanced/langs/
    3. Copy your new en.js to the folder you created.
    the above doesn't work please suggest another solution

Topic Closed

This topic has been closed to new replies.

About this Topic