WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Visual Editor: Not working in WordPress 3.5 (25 posts)

  1. iEnlive
    Member
    Posted 1 year ago #

    Hello,

    Recently upgraded to WordPress 3.5 to see that the Visual Editor is not working. Luckily Media uploader is fine and HTML editor only works when set to open a new post.

    Is there any fix to this ASAP? Already added "define('SCRIPT_DEBUG', true);" to WP.Config file but still no luck.

    Would appreciate support! Thank you!

  2. 757talent
    Member
    Posted 1 year ago #

    Status???

    I also recently upgraded to version 3.5 and just as Enlive said, my visual editor won't work either! Although I'm not totally dependent on visual, it's still a feature that I like to use at times. I thought that it had something to do with TINYMCE but it doesn't that I can see. I've been using WP for years now and have never had this issue. I think it has something to do with 3.5. Furthermore, I didn't manually upgrade it, I just logged into the dashboard and it was automatically updated! Guess I gotta double check my settings in my hosting panel.

    Please Help!

  3. drgreen
    Member
    Posted 1 year ago #

    visual editor works except cannot insert a link in text with visual or html editor. The icons just don't function in IE, Chrome, Firefox. I did get more icon functionality with a tinymce plugin, but the problem existed before uploading. Also need suggestions. Using 3.5 My site is still under development but would be happy to share it if that makes a difference.

    Thanks!

  4. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    All of you need to start by going through the troubleshooting steps in this thread:

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    Then, @757talent and @drgreen, please start your own threads per the forum guidelines. It's really much better for people trying to help and for you to have one person/topic per thread.

  5. brighamrussell
    Member
    Posted 1 year ago #

    I took the advise of WPyogi, and this issues is not listed, and none of the generic fixes worked (I did try every one of them).

  6. Aaron Anfinson
    Member
    Posted 1 year ago #

    I had the exact same issue, and I found a fix.

    Based on information from past forums of people struggling with this on old versions of WordPress, I installed the "Use Google Libraries" plugin, and then activated it (don't forget to activate it, as it won't activate automatically after installation).

    It worked!
    Apparently the plug-in "Allows your site to use common javascript libraries from Google's AJAX Libraries CDN, rather than from WordPress's own copies." I'm not so sure about all that, but it fixed my issue with the Visual editor! (Giving me the feeling that my site is held together with my own sloppy coding/template adaptations, duct tape, shoe string and now plugins!)

  7. btajis
    Member
    Posted 1 year ago #

    Thx Aaron Anfinson for the hint, it saved me!
    My Visual Editor was active but the icons disappeared and the HTML Editor (Text in 3.5) went inactive...
    I tried everything I could find on a number of forums with no success until finally your trick worked!

    I have no idea what javascript or AJAX libraries are but the "Use Google" Libraries plugin did the job.

    Thx again and have a great day!

  8. brighamrussell
    Member
    Posted 1 year ago #

    The fix that I found that worked on every borked WordPress site on which I tried, is just replace the core WordPress files with fresh WP 3.5 core files. It didn't work at first, but I just had to clear my browser's cache and cookies and it worked! Simple.

    [ Commercial link moderated. Please don't use the support forums to advertise or promote your services ]

  9. icedub
    Member
    Posted 1 year ago #

    +1 to Aaron's tip. It worked immediately on my blog to restore the functionality of the visual (and text) editors.

  10. mariahkw
    Member
    Posted 1 year ago #

    Thanks Aaron! Instant fix!

  11. 757talent
    Member
    Posted 1 year ago #

    Wow!

    I really struggled with this one for awhile but as promised, it instantly fixed my visual editor! Thanks for the advise Aaron!!!

    You are the MAN!

  12. postjoe.com
    Member
    Posted 1 year ago #

    Visual and Text Editor Bug also in MU installations: AJAX is busted. "Use Google Libraries" plugin corrected the issue multi user installation.

  13. tech.lover
    Member
    Posted 1 year ago #

  14. Kartoony
    Member
    Posted 1 year ago #

    Same problem - 3.5 - no Visual Editor - installed Google Library - all better now!!

    Thanks Aaron.

  15. rewbie
    Member
    Posted 1 year ago #

    Yay, it worked for me too! Thanks!!

  16. unknowndev
    Member
    Posted 1 year ago #

    I had this same issue and fixed it by doing the following:

    1. Go to Users->"Username" and check the box that says "Disable the visual editor when writing". Update Profile.
    2. Go to Post or Page and verify that the visual editor is disabled.
    3. Go back to Users and uncheck the box and save.

    After doing that when I went back to the Page/Post I was trying to edit everything was fixed.

  17. cadchr01
    Member
    Posted 1 year ago #

    I installed "Use Google Libraries" and that instantly fixed the problem. Interesting.

  18. deemat
    Member
    Posted 1 year ago #

    Dear Aaron Anfinson,
    bang on bull's eye its worked it a flash....
    thank you u saved it...
    regards..

  19. atroutcatcher
    Member
    Posted 1 year ago #

    Hello. I have this problem regularly (Visual editor stops working) for some reason and, this time, the installation of the 'Use Google Libraries' resolved the issue. Never seems related to any particular plug-in.

    Anyone know why this (installation of the 'Use Google Libraries' plug-in) solves the problem and how to repair it without installation of the additional plug-in?

  20. marcobarra
    Member
    Posted 1 year ago #

    google libraries solves it! thanks for the tip!

  21. admin_pursue
    Member
    Posted 1 year ago #

    Google Libraries resolved the issue. Thanks guys!

  22. Mooch12003
    Member
    Posted 1 year ago #

    I had the same issue with the visual editor not working correctly and tried all of the above, none of which worked.

    I have found the solution though.

    Turns out I had an .htaccess file in my 'wp-includes' folder, the contents of this file was 'deny all'. I deleted the file and everything is working spot on now. This file seemed to be stopping WP from accessing tinyMCE.

  23. ldelappe
    Member
    Posted 1 year ago #

    I am having the same issue with my visual editor (I hope this is in the right thread.)

    I've tried many of the suggestions - Use Google Libraries, switch to Twenty Eleven, clear the cache, turn off all plugins - and none of it works to restore my visual editor.

    Is there anything else I can do?

  24. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @ldelappe - actually, it's best if you start your own thread - as your issue is not likely identical even if it seems similar.

  25. ldelappe
    Member
    Posted 1 year ago #

    Thank you, WPyogi. I will do that.

Topic Closed

This topic has been closed to new replies.

About this Topic