WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editor not working in 2.2 (29 posts)

  1. satchel
    Member
    Posted 7 years ago #

    Just upgraded to 2.2. When my user is switched to use the visual editor, I get tabs for Visual and Code on the edit pages, but no TinyMCE buttons show up, and the entry is displayed in Code format. Clicking on the tabs does nothing. If I switch to not using the visual editor, everything's fine.

    I'm using a ton of plugins, but can't imagine what might be interfering. Any suggestions?

  2. drmike
    Member
    Posted 7 years ago #

    Log out clear your browser's file and cookie cache, relog in and try again. :)

  3. issye
    Member
    Posted 7 years ago #

    Did you delete the tinymce folder in wp-includes/js?

  4. mpanttaja
    Member
    Posted 7 years ago #

    I have cleared cache and cookies, but the edit icons in the editor are still garbled as is the login screen. Are there any other suggestions?

    Thanks
    M

  5. ignotus
    Member
    Posted 7 years ago #

    I am having the same problem of no TinyMCE buttons, everything in HMTL. FireFox 2.0.0.3 Mac's error console reports that "realtinyMCE is not defined" and similarly "switchEditors is not defined" when I attempt to swich by clicking the Code button.

    Here's the interesting part: If I submit a comment to a post and then edit it, TinyMCE shows up, in all its useful splendor. I still get the "tinyMCE is not defined" error on line 147 of the page (/wp-admin/comment.php?action=editcomment&c=2), but at least it is functional.

  6. bradleyscott
    Member
    Posted 7 years ago #

    I am also missing the TinyMCE editor for the Visual tab. It almost appears that it might be hidden underneath the Text Box. In any event, it seems to work in IE7, but not Firefox.

    I am running Firefox 2.0.0.3 on Windows XP.

  7. breakingball
    Member
    Posted 7 years ago #

    If you use the My Link Order, My Category Order or My Page Order plugins, there are new updates to the 2.1.3 versions that fix this problem.

  8. bradleyscott
    Member
    Posted 7 years ago #

    That makes sense. I have the My Page Order plugin installed. Thanks for the heads up.

  9. ignotus
    Member
    Posted 7 years ago #

    Hm. My problems show up on a new, bare bones installation, so it's not likely to be a plug-in problem. The TinyMCE buttons do show for Comments, but they enter HTML markup into the text area, not rich text. In addition, my RSS feeds were broken--the first line of the XML doc was blank, with the XML header on the second line.

    In my installation there are several problems. Many seem to be related to how JavaScripts are loading and executing. I dialed back to 2.0.9 (keeping my 2.2 installation to see if I can eventually debug everything), where everything just works.

    Could be an issue with what hosting services support, too, though the PHP and MySQL installations on my host are very current. There are quite a few threads on this and simlar problems.

  10. mpanttaja
    Member
    Posted 7 years ago #

    I am still having problems as follows:

    Everything in the editor seems to work on IE. The login page image background is garbled.

    On Safari, the Visual/Code tabs are missing and it comes up in Code mode. The login page image background is garbled.

    In Firefox, the images for some of the editor buttons are not getting into the page (not there in the page info). ("More" through "help" are there; they live in a different directory than the missing ones---though the directories seem clean.) The introductory login in page has a garbled looking background.

    So it seems like a combination of problems.

    The good news is that as long as I can remember what's what, I can work; but it's not pretty. Still searching for a repair.

    Thanks
    Mary

  11. ignotus
    Member
    Posted 7 years ago #

    I continue to experiment with WP 2.2, to no joy. Setting .js and .php file permissions to 755 has not helped (this was a solution for someone else, so it seemed worth a try).

    The fundamental issue appear to be that not all JavaScripts are loading or at least not loading at certain critical points.

  12. asfodel
    Member
    Posted 7 years ago #

    The visual editor has never worked for me. I just turn it off and don't use it. I wish that was the default, that it's off unless you choose to turn it on.

  13. nextwave
    Member
    Posted 7 years ago #

    In Firefox 2.0.0.4 - no visual text editor TinyMCE- or edit tools in code view.
    In Safari- I get no tabs- but do see a row of buttons- but in code view.
    Both are on a Mac. No plugins, default theme.
    This was working in WP 2.1.2
    I'm nervous about changing any other installs now.
    On a PC- with Firefox and explorer- nothing.
    It's not turned off in users.
    Any suggestions?

  14. nextwave
    Member
    Posted 7 years ago #

    Hope this helps- I cleared cache and cookies. Used control F5 (on a mac) to force it- again after doing it in Firefoxes prefs.
    Then hit refresh- while holding shift key.
    Problem solved.

  15. bdieu
    Member
    Posted 7 years ago #

    I have upgraded to WP 2.2 hoping I would get the rich editor this time but pb persists. When I check the rich editor at options, I get two tabs (visual and code) in the write area but nothing more.
    When I uncheck the rich text option, I get the code tab only with some of the functionalities but not all.
    I have tried the cache suggestion but nothing happened.

  16. Crowmanic
    Member
    Posted 7 years ago #

    Ok, so now I join the queue... just did the install of advanced TinyMCE, whatever as per instructions... now have only 2 buttons showing on write new post editor, the Visual and code!! lost what I had b4, at least some menu (alt+shift+V) Like others, using Wp v2.2 + Firefox... hmmm not a good day for many it seems. Any real suggestions or help from a tech would be great.

    PS: just did a login with IE... with some falty starts and stops... the editor loaded with the damn thing looking like its suppose to... so what gives? anyone? re the Firefox clanger? IE's a hog... can't stand the beast...

  17. kalico
    Member
    Posted 7 years ago #

    FWIW I also had the MyCategoryOrder plugin installed, and replacing it with the latest 2.1.3 did fix the problem for me. (re-download from http://www.geekyweekly.com/mycategoryorder even if you already have 2.1.3, the fixes are there)

    It's possible there is yet another plugin causing this for those who don't have MyCategoryOrder or his other plugins, so some trial and error might be in order. Deactivate all plugins, and see what you get, then enable them one by one and see which one changes the editor...and for the rest who are getting this on a clean install, I hope you (or the WP crew) can get it figured out soon!

  18. altonx
    Member
    Posted 7 years ago #

    My visual editor never appear after installing wp2.2. The option for turning it on is only show in the users profile page but not on Options> Writing page. However, even when I choose to use it, it is still not show.

    Anyone knows how to enable it? thanks!

  19. sandroWP
    Member
    Posted 7 years ago #

    Hello, I am working with WP 2.2 and have the same issue with the visual editor when editing comments. The editor works fine for Posts, and page edits. However, the comments editor shows only as code view.

    I disabled the CSS style sheet and noticed that the buttons to switch between code and visual are there. These however do not show up when CSS is enabled (firefox feature). I have tested the comments edit page with IE 6 and FF. both don't work.

    It seems that the javascript is not running properly on the "wp-admin/comment.php" file but runs fine in the "wp-admin/post.php" and "wp-admin/page.php" files. I am new to word press so I don't know my way around the code yet. Both the post and page edit pages allow you to switch between code view and visual view. The comment page shows the editor in code view and does not give you the option to switch between code and visual views.

    I am willing to go into the code and troubleshoot. However I would like to get some pointer where to start. I don't want to spin my wheels.

    I have noticed the following differences between the post/page files and the comments file:

    Some of the javascript calls in the head section of the html do not get included in the comments page.

    wp-includes/js/fat.js?ver=1.0-RC1_3660
    wp-includes/js/prototype.js?ver=1.5.0-0
    wp-includes/js/jquery/jquery.js?ver=1.1.2
    wp-includes/js/jquery/interface.js?ver=1.2
    wp-includes/js/tw-sack.js?ver=1.6.1
    wp-includes/js/autosave.js?ver=20070306
    among others, but I also found that these were definitively not included in the commments.php HTML output:

    wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20070326
    wp-includes/js/tinymce/tiny_mce_config.php?ver=20070225

    Your comments/findings are most appreciated.

    Sandro.

  20. sandroWP
    Member
    Posted 7 years ago #

    For whatever this is worth, I hard coded the two javascript calls mentioned on my last post reply and the visual editor works!.

    These are missing in the edit comments page:
    wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20070326
    wp-includes/js/tinymce/tiny_mce_config.php?ver=20070225

    However, hard coding these in is not the right way to do things. Any suggestions how to fix this? Why are they being omitted?.

    Thanks, Sandro.

  21. siriain
    Member
    Posted 7 years ago #

    I've had the same problem after upgrading to v2.2, and after much searching, have discovered that there are a number of editor plugins available in the Codex, which not only work, but have far many more useful features than the standard editor! Right now I'm using Dean's FCKeditor.

  22. ignotus
    Member
    Posted 7 years ago #

    I have upgraded to 2.2.1. This did not solve the problem. After some experimentation I determined that the gzipped version of TinyMCE was not loading. I suspect some resource issue or server setting is to blame, but have not isolated it.

    One solution is to edit script-loader.php, line 29:

    /*		$this->add( 'tiny_mce', '/wp-includes/js/tinymce/tiny_mce_gzip.php', false, '20070326' ); */
    		$this->add( 'tiny_mce', '/wp-includes/js/tinymce/tiny_mce.js', false, '20070326' );

    Above, I have commented out line 29, which calls tiny_mce_gzip.php, and added the next line, which calls tine_mce.js.

    This substitution allows me to use TinyMCE to edit posts.

    Unfortunately, the TinyMCE Editor has disappeared completely from the Comments editor. It doesn't even seem to be loaded by the header scripts. I have combed through WordPress settings, thinking there must be some obvious setting I have overlooked, but have not located it. Worse yet, the Comments editor insists on converting markup to ASCII--it wraps a comment in <p></p> tags, then converts the tags and wraps the comment again every time I edit and save. Not out of the woods yet.

    One thing I noticed, using TinyMCE in project I am developing: in FireFox, loading TinyMCE in the BODY instead of in the HEAD of an HTML page will usually result in TinyMCE failing to load.

    HTH,

    -- Paul

  23. nextwave
    Member
    Posted 7 years ago #

    After 6 hours of messing with just 3 wp installs of 2.2.1, I finally gave up and started using Dean's FCKEditor- it's ugly- but it shows up.
    Apache version 1.3.37 (Unix)
    PHP version 4.4.6
    MySQL version 4.1.21-standard
    cPanel Build 10.9.0-RELEASE 10737

    Don't know what is causing TinyMCE to fail- but I got it working on a few sites after much work. Note- I was generally updgrading from 2.1.2 installs- don't know if that had something to do with it.

  24. nextwave
    Member
    Posted 7 years ago #

    After much screwing around- the only solution to get the visual text editor back is to reinstall 2.1.3
    You have to update the db- and then things work as they should.
    There seems to be some kind of code in the TinyMCE folder that causes problems- I will wait till 2.2.2 to try this again.

  25. Michelin
    Member
    Posted 7 years ago #

    Have just come across, and installed, an alternative called WP Super Edit at http://www.funroe.net/projects/superedit/
    This seems to be working OK in WP 2.2.1 (via Firefox) and at least gives the extras I'm needing, though not all... has an Options page, much easier than my attempts with the "advanced TinyMCE" plugin... less convoluted...

  26. blogs4God
    Member
    Posted 7 years ago #

    ignotus/Paul - you were soooo close - close enough that I think I figured out the rest of the story ...

    I tried your hack ... got the same results. Looking over the add() method, immediately became obvious that the argument '20070326' was a date ...

    ... so in my case, it meant from the command line:
    ls -la /wp-includes/js/tinymce/tiny_mce_gzip.php

    this gave me a date, and for example purpose we'll say it's 2007-04-27

    ... once I had the date of my filesystem's install ... I ammended the now infamous line 29:
    $this->add( 'tiny_mce', '/wp-includes/js/tinymce/tiny_mce_gzip.php', false, '20070326' );

    to read like:
    $this->add( 'tiny_mce', '/wp-includes/js/tinymce/tiny_mce_gzip.php', false, '20070427' );

    And viola, buttons back - life is good - well at least I can again edit visually over at healyourchurchwebsite.com again!

    Personally, this may be a result of file date changes that occur for those using various installer packages or hosting providers provide ... which I only recently used instead of hand-coded installs just to help manage version control.

  27. bandersen
    Member
    Posted 7 years ago #

    Your change (the date) for line 29 worked for me, blogs4God. Thanks. The RTE is back and working fine.

  28. iplainsdrifter
    Member
    Posted 6 years ago #

    Changing the date to the correct one, in addition to ignoring the date, did not change how the editor (doesn't) load for me.

    Sad face!

    I've tried all the hacks I could find on the forums...

    Now, I'm installing another visual editor and kissing TinyMCE goodbye forever (I hope).

  29. tcharles
    Member
    Posted 6 years ago #

    Hey Guys, it looks to be a browser compatibility problem, atleast on my part. I use crazy browser and it stopped working, then I opened Internet Explorer 6 and the visual editor is back working, it's just not working in crazy browser or mozilla, I hope that helps until the problem is fixed...

Topic Closed

This topic has been closed to new replies.

About this Topic