WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Visual Editor Not Working After 3.3 Upgrade (122 posts)

  1. cwsthailand
    Member
    Posted 2 years ago #

    I had the same problem, couldn't fix it either.
    So I installed CKEditor for WordPress (formally FCK Editor) and everything works fine.
    It must be a problem about javascript, not about Java!!
    Java has nothing to do with wordpress.

  2. Kekepana
    Member
    Posted 2 years ago #

    Interesting. I immediately installed CKEditor with high hopes that I would get results similar to yours. Unfortunately, I got an editing screen with all the editing tools blanked out. I wish this were resolved, but, sadly, it is not. At least for me.

  3. Gavatron
    Member
    Posted 2 years ago #

    Installing the Google Libraries plugin solved the problem for me.

    Thanks!

  4. ullasahmed
    Member
    Posted 2 years ago #

    Navigate to Users => All Users => admin => untick the "Disable the visual editor when writing" box.

    It works! perfect.

    Thanks.

  5. crucou
    Member
    Posted 2 years ago #

    THIS WORKED FOR ME!

    5 Steps to restore your visual editor in WordPress 3.3

    1. Through your admin panel in WordPress , disable all plugins and leave them disabled until the finish of these steps

    2. Now through your wordpress admin panel go into users , click on your username and edit settings , at the top you will see the area to enable or disable the visual editor , click on this to disable , yet definately disable this visual editor for the time being.

    3. Now through the wordpress admin panel go into your posts and click on one of them to edit , you should now see your text in the post , this will be in Html format , exit out of this area back to the main admin area.

    4. Click on appearance and change your theme to Twenty Eleven , active the theme and click F5 to clear the cache. Once you have done this now go back into your user settings , edit your profile and enable the visual editor , always remember to save your settings at the bottom of the screen.

    5. Again click on one of your posts to edit and you should now see the visual editor has begun working , exit out of this area back to the main admin area and change your theme back to the original theme that you were using.

    6. Now go thru and re-activate each plugin one at a time , if after activating a plugin your editor is not working than you have to keep the plugin de-activated until it is updated to be wordpress 3.3 compliant.

    Restoring your Visual Editor in WordPress 3.3 via FTP

    1. Login in to your FTP account , under public_html find your site , proceed to wp_content / plugins, rename this folder to oldplugins , now log into your WordPress admin account and see if your visual editor is working , if it is then again it is a plugin related conflict , if it is not working , manually upload the wp-includes folder and overwrite the existing folder. This should have your site up and running again.

  6. cbernardi
    Member
    Posted 2 years ago #

    For me the issue was a JS conflict between the cforms plugin (version 11.5) and the JS used for the editor. Deactivating it restored the visual editor functionality. I used FF and Web Console to narrow it down. Hope that helps some one.

  7. dotwebs
    Member
    Posted 2 years ago #

    I went through all the suggested fixes here and nothing worked. In the end I discovered that it was a simple fix.

    Go to 'Users' click on 'admin' make sure that 'Disable the visual editor when writing' is unchecked. Do this for all users.

    I'm kicking myself that I didn't see this before. Hope it helps someone here.

  8. bridgetwes
    Member
    Posted 2 years ago #

    I was having the same issue but my solution is very different from the ones already posted. I too used FireFox and Web Console to narrow it down. I am using a Woo Theme and running Apache on Windows 7 locally (this was not happening on my live site running under Linux). The Web Console said it couldn't load a javascript file found in my themes/[themename]/functions folder. When I looked in that folder the icons were green because they were encrypted to secure data. After I removed that attribute (right click on folder -> Properties -> Advanced, Uncheck Encrypt contents to secure data) the forms started working.

    It appears there are a lot of ways TinyMCE can get messed up in the admin forms. If the problem is happening in Firefox, count yourself lucky. Run the Web Console, found under Tools -> Web Developer and see if you get an error that can lead you to an answer.

  9. fanale
    Member
    Posted 2 years ago #

    I have tried everything
    - change theme
    - disable plugins
    - install google libraries
    - different browsers
    _User admin changes etc etc

    Everything still no joy - please help I have been working on this issue for over 6 hours

  10. fanale
    Member
    Posted 2 years ago #

    Issue resolved for me

    I am on a mac and use VirusBarrier X6. IT bumped out security settings on our computers and under the 'surf' menu checked the box :

    Hide information about my computer and web browser

    This must suppress certain javascript or something like that as it was preventing the Visual and HTML tabs from being displayed

    Unchecked that box in virus protection voila they reappeared. Wish I could get my 8 hours back :(

  11. michaelphipps
    Member
    Posted 2 years ago #

    Before you waste hours switching off / on plugins, check the javascript debugger in your browser!

    For me, it turned out TinyMCE was looking for a missing en.js file (non standard) instead of wp-langs-en.js

    I just copied the wp-langs-en.js file to en.js and the visual editor came back. There's some more detailed instructions here: http://wordpress.org/support/topic/visual-editor-not-working-mimicing-html-editor-blanking-out-no-tool-bar

  12. TJ Kelly
    Member
    Posted 2 years ago #

    I tried everything listed, including the wp-langs-en.js fix michaelphipps posted above. Nothing worked.

    My Chrome Inspector says:

    "Cannot read property '0' of null" in "/wp-includes/js/tinymce/plugins/wpeditimage/editor_plugin.js?ver=349-20805"

    Also, I noticed that I only have this problem on one post. It has non-standard characters in it (French: é and è). I removed those characters and replaced them with character codes: é and è That didn't seem to help.

  13. satvinderjit
    Member
    Posted 2 years ago #

    i want to change sliders images with change in category in header how to do this plz rply

  14. PineapplePlayas
    Member
    Posted 2 years ago #

    Thank you len7288! Your solution worked for me:

    1. admin area then
    2. users then
    3. your profile
    4. on my profile area he uncheck the box at the top of the page which says disable the visual editor when writing.

    Hurrah!

  15. mepoooo
    Member
    Posted 2 years ago #

    I just installed Google Libraries and everything is ok. No needed to change theme here.

  16. doland
    Member
    Posted 2 years ago #

    AHA! Thanks,
    michaelphipps

    All I did was update my TINYMCE plugin which was calling for an update anyway and voila - it worked.

    None of the other suggestions worked (google libraries, empty cache, etc.) Should have known because it happened on 3 different browsers.

    Mac here. Normally use Chrome, but same problem on Safari and Firefox.

  17. TrailerTrash
    Member
    Posted 2 years ago #

    This is total crap! I have the same problem and nothing works, im gonna sue all people answering solution, I just wanna die now.

  18. esmi
    Forum Moderator
    Posted 2 years ago #

    This is a wind-up, yes?

  19. Or is it a plaintive cry for help?

  20. esmi
    Forum Moderator
    Posted 2 years ago #

    Threatening to sue anyone who has posted a solution is hardly going to elicit further help.

  21. jackyyong
    Member
    Posted 1 year ago #

    Realized that IE does not have this problem, only Google Chrome. Once installed "Use Google Library", everything is fixed!

  22. Andrew
    Forum Moderator
    Posted 1 year ago #

    This is total crap! I have the same problem and nothing works, im gonna sue all people answering solution, I just wanna die now

    Rest in peace.

  23. rishitron
    Member
    Posted 1 year ago #

    Hi, Even I faced the same problem. So there are 3 checks you need to do.

    1. Disable all plugins and check. if works, activate one by one. If not step-2.

    2. Go to your hosting site, click on ftp and you will find the file called "wp-config.php". download the file and add the following line in that, save it and upload it back.

    the line : define('CONCATENATE_SCRIPTS', false );

    If works, fine, if not step-3

    3. ursite/wp-admin and access the dash board. click on users. select the username you are trying to post. there is an option called "deactivate visual editor while posting". make sure its unchecked.

    The above options should work. if not there is some problem. may be u can reload the theme and check. Cheers !

    http://www.ivfox.com

  24. cstambush
    Member
    Posted 1 year ago #

    I was frustrated with the same issue and found that dotwebs' solution of....

    "Go to 'Users' click on 'admin' make sure that 'Disable the visual editor when writing' is unchecked"

    ....was the answer to my frustration.

    Thanks.

  25. pocketdynamo
    Member
    Posted 1 year ago #

    This has recently happened to a site of mine which needs to go to a client tomorrow. :-(

    Anyway, I read all the messages in this thread. Downloaded the Google Libraries - no fix. I then disabled all plugins - no fix. Changed theme to Twenty Eleven - no fix. I then checked other Javascript settings etc - no fix.

    So, I hovered over Dashboard and chose 'Updates'. I then chose 'Reinstall now'. The version I am running is 3.4.2.

    My editors now work. I also noticed there was a bug with featured images section too.

    Hope this helps someone.

  26. Jackmagic
    Member
    Posted 1 year ago #

    Hey everyone.

    I have solved my issue. None of these solutions worked for me. I found a media file in 'Media' That was corrupt. I deleted it, now it all works.

    http://www.diigo.com/item/image/27qt1/pnta?size=o

    Solutions:
    http://support.goodlayers.com/editorpage-option-is-not-showing/

    Hope everyone works their issues out.

  27. toberight
    Member
    Posted 1 year ago #

    I had a new install of 3.4.1 and was experiencing this problem. Tried all recommended fixes.

    What worked for me was to re-install WordPress from the Updates page. It said that I did not require any updates, but I did it anyway using the automatic update.

    The update took about 20 seconds and it came back up with the HTML/visual editors working and toggling fine.

  28. MarioMagdic
    Member
    Posted 1 year ago #

    Disable magic_quotes_runtime. This seems to be causing the problem because it escapes the Javascript code and therefore creates syntax errors in the js Code.

    magic_quotes_gpc = Off
    magic_quotes_runtime = Off
    magic_quotes_sybase = Off

    Step by step here

  29. chiwaili
    Member
    Posted 1 year ago #

    Google Library update worked for me, not the ideal situation but at least it's resolved.
    Thanks folks

  30. robaato
    Member
    Posted 1 year ago #

    For me it was the plugin "Empty Paragraph in TinyMCE editor" which was causing the problem...

Topic Closed

This topic has been closed to new replies.

About this Topic