WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Visual Editor Not Working After 3.3 Upgrade (122 posts)

  1. bjobson
    Member
    Posted 2 years ago #

    So after I downgraded to 3.2.1 everything was working fine for a while. Now it's back to the same problem. Not sure what it could be this time. I've tried everything. HELP!!!

  2. carlweaver
    Member
    Posted 2 years ago #

    bjobson,

    I am in the same boat. None of this worked for me. This is a new install I am having trouble with. Older installs that I have upgraded to the current version are fine. I can only conclude that there is a difference between the new version and the auto upgrade version.

    :(

  3. len7288
    Member
    Posted 2 years ago #

    I'm using the latest version of wp and yesterday I encountered this problem, so today it was resolve my my host CSA. What he did is he went into my
    1. admin area then
    2. users then
    3. your profile
    4. on my profile area he uncheck the box at the top of the page which says disable the visual editor when writing.

    and now its working fine. I hope this will help you.

    len7288
    http://www.healthandbeautypages.com

  4. davidbick01
    Member
    Posted 2 years ago #

    No good Len7288, I'm afraid.The box was unchecked anyway! Maybe it works for others.

  5. neilster
    Member
    Posted 2 years ago #

    In wp dashboard,try going to users, then profile, make sure the disable visual tab when writing is not checked.

  6. Sebaztian
    Member
    Posted 2 years ago #

    It seems like if any of the above mentioned suggestions doesn't work you have no option left than to downgrade. It's fascinating how it affects so many people, but nobody was able so far to figure out what the actual reason for this problem is, or even, if it's only one issue or a handful of reasons

  7. Sebaztian
    Member
    Posted 2 years ago #

    Everything is working for me now again. What actually helped was the following change in the config file:

    define('WP_MEMORY_LIMIT', '128M');

  8. developerscentral
    Member
    Posted 2 years ago #

    Yes , I have same problem but I just switch my theme to the default and back to my theme any visual editor back online.
    Thank you !!

  9. deswalsh
    Member
    Posted 2 years ago #

    With 3.3.1 installed. Have Tiny MCE Advanced plugin installed and active

    Visual Editor was not working in Chrome or Firefox but was working in IE9.

    Tried deactivating all plugins - no difference.

    Installed and activated Google Libraries plugin, Visual Editor now functioning in all three browsers.

    Thanks to everyone for all the suggestions, esp re Google Libraries plugin!

  10. livingzombie
    Member
    Posted 2 years ago #

    The following is how I fixed a site with the same issue, however this required digging into the database. Not for the 'faint of heart' ... proceed with caution.

    I resolved this by viewing errors in a web inspector. Found there was some issues with the domain name pointing to an old host (this site was also migrated to a new host for this 3.3.1 upgrade). I search the database wp_options values for the incorrect domain name and changed them all to the correct domain name and all is working perfectly. I hope this helps someone.

  11. faqvideo
    Member
    Posted 2 years ago #

    Navigate to Users => All Users => admin => untick the "Disable the visual editor when writing" box.

    That helped me.

  12. bjobson
    Member
    Posted 2 years ago #

    I've had good and bad experiences since downgrading. The good news is that the visual editor now works. The bad news is that it works when it wants to. The editor flips back and forth from working to not working. This is the best I can get so far. Nothing else even got me this far.

  13. ruslyrossi
    Member
    Posted 2 years ago #

    i follow all suggestion..and it's work in almost all browser but no with firefox(firefox version 11).. i test with firefox version 3.6 and its work..i don't know how to fix this(browser problem ???)

  14. magicwings
    Member
    Posted 2 years ago #

    I've been having the same problem on and off for the last week or so, but it has been leaving of it's own accord.

    Now however it's stuck for hours and I'm unable to update my site. None of the solutions here have worked for me - and I've tried every single one, bar downgrading to an earlier version of WP.

  15. Dominicoben
    Member
    Posted 2 years ago #

    Hey guys. I was having the exact same problem and literally tried everything. - including the downgrade and re-install, google libraries plugin, new wp-includes, clear cache ...
    none of it worked.

    SO I deleted my .htaccess file and it's now working!!!!!!!!!!!!
    I am soo happy! SO delete your .htaccess and see if that fixes it!

    It should be in your cpanel public_html
    Make sure that the "Show hidden files (dotfiles)" is ticked.

    Then delete and the problem is fixed (at least, it was for me!)

  16. Hoib
    Member
    Posted 2 years ago #

    I have two desktops and one laptop. I've narrowed this "no visual editor" to just one desktop. I use IE8 solely all around. So, on the one desktop, I've followed all the "tick this on and off", clear cache, reload browser with F5, go into edit/F5 come back in suggestions. Kill IE and use XP Pro's Control Panel Internet Options to clear history, cache and cookies. Only on this one machine, it's broken. It's unfortunate as it's my one main machine I use for this. I do not have server level access so no going to take out hta.access.

    Question please: Are we able to use another IDE like a Dreamweaver to edit our WP blogs? Anyone tried that? That would get me out of this silliness and on to more important things.

    H

  17. tblajoie
    Member
    Posted 2 years ago #

    Hey all, I've been having similar problems with the Visual Editor not working in 3.3. In my case the Visual Editor tab would never show up. I tried a bunch of the fixes in this thread to no avail until I remembered that I have the Intego VirusBarrier X6 app on my machine and I had "Information Hiding" turned on (I think its a default). After turning that off the Visual Editor panel came back. Turn it back on and the VE disappears.

    So, for those of you who aren't having any luck with the prescribed fixes try looking to see if you have anything running on your machine that might be interfering.

    Hope this helps.

  18. janeprinsep
    Member
    Posted 2 years ago #

    Hi
    I've been having this Visual Editor problem for a couple of days. I installed this plugin after reading numerous forums and it has fixed the problem.

    http://wordpress.org/extend/plugins/fckeditor-for-wordpress-plugin/

    Hope this helps.

  19. turboN13
    Member
    Posted 2 years ago #

    Google Libraries plugin solution solved it for me.

    Thanks.

  20. chayan
    Member
    Posted 2 years ago #

    I had the same problem.
    On my website the problem was the plugin "WordPress User Frontend"
    After updating to 0.7 the problem was there.
    With 0.6 it works fine.
    If you were so smart to make a backup from your website, just copy the old
    "WordPress User Frontend" files with ftp to your website.
    Then you will again have 0.6.

  21. magicwings
    Member
    Posted 2 years ago #

    Dominicoben wrote
    Hey guys. I was having the exact same problem and literally tried everything. - including the downgrade and re-install, google libraries plugin, new wp-includes, clear cache ...
    none of it worked.

    SO I deleted my .htaccess file and it's now working!!!!!!!!!!!!
    I am soo happy! SO delete your .htaccess and see if that fixes it!

    It should be in your cpanel public_html
    Make sure that the "Show hidden files (dotfiles)" is ticked.

    Then delete and the problem is fixed (at least, it was for me!)

    Working it may be, but deleting the .htaccess file is dangerous as it contains the security settings for each folder. I'd try and find a different way to achieve it.

  22. bjobson
    Member
    Posted 2 years ago #

    So WP has a new upgrade available now. I'm afraid to update because there might be some more bugs in this update. Has anyone heard of any issues with the latest update released this past week?

  23. @bjobson, reports have been low and please start your own topic.

    Your question has nothing to do with the topic of visual editor not working.

  24. bjobson
    Member
    Posted 2 years ago #

    Excuse you but yes it does. I've had the visual editor problem and I'm asking if the new update has the same issue.

  25. carlweaver
    Member
    Posted 2 years ago #

    @bjobson - I updated but that did not fix the problem. It didn't seem to create any new problems, though, so I would recommend doing it.

  26. lernerleben
    Member
    Posted 2 years ago #

    Hey, everyone, after having problems with 3.3.1 and the viz editor, tried all of the solutions but failed, stumbled over this:
    define( 'CONCATENATE_SCRIPTS', false );

    placed in wp-config.php

    And it solved my problem.

    Thanks to this person

    Hope it works for you.

  27. ronavroberts
    Member
    Posted 2 years ago #

    Deactivated all plugins in an effort to figure out what is causing terrible slowing down when I'm in admin. (90 secs to save, for example.) Lost visual editor. Remembered I had spent two other manic periods trying to solve this problem, and had eventually solved it, but have spent a harried hour trying to remember how. In my case, it's the "Use Google Libraries" plugin. I have updated to 3.3.2 and did not lose the visual editor. I have not activated other necessary plugins, but will report back here if there is a problem with any of them.

  28. Kekepana
    Member
    Posted 2 years ago #

    I am amused and frustrated that people think this issue is resolved. I may not be the expert on WordPress that some others of you are, but I believe I have tried every "fix" in this thread. I still don't see a button to access the Visual Editor when I edit or initially draft a post. I have switched to twenty-eleven, have de-activated and re-activated every plug-in (together and separately), have cleared browser caches multiple times, have updated and reinstalled Java, and I am using Google Libraries.

    I use a Mac with OS X 10.7.3. No Visual Editor in either Chrome (18.0.1025.168) or Safari (5.1.5 (7534.55.3)). Curiously, I am able to use Visual Editor in Safari on my iPad. But not in the AtomicWeb browser or the WordPress app for iPad.

    I would appreciate any ideas, because I would love to use Visual Editor on my Mac.

  29. latituderesorts
    Member
    Posted 2 years ago #

    A very nice idea in theory to start a new thread, BUT it just sits withthe thousands on un assisted threads. I have personally now started over 10 threads and not got a response from one! At least with a discussion on a thread people are already talking.... This forum is next to useless.

  30. golfball-uhu
    Member
    Posted 2 years ago #

    I have the same problem. Downgrade WP from 3.3.2 to 3.3.1 makes no sense for me because my test-page running on a subdomain is working with 3.3.1 and has the same problem.

    change the theme did´t work as well.

    installing the "Google Libraries plugin" which means your javascript libraries are hosted on googles CDN is a indication that´s something wrong with the javascript. I´m already using Amazons S3-CDN so I don´t know whether it´s a good idea to use "Google Libraries plugin" in addition!?

    Also a Java-update and Computer restart did not work for me!

Topic Closed

This topic has been closed to new replies.

About this Topic