WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Visual editor non-existant? (13 posts)

  1. kunoichikat
    Member
    Posted 1 year ago #

    I don't seem to have a visual editor in my wordpress. I'm new to self hosting but I've used wordpress before. Now, I'm not that much of a techie but I have done a couple of obvious things like reinstalling wordpress, deactivating all plug-ins and returning to the default theme. Still nothing. What should I do?
    If it will be of any help I use Opera and Mozilla and my host is hostgator.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. kunoichikat
    Member
    Posted 1 year ago #

    Oh no. I have no idea how to do the reuploading thing. :( I'll try resetting the plugins in the meantime.
    Is there any chance that I need to manipulate the wp-content.php code? I've already backed it up and opened it just in case :)

  4. kunoichikat
    Member
    Posted 1 year ago #

    Just reset the plugins. Still not working :/

  5. shirazdrum
    Member
    Posted 1 year ago #

    Switch your theme to the default theme to see if it was blocked from your current theme function.

  6. kunoichikat
    Member
    Posted 1 year ago #

    I already reset my theme. I'm using twenty twelve. Still no visual editor. I tried to follow this method I found online http://www.semantica.co.za/latest-news/wordpress-3-5-1-visual-editor-bug-hottemporary-fix/

    but nothing :( Though I edited the code directly from cpanel rather than in notepad.

  7. kunoichikat
    Member
    Posted 1 year ago #

    would downloading the file and editing it make any difference?

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Try adding define('SCRIPT_DEBUG', true);to the bottom of your wp-config.php file (just before the require_once line).

  9. kunoichikat
    Member
    Posted 1 year ago #

    I added that and when I try to open my wp-admin it says gives this error message
    Parse error: syntax error, unexpected ',' in /home/annette/public_html/wp-config.php on line 93
    Line 93 is where I added the SCRIPT_DEBUG

  10. kunoichikat
    Member
    Posted 1 year ago #

    Oh missed out the 'define'. Added it now and it opens up but still no visual editor. Sigh :( Isn't there a good WYSIWYG plugin I can get instead or something?

  11. kunoichikat
    Member
    Posted 1 year ago #

    Would it help if I deleted everything and started over again? I haven't put much up on my site.

  12. kunoichikat
    Member
    Posted 1 year ago #

    I solved my problem! The solution was so simple I cried. I've been trying to figure it out since 9 in the morning and it's almost midnight. The visual editor was disabled in my user options. I fixed it like so...
    http://wpmu.org/a-complete-guide-to-the-wordpress-visual-post-editor/
    I'M SUCH A HAPPY IDIOT RIGHT NOW!

  13. kunoichikat
    Member
    Posted 1 year ago #

    Guess it's too late for the Valentines day post I was counting on. Oh well.

Topic Closed

This topic has been closed to new replies.

About this Topic