WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Visual Editor missing, profile is right (10 posts)

  1. jefferisp7
    Member
    Posted 2 years ago #

    The visual editor toolbar is missing on 2 different WP sites on 2 different servers, one of them is WordPress.com. I am the only user and the disable visual editor is Unchecked, meaning it should be visible. Makes editing very hard.

    I find this happening a lot on multiple sites I manage.

    I am using Safari and Lion on a Mac. Do not have ad blockers installed.

    Any help appreciated.

  2. krembo99
    Member
    Posted 2 years ago #

    which toolbar ? all of them ? I am sorry I must ask such a trivial question - but you do know that the last button (left) on the first toolbar will "open" the second one ?
    Also - do you use custom themes / plugins that might have disabled the mce ?

  3. jefferisp7
    Member
    Posted 2 years ago #

    THis isn't a toolbar issue but a Tabs issue of HTML and Visual tabs, which are missing. Plus there is no option button to open the second row of buttons.

  4. krembo99
    Member
    Posted 2 years ago #

    ok.. in your original question you asked about "toolbars" and not the "html, visual" tabs .

    in that case :
    Users > admin > edit
    Make sure the 'disable visual editor when writing' box isn't ticked.

    Users > Your Profile
    Again, make sure the 'disable visual editor when writing' box isn't ticked.

    you should check those values in BOTH places to make sure for all users.

    If still no-go , you will need to revert to default theme, disable all plugins, and check where is the culprit .

    (and BTW - the button to open the second toolbar is THIS ONE.

  5. jefferisp7
    Member
    Posted 2 years ago #

    Okay, but there is no Users > admin >
    It goes to Users> and I am the only one there and am also the admin
    The ONLY place I can find that check box in in Users> My Profile. When I go to Users> and see my name and click on it the checkbox is not in that area. It goes to My Public Profile.

    I have NO plugins enabled in the WordPress.org site and it is a standard theme from WP. I cannot enable plugins in WP.org.

  6. lunahak
    Member
    Posted 2 years ago #

    Me too, I was use with 2 servers on different provider but i have the same problem. However when I was check on localhost that good.

    Thanks

  7. bjprc
    Member
    Posted 1 year ago #

    I have the same problem, no more visual editor. Using WP 3.4.1 on several servers and several blogs. Firefox latest version on MAC. After the latest update of WP, Visual Editor is gone. Box under My Profile is unchecked. Using the standard theme. Nothing was changed in terms of plugins. No idea...

  8. bjprc
    Member
    Posted 1 year ago #

    I read somewhere the JS folder in the wp-admin folder could be missing and should be uploaded again by FTP. Anybody has an idea about this?

  9. bjprc
    Member
    Posted 1 year ago #

    Problem solved! Simply install plugin "Use Google Libraries". JS folders were not missing, so that is not the problem.

  10. jefferisp7
    Member
    Posted 1 year ago #

    My problem appears to be related to anti-phishing or filtering settings using Virus barrier... Turn them off and the visual editor reappears.

Topic Closed

This topic has been closed to new replies.

About this Topic