WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Visual Editor missing and broken in 3.1 (59 posts)

  1. themightyant
    Member
    Posted 3 years ago #

    Hi,
    I have seen that others are having similar problems that may or may not be related.

    The Problem

    1. Just upgraded to 3.1 through automatic upgrade on the dashboard
    2. The Visual editor GUI is missing and text appears in white. (see image)
      http://www.flickr.com/photos/60163908@N04/5515622066/
    3. Once 'Visual' is clicked again text appears but in html (see image)
      http://www.flickr.com/photos/60163908@N04/5515030857/
    4. The front end of the website is fine

    What I have tried

    • I have read a lot of similar posts here and gone through the 'Troubleshooting WordPress 3.1 - Master List' and tried the following without any luck so far
    • Checked other browsers (Chrome, Firefox, Safari)
    • Disabled and re-enabled visual editor in my profile
    • Deactivated all plugins
    • Switching to the Twenty Ten theme
    • Resetting the plugins folder by FTP (renaming folder, creating a new one and visiting admin page)
    • Disabled the Admin bar
    • Downloaded and re-uploaded a fresh copy of the wo-admin and wp-includes folders
    • Checked I am running PHP 5
    • Upgraded the php memory limit to 64MB through .htaccess, wp-config and memory-bump plugin (shared hosting no access to php.ini)
    • Tried adding the following code to wp-config
      define('CONCATENATE_SCRIPTS', false);

    None of the above worked does anyone have any suggestions?

  2. Tara
    Member
    Posted 3 years ago #

    have tried:

    -increasing memory available for php.

    -if that does not help, try deactivating ALL plugins temporarily to narrow down and possibly fix the problem. If the problem goes away, activate them individually (one-by-one) to find the culprit.

    -if that does not help, try switching to the default theme ("twentyten") for a moment by renaming your current theme's folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

  3. themightyant
    Member
    Posted 3 years ago #

    Hi t-p,
    thanks for the suggestions however as I mentioned in my initial post I have already tried ALL three of these and none of them have worked.
    Just to clarify, in addition to what I mentioned above, I have already tried

    • Increasing the memory available for PHP
    • Deactivating ALL plugins (by renaming the plugins folder and replacing it with an empty one
    • Switched to Twenty Ten theme
    • In addition I tried renaming the themes folder and replaced with an empty one

    None of the above have worked.

    Temporary Fix
    In the meantime, for anyone else who is experiencing the same problem, I have installed the CKeditor (by CKSource) which uses a different visual editor than the default wordPress one. While this works for the moment this is not a fix.

    If anyone else has any suggestions I would love to hear them or if anyone has solved this problem what steps did you take to resolve it.

    Many thanks

  4. Tara
    Member
    Posted 3 years ago #

    In addition I tried renaming the themes folder and replaced with an empty one

    - have you tried the same with the plugins folder

    -also, have you reviewed: Troubleshooting WordPress 3.1 - Master List

    --If the above steps do not resolve the issue, Download WordPress again and replace your copies of everything EXCEPT the wp-config.php file and the /wp-content/ directory with fresh copies. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory.

  5. themightyant
    Member
    Posted 3 years ago #

    Hi t-p, I hope you had a good weekend.

    While I appreciate the suggestions, I have already tried ALL of these as I had mentioned in my first post.
    Yes to plugins, Mater list & reinstalling WordPress manually.

    I should say that I am not new to WordPress I am a Web Developer who has built dozens of WP websites for clients. As such I checked the forums and worked at the problem BEFORE starting this thread as solutions are usually already here. I only posted AFTER I had tried all of the potential solutions I could find without any progress.

    Thank you for trying though.

  6. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    Do you have any other WP installs running on the same server? Just want to see if it could be server related.

  7. themightyant
    Member
    Posted 3 years ago #

    Hi Rev. Voodoo,thanks for the prompt response.
    No other WP installs on that server. It is on shared Linux hosting with 123-reg.co.uk I have updated seven other sites with no problem and am hesitating updating another 15 or so until I know what the problem is with this one in case the problem occurs again.

  8. aaronkarp
    Member
    Posted 3 years ago #

    I may have an insight on this, or at least a description of what seems to be the problem on my instance. Are you using cForms? Even if you're not, a similar issue may be at the root of your woes. I found that some browsers are choking because my admin pages are https://, but some elements are coming over non-secure connections. Specifically, the cForms icon that appears in the TinyMCE toolbar was being flagged as insecure and not loading, which seemed to gum up the loading of the entire TinyMCE environment, causing the Visual Editor not to display and the text to remain white/HTML.

  9. aaronkarp
    Member
    Posted 3 years ago #

    Follow-up: If you are using cForms, the easiest way to fix this problem is to go into cForms settings and uncheck Enable TinyMCE & Code editor buttons in the WP Editor Button support section of Global Settings.

  10. themightyant
    Member
    Posted 3 years ago #

    Hi Aaron, thanks for the input.
    I am not running cForms but have looked through my other plugins options to see if there was anything similar. There wasn't.

    Shouldn't disabling all plugins (via renaming the Plugins folder) negate the need for this anyway?

    I am going to try and install a fresh blog on the same server to try and ascertain whether it is server specific. I am a little tied up with another website launch today but will report back asap.

    In the meantime if anyone has any further ideas i'd love to hear them.

  11. aaronkarp
    Member
    Posted 3 years ago #

    Yeah, I was thinking that disabling all of the plugins would have negated any effect like the one I was seeing, but I thought I'd mention it anyway, just to be sure. Sorry this didn't help you. I guess mine was a rather specific case.

  12. Rudha-an
    Member
    Posted 3 years ago #

    I am having the same problem as themghtyant. I have followed his/her checklist and there is no resolution to the problem. It occurs in Firefox and IE8.

  13. themightyant
    Member
    Posted 3 years ago #

    Hi Rudha-an,
    Have you tried with other browsers too (eg:Google Chrome) or is this limited to Firefox and IE8?

  14. Rudha-an
    Member
    Posted 3 years ago #

    Sadly, I haven't. I don't use them. I can only speak for Firefox and IE8. I did switch to the Weaver theme, but that isn't the problem either. Aside from that, I've not added anything new. Visual Editor was working fine yesterday.

  15. themightyant
    Member
    Posted 3 years ago #

    Rudha-an,
    you should check with another browser. There were some others on this forum who were saying that it only happened in some. This may or may not differentiate your problem from mine. Good luck

  16. werendle
    Member
    Posted 3 years ago #

    Hi All, I had been around in circles for ages on this one, until when talking a client through the back end they clicked on 'Show / hide kitchen sink' right in front of me.
    It turned out to be as simple as that.
    Hope it helps someone else,

  17. themightyant
    Member
    Posted 3 years ago #

    Hi Werendle, thanks for the suggestion. I'm glad you got your problem sorted. However this doesn't sort this problem as there is NO visual editor at all (see image link on flickr) so no show/hide kitchen sink button to click.
    http://www.flickr.com/photos/60163908@N04/5515622066/

    Thanks for the support though, I appreciate it.

  18. Rudha-an
    Member
    Posted 3 years ago #

    And now for bizarre news...

    We took a break for the problem for a while. Today, my husband decided to post a movie review, since HTML works fine. Everything was back to normal. NORMAL??? We made no changes. We did not add or delete anything. The visual editor is working normally now. This is beyond strange.

    Yes, we did reboot the computer. We did that several times during the visual editor problem and it didn't make a difference then. Otherwise, I'm without a clue. I realize that this doesn't help, but I figured the update could be useful to someone.

  19. foodalogue
    Member
    Posted 3 years ago #

    Just installed 3.1 yesterday and have the same problem in visual edit (no toolbar). I am not a web developer and do not understand any of the suggestions above.

    I've always updated via 'automatic' without problem and this is very upsetting.

    If there is no fix, how can I return to older version?

  20. esmi
    Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - checking through Troubleshooting WordPress 3.1 - Master List

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  21. rosyid
    Member
    Posted 3 years ago #

    to fix it just adding define('CONCATENATE_SCRIPTS', false );to wp-config.php and you get working visual editor... good luck

  22. foodalogue
    Member
    Posted 3 years ago #

    Thanks, I was able to get it back by deactivating plug-ins and then re-activating.

  23. Tara
    Member
    Posted 3 years ago #

    Glad to know you got it back. :-)

    Please mark thread as "resolved" using the dropdown in the right panel so that:
    - others with similar problem can see it as "resolved" and will read this thread for help if they have similar problem.
    -volunteers providing help see it as "resolved" and will not waste time reading it.

  24. foodalogue
    Member
    Posted 3 years ago #

    Would be happy to mark as 'resolved', but there is no option for it on this page. Sorry.

  25. themightyant
    Member
    Posted 3 years ago #

    Hi t-p this is not his thread, so he can't mark it 'resolved' it is now midnight in the UK, I will try the most recent fix in the morning, fingers crossed it will work, I have tried every other suggested solution to no avail.
    Many thanks
    theMightyAnt

  26. kbarncat
    Member
    Posted 3 years ago #

    I don't see how hitting "resolved" when other users on this thread are NOT AT ALL resolved is even ethical. "themightyant": thank you for laying out the case clearly. Amen to everything you said. My problem was across FF, Chrome, Safari, IE. I will be interested in seeing what happens when my host, Netfirms, which has just been purchased, finishes migrating. Over the period of my initial posting, I was finally getting emotional in my writing, and was reprimanded for posting on several like threads. But how are you supposed to learn anything if you don't read all the threads and try all the suggestions? And then to post the results so others don't feel alone.

    Your patience here has been monumental. But in the end, all you will get is silence. Existential statement, I know. But I am smarting from this experience.

    my "fix" has been to go back to 3.0. Some fix.

  27. Expressions
    Member
    Posted 3 years ago #

    themightant.
    Have you resolved your issue? Because I'm having the same problem with one of mine.

    I have 2 wp sites on the one hosting account. Use FF. Only 1 site is having this issue.

    Have also done all the above suggestions with no success.

    Don't want to hear from anyone that its a hosting server issue because its not. Have 3 other clients using the same hosting & no problems with their wp sites.

  28. kbarncat
    Member
    Posted 3 years ago #

    I am very disappointed that you've knocked out the server possibility. All my hopes were pinned on the otherwise disturbing sale of my host to some unnamed and probably more expensive company (a la Mozy). I'm still running 3.0 as my fix, which means that I've tried everything to no avail. It's so odd - every suggestion made has worked for some but done nothing for others. I wonder what tiny line of code in the new version could be so widely applied.

  29. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    As I understand it, the menu bar and other items in the editor are javascript driven. For several having a problem, deleting the wp-includes and wp-admin folders and reinstalling new wp files has helped. In a previous version, some time ago, one person did this three times before having any success.

    You can check your java here, http://java.com/en/download/installed.jsp?detect=jre&try=1

    WP 3.1 has been installed successfully on thousands of computers so the question is what do you, kbarncat, Expressions and themightyant, have in common on your setup other than just wp 3.1?

    .htaccess files? And

    Don't want to hear from anyone that its a hosting server issue because its not. Have 3 other clients using the same hosting & no problems with their wp sites.
    does not rule out the server issue unless all three are on the same server.
    Do your hosts have something in common? Windows or Linux servers. Error logs on the server?

  30. kbarncat
    Member
    Posted 3 years ago #

    This is an excellent answer. I will check the Java. But isn't the Java an individual computer factor? I work in two stations, one a lap top, the other a desk top. They run different versions of SnowLeopard (for various reasons), and I imagine, then, that their Java is also different. The desk top is regularly updated. The lap top is not. So it's not a problem with display on individual computers.

    Okay - as to set up, Mac in various configs. Netfirms uses Linux servers. Not Windows servers. I am using a variation of 20-10, but 20-10 does the same thing when I switch to it. When I have the courage to re-install, I'll do it manually, and I'll try the includes and admin folder replacement - though that seems very mysterious to me - especially the three time replacement. (Logic? Is this an argument for A/I?)

    I run only Askemet and comment subscription. Mine is a very simple setup. I have about four blogs, all on the same server - some of them have not been updated, some have. The ones I took to 3.1 - all different themes and plug-in set ups - all had this problem. So it really does feel like a server thing.

    I'll have to google .htaccess files.

    Thank you for this measured, logical and informative response.

Topic Closed

This topic has been closed to new replies.

About this Topic