WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editor MIA (24 posts)

  1. JessCrippsDesign
    Member
    Posted 2 years ago #

    My visual editor (and HTML editor) buttons have disappeared on all three of the sites I'm working on.

    Two use 3.4.1 and one is running an old version of WordPress 3.3.2.

    All versions I have lost the editor capabilities somewhere between yesterday morning and yesterday evening.

    I've searched threads and tried everything (cleared out caches, tried different browsers, reinstalled WordPress, deactivated and reactivated plugins and even deleted some, changed the user settings).

    Is there anything anyone out there can tell me about this? Is this a common occurence? Any help is greatly appreciated!

  2. haxxxton
    Member
    Posted 2 years ago #

    could you screen shot this for us please..

    has the entire thing disappeared? or not loaded? or partially loaded somewhere else? :(

  3. JessCrippsDesign
    Member
    Posted 2 years ago #

    The sites and all the pages are still there, but when I enter the pages themselves for editing the visual editor is just gone.

    Here is what the page editor now looks like:

    http://www.criptest.com/learning/carole/

  4. SnarkFIlms
    Member
    Posted 2 years ago #

    I'm having this same problem. It was confusing for me as well. I can only view one or two of the twenty or so pages in the visual editor. The rest show nothing whatsoever.

    Will Ryan
    Snark Films

  5. SnarkFIlms
    Member
    Posted 2 years ago #

    I hope this will be fixed ASAP

  6. Try making a backup copy of your wp-config.php file and adding this line

    define( 'CONCATENATE_SCRIPTS', false );

    If that doesn't work, try the usual troubleshooting 101 steps.

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    Give this a read too if you've just upgraded to 3.4.[1]. http://wordpress.org/support/topic/troubleshooting-wordpress-34-master-list?replies=4

  7. JessCrippsDesign
    Member
    Posted 2 years ago #

    Jan:

    Thanks for that - none of it worked. I even uninstalled WordPress and did a fresh install, and it still does not show.

    I'm also trying to run the plugin Ultimate TinyMCE and that doesn't give me any editing options either. It's the only plugin I've installed.

    Anybody have any other idea what could be causing this? Could it be my OS? I am running Mac OS X Lion V. 10.7.4

    Jess

  8. This is the worst topic for me: I've never been able to reproduce this problem.

    Have you tried different bowsers on that Mac to see if. It may be your browser?

  9. JessCrippsDesign
    Member
    Posted 2 years ago #

    Yes - I've tried Firefox, Safari and Chrome. Cleared the cache on all of them too. It's the weirdest thing, especially since it's happening across my sites and they are using different versions and are on different hosts. Hm.

  10. samgeppi108
    Member
    Posted 1 year ago #

    I am getting the same errors AND the photon uploader / add image to this post functions are not working properly.. hanging up after selection.. also tags are not being saved,, and other things .like when I click on the "chain" to make a link, nothing happens..

  11. bjprc
    Member
    Posted 1 year ago #

    Same for me. After updating different blogs on different servers to the latest WP 3.4.1, visual editor is dead on all of them, only html, very annoying and impossible to use. Using latest Firefox, latest MAC OS but I think this is not the issue. Checked several other forum entries and none seems to have the answer. Of course the box under My Profile is unchecked...

  12. bjprc
    Member
    Posted 1 year ago #

    "Use Google Libraries" plugin and all problems are solved!

  13. KimWhite
    Member
    Posted 1 year ago #

    I have the same problem on one of my sites. It is happening to multiply users using all browsers. Also on PC's and Macs.

    Can see the tab "visual" but none of the buttons or text in the box.
    can only edit post with HTML tab.

    "Use Google Libraries" did not fix it.

    Any solutions yet?

  14. Luke Woodward
    Member
    Posted 1 year ago #

    Hey all, check and make sure JavaScript is on in your browser. The TinyMCE Editor required JavaScript to run, so if it is off, poof, no editor.

  15. bjprc
    Member
    Posted 1 year ago #

    I did not have that problem, but I read in other posts some people may have the JS folder missing in wp-admin, check this and if missing download WordPress complete package, unzip and look for the JS folder then upload by FTP. I also don't understand why "Use Google Libraries" worked, but it did on different blogs with different service providers. I suspect the plugin automatic upgrade could be the reason, but no clue really.

  16. groomez
    Member
    Posted 1 year ago #

    Funny, when I use "Use Google Libraries" the dashboard breaks and also doesn't solve the problem of the visual editor showing up.

  17. bjprc
    Member
    Posted 1 year ago #

    For groomez: that is strange indeed. Honestly, I even don't know why it worked for me. In your case you might check the JS folder and desactivate other plugins or try to reload WP again (yes, sucks), in that order. Something with the new WP version is wrong but nobody has a clue. One friend had no problem at all. Explain that...

  18. Roine Oberg
    Member
    Posted 1 year ago #

    Check your PHP version.
    I rolled back from 5.4.4 to 5.2.17 and that solved it for me

  19. KimWhite
    Member
    Posted 1 year ago #

    I DID clean the cache after reinstalling wp and adding the google lib.
    works now, but not sure which did it!
    Thanks
    Kim

  20. ronald311
    Member
    Posted 1 year ago #

    Hello,

    I have the same issue with the Visual Editor but the difference is the role of the user when I access the editor: as an "administrator" there's no problem at all but as an "editor" the textarea is locked without any menu. When I change the role of the user from Editor to Administrator, the visual editor works fine.

    I've tried with "Use Google Libraries" plugin without success. Maybe is the PHP version (I have 5.3.15) or my server doesn't have the right settings? For example, when I activate the "Advanced Access Manager" plugin (among others) the website give me the error 500 all the time.

    I'll appreciate any help about this...thanks!

  21. bjprc
    Member
    Posted 1 year ago #

    Hi ronald311, yes annoying problem you have. Something must be wrong with WP as there seems to be no single solution for this, irritating. Some people have no problem at all. Nobody seems to be able to figure out where the problem sits and on what it depends. I don't understand why "Use Google Libraries" worked for my 3 blogs on two different servers and providers. WP 3.4.1 requires at least PHP 5.2.4, so you should be OK. I had to change servers because the one I was using had only 5.1.6. I only use "administrator", so no idea. At one point there was a problem with the server settings (the permissions). Did you check those? I guess you have the JS folder, otherwise administrator would not work either.

  22. ronald311
    Member
    Posted 1 year ago #

    I don't know what to do...any advices?

  23. ronald311
    Member
    Posted 1 year ago #

    What a stupid thing: I changed the value of the "memory allowed" variable in php.ini from 16M to 128M and now everything is working...sorry about this newbie mistake!

  24. bjprc
    Member
    Posted 1 year ago #

    ronald311: Not stupid at all. Maybe you found one of the key issues. I will check my php.ini later. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic