WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Visual editor lost after upgrade to 3.0 (18 posts)

  1. ronavroberts
    Member
    Posted 4 years ago #

    I have no visual editor after upgrading from 2.92 to 3.0. I have tried every fix I can locate: flush browser cache; switch to default theme and change profile preferences related to visual editor off and on; reinstall WP-content and WP-admin from a fresh download of 3.0, disable all plugins (with combinations of the other attempted fixes listed above), rename the plugins folder and create a new, empty plugins folder, and probably more that I have forgotten over the past three days. Nothing has helped. I am using Thesis 1.7, and have tried using Safari, Firefox, and Chrome browsers. Working on a Mac with OS 10.6.4.

    I'm stumped. It's probably me, and I'd love to find out just what silly thing I'm not doing. Would appreciate any new suggestions about what to try. http://www.savoringkentucky.com

  2. rrwriter
    Member
    Posted 4 years ago #

    Still searching. Has anyone else resolved the missing visual editor in a way I haven't tried?

  3. johnflufin
    Member
    Posted 4 years ago #

    Same prob here. Mac 10.5.7, FF 3.5.3. This is disappointing to say the least. WP 2.9.2 still works great.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

  5. johnflufin
    Member
    Posted 4 years ago #

    Just tested WP 3.0 in Safari 3.2.3 and all is well so this appears to be a Firefox related issue. I'll try upgrading FF and report back.

  6. goldmills
    Member
    Posted 4 years ago #

    Same problem here.
    Installed 3.0 and boom- it's gone, no icons, no text, but its there if I highlight the "empty space" where I do type, but I just cannot see it.

    Why does this happen?

    I check browsers - happens in FF and IE latest editions as of today.

    So is there a fix? How do you DOWNgrade ablog to a different lower version?

  7. envygeeks
    Member
    Posted 4 years ago #

    I can see it in everything but Chrome and here is the Chrome Debug:
    "Uncaught TypeError: Object #<an Object> has no method 'go'"

    This error might be true, very very true, since I did several searches of the TinyMCE source included with WP (AKA WP-TinyMCE) and I constantly get no results for "Go", "go", "GO" and "gO"...Seems like a tiny insight but on that was reported over six months ago and still not noticed by the "developers" who obviously don't use Debug tools or multiple browsers.

  8. johnflufin
    Member
    Posted 4 years ago #

    I fixed my missing visual editor problem by logging out and clearing my browser cache and cookies. I restarted my browser too for good measure.

    As I said before the visual editor worked fine in Safari so this led me to believe this is a browser related issue. Firefox in my case. I recently did a little research on the problem and, voila, someone suggested the steps above.

    If this doesn't work for you, you might try...

    • Go to your user profile. If "Disable the visual editor when writing" is checked, then uncheck it, click Update Profile and see if the visual editor is back.
    • If "Disable the visual editor when writing" is unchecked, then check it, click Update Profile. Now uncheck it again, click Update Profile and see if the visual editor is back.
    • Re-upload the content of the wp-includes directory from the full wordpress ZIP file in case some files only partially uploaded or became corrupted
    • Check the permissions of the wp-includes directory and the files it contains. I'm pretty sure they should be set to 755.
    • Delete page revisions

    Most of these possible solutions were suggested here
    http://wordpress.org/support/topic/visual-editor-lost-after-upgrade-to-30?replies=3

    Good luck!

  9. johnflufin
    Member
    Posted 4 years ago #

    envygeeks,

    A quick google search reveals that your problem might be a javascript issue.

    Keep in mind that Chrome is still in it's infancy compared to other well established browsers. Plus it also has a small (albeit growing) user base. I'm sure WordPress developers spend a lot of time getting their product to work on multiple browsers but I don't blame them for not giving a little used browser the same priority as IE or FF.

  10. Dave Kaufman
    Member
    Posted 4 years ago #

    @johnflufin - I was having the same issue upgrade from older to 3.x and Chrome didn't like it. Even though I have other 3.x instances open in other tabs showing the Visual editor buttons. Logging into the new upgrade site in IE showed the buttons, so at least I know the issue is browser based.

  11. johnflufin
    Member
    Posted 4 years ago #

    dave,

    Try logging out and deleting cache and cookies. When I perused through my cookies in FF I found one or two tied to the problematic WP3 install. I believe one was labeled TESTCOOKIE. But honestly I'm not sure if deleting the cookies or the cache or both fixed the visual editor. Maybe the cache or something else from other 2.9.2 installs conflicts? Who knows.

    If this doesn't work, you might try the other possible solutions in my post above.

  12. johnflufin
    Member
    Posted 4 years ago #

    Upon further review, the visual editor disappears on occasion even after logging out and deleting cache & cookies. Eventually it decides to reappear again.

    This makes me wonder if it's a server memory issue but then that doesn't explain why only certain browsers are affected. Hmmm...

  13. johnflufin
    Member
    Posted 4 years ago #

    Another possible solution from here:

    You can add a setting in the wp-config.php file define('CONCATENATE_SCRIPTS', false );

    More suggestions here.

  14. Matheus Eduardo
    Member
    Posted 3 years ago #

    define('CONCATENATE_SCRIPTS', false );

    solved to me! thanks for all! :D

  15. 55Eagle
    Member
    Posted 3 years ago #

    define('CONCATENATE_SCRIPTS', false );

    This also worked for me! Thanks!

  16. johnkgibson
    Member
    Posted 3 years ago #

    Added that to my wp-config.php...

    didn't work for me...

    I downloaded and installed Dean's Editor, maybe it will be fixed in wordpress 3.02...

  17. teapotteapot
    Member
    Posted 3 years ago #

    adding define('CONCATENATE_SCRIPTS', false ); worked for me too, and I downloaded Deans Editor which rocks!
    Thank you everyone!

  18. tonyromeo
    Member
    Posted 3 years ago #

    I tried everything I could get my hands on in these forums and others. Installed, uninstalled, modified code. But this thread made me think to try it on CHROME. And WP 3.0.4 Visual Editor was fine on Google Chrome.

    SO, I instead attacked it at the browser level. Made ANY and ALL updates to Firefox Browser.

    (Tools, Add Ons, (then at the bottom of pop-up box) Find Updates).

    I updated my JAVA, Acrobat, and Shockwave. And my Visual Editor came back in Firefox. (Not sure which one did the trick?!)

    And oddly enough? It's now working on I.E. as well...

    I am a content person, not a coder, so, I am not sure what made this work, only that it did.

    Good Luck!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.