WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editor is not running in WordPress 3.5 for my Weblog (17 posts)

  1. mothi
    Member
    Posted 1 year ago #

    Currently I have updated the new release WordPress 3.5 for my website. After that I can't able to edit my article in Visual editor mode. Its not working when I clicked over it. reply me how to resolve this ( or ) help me how to remove this WordPress 3.5 update back again. Thanks :)

  2. esmi
    Forum Moderator
    Posted 1 year ago #

  3. billhood
    Member
    Posted 1 year ago #

    I don't understand why people are so fond of directing problems with a link to a page that does not address the issue. The Visual Editor mode is a bug in WP3.5 for a great number of people. The link above does not address this bug.

  4. billhood
    Member
    Posted 1 year ago #

    I found a fix for my sites in which the Visual Editor was not showing.

    I had been working on a posting and had the Visual Editor. I went back to the dashboard and saw the notice that there was a new WP upgrade so I upgraded. Immediately after upgrading, I went back to the same post and my Visual Editor was gone and I was stuck in the Text mode.

    Knowing the there was checkbox in my profile to disable the Visual Editor, I went there and lo and behold the box was checked.

    Apparently when I upgraded to WP3.5 it reset all of my users to "Disable the visual editor when writing". I simply went to the profile of each user and unchecked the box at the top of each user's page and voila the problem was resolved.

  5. taruns
    Member
    Posted 1 year ago #

    When I updated the wordpress to its 3.5 update. Now my visual editor tab is not working . Also I am unable to add images to my photo gallery as images present in the library are not getting attached. Please help me out in this as site on which i m working is non-profit
    theshantiproject.org
    Thanks!!

  6. mawditt
    Member
    Posted 1 year ago #

    billhood, thanks for your information. I have exactly this problem and I have seen someone else say (on this support site) to uncheck the visual editor checkbox in the user/profile page. In my user profile page, I only have checkboxes for 'Keyboard Shortcuts' and 'Toolbar'. Am I looking in the wrong place? Any further guidance would be appreciated.
    Thanks.

  7. muttley
    Member
    Posted 1 year ago #

    Visual editor tab is not working and i can't insert uploaded images. I tried all solutions provided on this forum, disabling plugins, changing to twenty eleven, adding define(‘SCRIPT_DEBUG’, true ); define(‘CONCATENATE_SCRIPTS’, false ); into the wp-config.php file, but problem remains.

  8. brighamrussell
    Member
    Posted 1 year ago #

    I figured out the solution. All I need to do was delete the old WP core files and upload brand new ones. At first it did not appear to fix the issue, then I cleared cache and cookies and did a hard refresh and it started working. I hope this helps.

  9. h0rsefly
    Member
    Posted 1 year ago #

    I am brand new to web sites. I've had pretty good luck thus far, but I don't believe I ever had an editor, before or after update.
    brighamrussell - could you tell me how to work with the uploading of files; I imagine I'd need to do that at my Hostgator Cpanel?
    This started when I wanted to add a link to a pdf and word sign-up form on my site. I figured I needed the toolbar for "insert"; could be another way around? Thanks
    BTW, my theme is basic, TwentyTen, and I've checked the checkboxes, etc. in my profile.

  10. brighamrussell
    Member
    Posted 1 year ago #

    The following link answers your questions:
    http://www.hostgator.com/tutorials/ftp/filezilla/transferring-files-via-filezilla.htm

    [ solicitation for paid support moderated. Please don't use the forums to advertise your services ]

  11. RichMonk
    Member
    Posted 1 year ago #

    Thanks for posting the fix for this problem and the helpful video.
    "All I need to do was delete the old WP core files and upload brand new ones." Could you
    please specify what are the "WP core fies?" Thanks!

    Does anyone know whether WordPress will address this issue with an upgrade to the upgrade? I have 17 sites to maintain. Thanks for any helpful information.

  12. andrewevans001
    Member
    Posted 1 year ago #

    I've read a few different fixes for this error, which i am also experiencing and all of them sound very complicated. Does anyone know if WordPress are planning on fixing this bug, which seems pretty common?

  13. brighamrussell
    Member
    Posted 1 year ago #

    It is simple. Delete your wp-admin and wp-includes directories as well as all the files in the root directory. Basically your deleting everything EXCEPT the WP-CONTENT directory. Also before you delete everything, you will need to get the database name, username and password out of the wp-config.php file, because you will need to put that information back into the new file, or else you will get a database connection error.
    It is actually easier than it sounds.

    [ Solicitation for paid support moderated. Please don't use the forums to advertise your services ]

  14. ringtail
    Member
    Posted 1 year ago #

    Thank you BillHood. I have spent hours upon hours trying out the numerous solutions presented on the different boards and not only were you right that wordpress reset to "disable the visual editor" with the upgrade, but you also told me where to find the dang button to remove the "check" from. A big bouquet of thank you's to you! After literally hours of trying to get my visual editor back, you've solved it just like that.

    "Apparently when I upgraded to WP3.5 it reset all of my users to "Disable the visual editor when writing". I simply went to the profile of each user and unchecked the box at the top of each user's page and voila the problem was resolved."

  15. mc95131
    Member
    Posted 1 year ago #

    The solution suggested here, re: editing adding a line to your wp-config.php file, worked for me:

    http://wordpress.org/support/topic/post-editor-visual-tab-doesnt-work?replies=4#post-3716935

  16. bbalfour
    Member
    Posted 1 year ago #

    the solution of adding a line to wp-config.php worked for me too!

  17. nicole1214
    Member
    Posted 1 year ago #

    Hello Everyone:

    I am new to word press and I installed version 3.5. At first my Visual Editor was working fine and then it just kind of disappeared.

    I went to youtube and found that I needed to take the following steps to get my Visual Editor back.

    First you go to WordPress Admin then follow these steps and click:

    1. User
    2. Your Profile
    3. In the profile screen I Unchecked “Disable the visual editor when writing”
    4. Saved changes and my visual editor was back. I did not have to change any codes.

    Hope this helps!

Topic Closed

This topic has been closed to new replies.

About this Topic