WordPress.org

Ready to get started?Download WordPress

Forums

Visual editor is no longer showing after upgrading to 3.3 (44 posts)

  1. sjbmaine
    Member
    Posted 2 years ago #

    I've just upgraded to 3.3 from 3.2.1 on two different web sites. On each of these sites I've lost the visual editor. I do not see the tabs for "visual" and for "html". All I have is the html pane.

    I have tried the sites on two different computers. I have cleared my cache. I've done a hard refresh. I've switched to the twentyeleven theme. I disabled all plugins. I've shutdown my satellite internet and restarted (you never know). None of these efforts seem to be working.

    I suspect that this is not a WordPress issue, but I am stumped. Any suggestions would be very welcome!

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Read the sticky above particularly the part about json and javascript.

  3. esmi
    Forum Moderator
    Posted 2 years ago #

  4. lewatson
    Member
    Posted 2 years ago #

    I have a similar problem with losing the visual editor on two WP installations. I can see the Visual and HTML tabs but only the HTML tab / pane is active. I can't switch to the Visual tab.

    The first time I tried to edit a post the editor was on the Visual tab but the pane was blank except for some red underlines for misspelled words. I switched to the HTML tab to see what was happening and now I can't get back to Visual tab.

    I also deactivated all plugins and switched to the twentyeleven theme. No difference.

    Thanks for suggestions as well!!

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    @lewatson: It is considered impolite to interrupt another poster's thread. Please post a new topic.

  6. sjbmaine
    Member
    Posted 2 years ago #

    Yes, I've worked through the list and passed the json/javascript bug test. That doesn't appear to be the issue. The only thing I have not done is a manual update. I'd be tempted to try this if it were not for the fact that it's happening on two different sites.

  7. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Basically, the only thing that can cause this is a javascript conflict. But you might try replacing the wp-admin and wp-includes folders with fresh copies to rule out a corrupted file.

  8. sjbmaine
    Member
    Posted 2 years ago #

    I deleted the wp-admin and wp-include folders and then uploaded fresh 3.3 folders. This did not solve my visual editor issue on at least one of my sites (I've only done it on one site so far).

    I created an entirely new WordPress site install and I've got the same issue in this brand new site - no visual editor. This is the case in multiple browsers and on different computers.

    Still stumped.

  9. lewatson
    Member
    Posted 2 years ago #

    Try this. I was able to get me visual editor back with the following:

    1) Switch theme to Twenty Eleven
    2) Edit a post (displays as white pane with red underlines)
    3) Clear cache (press F5)

    Visual editor, tabs and buttons returned at this point in edit post mode.

    4) Switch back to original theme.
    5) Edit post. (all returns to normal, do the happy dance!)

    I did not have to deactivate the plugins for this to work.

  10. robthecomputerguy
    Member
    Posted 2 years ago #

    Do you have an ad blocker or content blocker of any type installed on your browser? It seems to be a guaranteed cause of the buttons not working.

    I could also see a safe browsing filter internet thingy causing a problem?

  11. sjbmaine
    Member
    Posted 2 years ago #

    lewatson, I jumped through your series of hoops on one of my sites and it seemed to do the trick - only after step 5 I had to CTRL/F5 a couple of times before I could do the happy dance.

    What your scenario added to what I'd done before was to edit a post while in the Twenty Eleven theme before switching it back to my theme. Silly, but it worked. Thanks for posting!

  12. davaobase
    Member
    Posted 2 years ago #

    I also had the same issue in my two blogs. For the first one, I tried lewatson's 5-step approach, and it worked!

    For the second site, I tried a shorter route. I simply went to the Edit Post mode without changing themes. I pressed F5 three or four times (after clearing the cache). Voila! It also worked!

  13. sjbmaine
    Member
    Posted 2 years ago #

    I confess I'm at a total loss here. I was so excited last night when I got one site on one computer to show the visual editor following lewatson's instructions.

    Despite jumping through these hoops I have not been able to get the second site to show the visual editor or either site on my desktop. I don't have anything fancy running here - Firefox as the principle browser, Windows 7, Avast anti-virus with no additional ad or popup blockers. I just seems like my computers will not give up this cache.

    I'm afraid to update my other sites to 3.3 until I can figure out a sure fire way to get the cache cleared. Ugh.

  14. Don
    Member
    Posted 2 years ago #

    Changing themes and jumping through coding hoops should not be a resolution. I had one Plugin button/feature disappear (phpBay) and have yet to resolve the issue.

    I'm using the Arthemia theme (FYI) but the normal visual editor stayed in place as normal.

  15. robthecomputerguy
    Member
    Posted 2 years ago #

    @sjbmaine did you try the fixes listed for "use google libraries" and the hotfix .8?

    The "use google libraries" plugin seems to solve a lot of people's problems.

  16. Buzzdesigner
    Member
    Posted 2 years ago #

    I've got the same problem. If anybody use cloudflare follow 3 steps:

    1)Go to cloudflare settings: Caching Level --> choose basic
    2)turn on development mode
    3)empty cache

    Should help.

  17. sjbmaine
    Member
    Posted 2 years ago #

    robthecomputerguy, can you tell me more about hotfix .8? I'm not familiar with this - where to get it, etc. A quick google search left me confused on this.

  18. Buzzdesigner
    Member
    Posted 2 years ago #

  19. sjbmaine
    Member
    Posted 2 years ago #

    Thank you Buzzdeisgner.

    Curiously, I went to a computer that I've never used to work on my sites before and checked them. They work absolutely beautifully - visual editor showing just as it should, so I know this is a cache thing. The Use Google Libraries did nothing for me. I'll give the hotfix a run.

  20. robthecomputerguy
    Member
    Posted 2 years ago #

    I think (and therefore could be wrong) it's crucially important to seriously clear out your cache, and make sure you delete any cached files for your site (W3, SuperCache, Cloudflare) if it makes use of that.

    The existence of the cache could prevent the fix from showing properly.

    After the hotfix, did it still fail on multiple browsers? I'm not seeing anyone on my end where the hotfix didn't solve their problem.

    (Except when they had an adblocker installed.)

  21. robthecomputerguy
    Member
    Posted 2 years ago #

    I know all browsers have cache clearing options, but I've had any given one fail me at one time or another.

    Safari, on both Mac & Windows, has a nice "Reset Safari" function that just starts the whole thing over, clearing out everything. That usually clears up cache problems for me.

  22. sjbmaine
    Member
    Posted 2 years ago #

    The hotfix didn't do the trick.

    I know this is a caching given the successful functioning on another computer (that has the same software/browser, etc as the computers I'm having issues on).

    Are there any special tricks in Firefox to lose the cache that I may not know about? I've done the obvious Clear Cache including the entire history and the CTRL/F5 - numerous times.

    :(

  23. Argos_t
    Member
    Posted 2 years ago #

    I have also the same problem with Visual editor, plus that I can't wee the text since they became white letters in white background (only in edit mode)

  24. giddykipper
    Member
    Posted 2 years ago #

    Here's something the same but different -
    when I have the Visual Editor selected, the HTML editor is there as well, it doesn't close. Does this ring a bell with anyone? I, too, have disabled plugins and tried the vanilla theme route. Not life threatening but tedious - all help welcomed with a Christmassy kiss!

  25. Andrea Duni
    Member
    Posted 2 years ago #

    I got the same problem but... I found also that my VirusBarrier X6 (I got a Mac) was the problem!!
    With full protection activated doesn't let me see visual (and plugins too) activated!

    Because I don't want to disable it everytime I want to post something, do someone know what is exactly to be authorized on the VirusBarrier?

    Edited: I have found that Hidden Information, and exactly Hidden information of computer and browser, HAS NOT TO BE ACTIVATED.

    I think it will work for other Internet Security Suites...

  26. blogger2020
    Member
    Posted 2 years ago #

    Before jumping through hoops, try the above mentioned.

    1. Go to your posts and pick any post and 'edit'.
    2. Press F5 three or four times (after clearing the cache).

  27. sjbmaine
    Member
    Posted 2 years ago #

    blogger2020, started with that all the way up in the very first post above.

    I have since totally shut down my antivirus. Cleared the cache and hard refreshed. Multiple times. Nada.

    So far on my laptop I've gotten the visual editor to work in Chrome - not in IE or Firefox. My primary desktop I've not gotten the visual editor to show in IE, Firefox, Chrome or Safari.

    Consequently, on my husband's computer from which I have never edited my blogs, I got the visual editor to show up with no trouble.

    I hate cache.

  28. dragonc
    Member
    Posted 2 years ago #

    I have two sites on the same server. After upgrading both to 3.3 one is OK and one has the same problems described above - and its not related to cache on my computer as my client in a different city is having the exact same issue with one of the two sites. Editing and using F5 have made no difference.
    The site that is OK is in a subdirectory, while the problem site is in the public_html (main) directory.

  29. What happens if you install http://wordpress.org/extend/plugins/use-google-libraries/

    If THAT works, then it IS your cache. Your browser isn't letting go of the cached JS files (happened to me and I had to go in to my documents and manually delete the cache folder entirely).

  30. Argos_t
    Member
    Posted 2 years ago #

    @Ipstenu
    Thanks a lot. This solution, with the google plugin worked fine with me

Topic Closed

This topic has been closed to new replies.

About this Topic