WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editor Doesn't Work (35 posts)

  1. fanvid
    Member
    Posted 6 years ago #

    have the same problem some people are having... ever since 2.3 (and upgrades to this) and now I've upgraded to 2.5, still the same problem, no plugins, no themes, tried almost everything that all the forum threads say... so i don't know...

    also just because it works for most people (and it works fine in the other 20 wordpress installations i have) still on this one it just doesn't work, and since the only thing that i haven't messed with is the database, i think something is not as it should in there, maybe from some old plugin, because i tried everything from deleting everything and installing everything from scratch... and still it doesn't work

    here is a screenshot:
    http://img246.imageshack.us/img246/6191/wordpress25yc8.jpg

  2. fanvid
    Member
    Posted 6 years ago #

    no one?

  3. dig1618
    Member
    Posted 6 years ago #

    I am having a similar problem with wordpress 2.5's visual editor. my plugins and themes still work.
    but i can not use the visual editor and the buttons for bold, italic, links, etc... are missing.

    i have circled what is missing in this image.

  4. philsci
    Member
    Posted 6 years ago #

    Dear forum,
    Now I have met with the same problem. And I've found at:

    /wp-includes/js/tinymce/langs/wp-langs.php

    Firebug for Firefox tells me that this script is crashed
    if I use the visual editor. And nothing helps when I hard-code
    to replace all of $langage variables with 'en', and add

    define ('WPLANG', 'en');

    line in wp-config.php as well...

  5. hakre
    Member
    Posted 6 years ago #

    If something works everywhere else and you upgraded and only on a single instance it does not work and it is script related, please do the following:

    * deactivate your browsers cache
    * deactivate javascript in your browser
    * shift-reload the page that does not work
    * wait until everything has been loaded
    * re-activate javascript
    * shift-reload that page that did not work before again
    * the page should work now as intended
    * re-activate your browsers cache
    * you should be able to use that blog as all the others

    If not, this was not a caching issue. That means, on of the currently installed (or ever has been installed and then deleted plugins) is not compatible with your current version. Or some of you files are modified and lead to that error.

  6. Ryokuns
    Member
    Posted 6 years ago #

    I'm having the same problem.. this happened right after I installed a fresh wp 2.5 on my hosting.. I test the same version on my pc and it works. What makes it not working on my hoster?

    I have disabled all plugins and it's still not working

    follow ur guide above. didn't work

  7. dig1618
    Member
    Posted 6 years ago #

    i deactivated all plugins except akismet, still no change in most gecko-based browsers and midori web browser. but in konqueror the buttons work somewhat.

    a fresh wordpress2.5RC1 functions perfectly.

  8. hakre
    Member
    Posted 6 years ago #

    So did it work as long as the browsers cache was disabled?

  9. philsci
    Member
    Posted 6 years ago #

    Thanks hakre,
    It works by the following steps.

    1. Set the cache volume to 0 MB, turn off JavaScript in Firefox, and then set the user preference NOT to use the visual editor.
    2. Close the browser and start again.
    3. See the entry post page and check JavaScript is disabled.
    4. Go to the user preference and turn on (to be enable) the visual editor.
    5. And go back the entry post page.
  10. lightspeed
    Member
    Posted 6 years ago #

    Regarding the visual editor for 2.5, I can't even see it. My Write Window options end with the "Add Media" buttons. How does one turn on or find the visual editor? Argh!

    Thank you.

  11. lightspeed
    Member
    Posted 6 years ago #

    Well, there ya be, there ya be ... I found the answer in another thread, which is that one must go to one's profile and turn ON the Visual Editor. *sigh* To do so is SO non-intuitive. WP People - please move this option to the actual Write Post area...please?

    Anyway, back to the grind.

  12. hakre
    Member
    Posted 6 years ago #

    Well these problems can get mixed up with updates a lot. Basically the User does have to have the Visual Editor Option enabled - otherwise there is no visual editor.

    Beyond that setting, partial wordpress upgrades often fail because the upgrader does not validly upgrade his or her wordpress installation. And even if he or she did, you can run into caching problems.

    To use the visual editor you need to have the option set and you need to have javascript enabled.

  13. turkeypants
    Member
    Posted 6 years ago #

    For me, I think the problem occurred during the svn switch to 2.5. Looking into the wp-includes/js/tinymce/ directory showed a couple versions or tiny_mce.js. One was tiny_mce.js.r7627. So I renamed the old tiny_mce.js to tiny_mce.js.old and then renamed tiny_mce.js.r7627 to tiny_mce.js and refreshed. That fixed the problem for me.

  14. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    There are some step-by-step instructions how to try to fix this here:
    http://wordpress.org/support/topic/165449

    If it still doesn't work after going through all steps, notice the first js error when loading the write page (best done in Firefox with Firebug) and post it here. That will make it a lot easier for someone to help.

  15. TomBayer
    Member
    Posted 6 years ago #

    My problem is a tad different from what most of you guys report. I can see the Editor without a problem and can also switch between raw and WYSIWYG mode but the frame of the post box itself is screwed up. It is larger than it should be (both in FF and IE in latest versions) and is overlapping and hiding a part of the options right next to the write post box. This is only cosmetics but way worse is, I can't see any options for font, size and colors anymore. Where are they? See the screenshot to see what I mean.

    http://img413.imageshack.us/img413/1892/wpmp2.jpg

  16. hakre
    Member
    Posted 6 years ago #

    Additional Steps:

    1. Clear wp-content/uploads/js_cache
    2. Check if there is a Desktop Firewall. Whitelist your Blog

    Started to collect some Stuff in the Codex Wiki.

  17. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @TomBayer, which plugin for TinyMCE are you using? Either upgrade it or disable it and the default toolbars will show fine.

  18. TomBayer
    Member
    Posted 6 years ago #

    @ azaozz: I have no TinyMCE plugin in my plugin list. When I disable the Advanced WYSIWYG Editor, the box is no longer overlapping other options but I see even less options. I will look for that TinyMCE plugin for WordPress if that's the solution. Thanks for the hint.

  19. TomBayer
    Member
    Posted 6 years ago #

    Installing the recent 0.5.0 TinyMCE plugin resulted in making ALL icons go away and receiving errors in new-post.php..even after disabling the plugin I could not get the old editor back YUCK. Now I have not one icon anymore in my write post box LMAO. I have rolled back to the previous 2.5 version of the files now and hope more people are affected from the editor bug so a fix will be released. I doubt this bug has something to do with my settings since it also occurs when all plugins are disabled. Having tried every hint that was given in this thread is another reason to come to this conclusion. :-( Stuck here and hoping for feedback.

  20. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    Try deleting /wp-includes/js/tinymce and wp-content/uploads/js-cache directories, then upload fresh copy of the first one, clean browser cache and force-refresh the write page.

    Also, are you referring to the "Advanced WYSIWYG Editor" plugin for WordPress 2.0? It's not compatible with WordPress 2.5.

  21. fanvid
    Member
    Posted 6 years ago #

    nope nope nope, nothing works, like i said, all my other wordpress installs work fine, with this one, its just fixed on that position, it is not a cache problem / browser problem /server problem, im guessing is some weird plugin that screwed something on the database side, cause all files are clean from 2.5, its just stuck on that position and i cant switch back between html and visual, and of course its not the "Use the visual editor when writing" ...

  22. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    Generally TinyMCE (not only in WordPress, the stand-alone versions too) can be affected by 3 things:

    1. Some of the old .js and .css files weren't replaced when upgrading it.
    2. Some of the old files are loaded from cache instead of the server.
    3. Some kind of browser addons, antivirus, popup blocker, anti-phishing, etc. software that prevents the js from running properly.

    Additionally in WordPress all TinyMCE .js files are concatenated and compressed before sending them to the browser. This makes it a lot faster. The compressed file is also saved in wp-content/uploads/js-cache directory and it's name is tinymce_..long number...gz. This file can be deleted safely, as it will be recreated the next time TinyMCE is loaded.

    Some hosting companies also enable compression of all server output by default and in very rare cases, this is not set up properly in php.ini (they use buffering instead).

    In these cases, the TinyMCE compressor cannot detect the setting which results in double compression. Trying to load sitename/wp-includes/js/tinymce/tiny_mce_config.php directly in Firefox, results in a large garbled text.

    To fix this, tiny_mce_config.php can be edited and the line 'compress' => true have to be changed to 'compress' => false. There's also a small plugin that will change this setting, linked in this thread:
    http://wordpress.org/support/topic/165449

    If your server is doing that, it's a good idea to talk to your hosting company and ask them either to disable compression for your account or to set it up in php.ini, or perhaps use Apache's deflate module as it works better.

  23. Rivo
    Member
    Posted 6 years ago #

    I've got the same problem.

    It's not cache issue, I've checked it, didn't helped (and I'm using Opera, I didn't hear that there are also problems with caching in this browser. Or there only Firefox users :P )

    I deleted js_cache, reinstalled WP, turned off and on Visual Editor, nothing helped.

  24. TomBayer
    Member
    Posted 6 years ago #

    @ azaozz: Thanks for your help and bearing with me. I did what you said and turned the Advanced WYSIWYG Editor plugin off, cleared the dirs and uploaded the tinymce folder from a clean 2.5 copy. Now the overlapping problem is gone and my toolbar in the write post box looks like this:

    http://img148.imageshack.us/img148/2963/updatexl1.jpg

    I must admit, I can't tell what options are given here by default because I have been using the Advanced WYSIWYG Editor since the beginning. What I am missing is a font option but I guess I can do without for a while till other plugins provide this option again. I now at least see the color and size options I was looking for again...phew.

    One weird thing I saw is that when I choose a color from the 2nd row of the toolbar, I see the pop up you normally only see when you try to navigate away from the page. But when I click OK I stay on the page and the color is changed.

    I also see an error when I access the the post new site wp-admin/post-new.php. On the bottom left in the Explorer I see that an error occured and details tell me that in line 4 dbxgroup is undefined. Any help for sorting the remaining problems is appreciated.

  25. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @TomBayer, there are several plugins that should work in 2.5:
    http://wordpress.org/extend/plugins/tags/wysiwyg

  26. TomBayer
    Member
    Posted 6 years ago #

    ^^ Thanks, will have a look at these. I only wonder where the 2 errors (pop up coming up for changing a color + dbxgroup undefined error) I talked about come from and if installing another plugin is a good idea already at this stage. I guess I will wait a bit to see how WP evolves. I can live with the 2 remaining bugs but I dislike seeing errors on my site so I am rather cautious now. "Never change a running system" :-)

  27. Andrew Ozz
    WordPress Dev
    Posted 6 years ago #

    @TomBayer the dbxgroup (dbx.js) was in 2.3, it's not there any more in 2.5, so it may be another plugin that needs update for 2.5.

  28. maxhansen
    Member
    Posted 6 years ago #

    I had this problem, but in my case it <strong>was</strong> a plugin. I use AskApache Password Protect v. 3.5.1. In this plugin, when I enable protection of

    /wp-includes/*.php
    (Denies any Direct request for files [in that directory] ending in .php with a 403 Forbidden)

    then my visual editor goes away.

    Another note: after turning off this protection, when I return to the Write Post page, a shift-reload doesn't get my VE back; I have to clear Firefox's cache and then reload. (FF 2.0.0.14)

    Thought this might help someone.

  29. dig1618
    Member
    Posted 6 years ago #

    this is very frustrating.

  30. philsci
    Member
    Posted 6 years ago #

    dear all,
    I've heard a new way to solve this problem from Mr. watanabe.
    Please try the following steps.

    1. Open wp-includes/js/tinymce/tiny_mce_config.php.
    2. Disable if-clause with a comment as: // Use cached file if exists (line 244 or around)
    3. Disable if-clause with a cooment as: // Generate GZIP'd content (line 299 or around)
    4. Comment out: header( 'Content-Length: ' . strlen($content) ); (line 306 or around) as well
    5. Then go to the post form and do the Super-reload

    In my situation, it works :)

Topic Closed

This topic has been closed to new replies.

About this Topic