WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Visual Editor Blank, No Text Editor (10 posts)

  1. HelenNovice
    Member
    Posted 1 year ago #

    After loading a theme, I lost my visual editor view. It is there, but when I type it is white on white. I deleted the theme and activated Twenty Twelve. It still does not work. I have no plugins.
    Here is what I found in the forums and I did all of these things. None have worked.
    Go to your wp-admin, your profile, and ensure "Disable the visual editor when writing" is unchecked.

    - Rename your wp-content/plugins folder to plugins-old or something like that. You should then be able to determine if your visual editor is working at all. This step allows you to verify that the visual editor is working and in fact a plugin was the culprit.

    - Go into Settings -> General settings and if there is a colon ':' in the end of the Site URL (eg: http://www.mysite.com/wordpress:) then remove the colon.

    - switch to the Twenty Ten theme to rule out any theme-specific problems.

    - Make sure your WP version is up to date.

    - Consider a WYSIWYG editor like TinyMCE Advanced and see if that solves things.

    - Follow WP's instructions on how to deactivate all plugins

    - Try re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    It shouldn't come to this, but if all else fails, back up your wp-includes/general-template.php, and ensure these lines are there:

    function user_can_richedit() {
     global $wp_rich_edit, $is_gecko, $is_opera, $is_safari, $is_chrome, $is_IE;
    
    if ( !isset($wp_rich_edit) ) {
     $wp_rich_edit = false;
    
    if ( get_user_option( 'rich_editing' ) == 'true' || ! is_user_logged_in() ) { // default to 'true' for logged out users
     if ( $is_safari ) {
     $wp_rich_edit = ! wp_is_mobile() || ( preg_match( '!AppleWebKit/(\d+)!', $_SERVER['HTTP_USER_AGENT'], $match ) && intval( $match[1] ) >= 534 );
     } elseif ( $is_gecko || $is_chrome || $is_IE || ( $is_opera && !wp_is_mobile() ) ) {
     $wp_rich_edit = true;
     }
     }
     }
    
    return apply_filters('user_can_richedit', $wp_rich_edit);
     }

    The last one gave me an error and I lost the whole site. I went back to the existing version and everything came back but the editor.

    I edited CSS in /wp-includes/css/editor-buttons.css.
    From: .js .tmce-active .wp-editor-area{color:white;}
    To: .js .tmce-active .wp-editor-area{color:black; /* bwh */}

    Also, I have the tab for text editor, but when I click on it I stay on visual text editor.

    Any suggestions? I am at: http://www.hlnwebdesigns.com/cms
    This is a test site as an addon to my regular site while I set up a wordpress site.

    Helen

  2. Tara
    Member
    Posted 1 year ago #

    have you tried:

    - open wp-config.php and try adding the following line before "That's all, stop editing! Happy blogging" Add this to your wp-config file (not the best solution, but now you may be able to use admin again): define('SCRIPT_DEBUG', true);

  3. HelenNovice
    Member
    Posted 1 year ago #

    I can access my entire dashboard, I just can't see what I'm typing in the editor. It is typing white on white.

    I will try your suggestion because right now everything I type has to then be highlighted to be sure I don't have a typo and just to see it in the editor. It shows up fine in the page. I just can't find what file and what line of code pertains to the text editor's font color.

  4. HelenNovice
    Member
    Posted 1 year ago #

    That did it! Thanks.

    They should put this as a sticky note. As others have had this same problem and other scenarios have worked for them. One sticky on all things you can try and this should be at the top.

    Thanks for your help.

  5. HelenNovice
    Member
    Posted 1 year ago #

    I just found out that this was not a fix but a bandage over another problem.

    So I guess it is not good to use: define("SCRIPT_DEBUG",true);

    If I don't do this, I can see what I am typing in the Visual Editor and all I get is a tab for Text editor but it never opens.

    Help please.

    Helen

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    On some hosting environments, aggressive settings for the "mod_pagespeed" addon can break the javascript code and cause scripts to not be able to function. This can cause many problems, such as widgets not working, menus not being draggable, the customizer not working, or the media screens not being available.

    To fix the issue, you will need to disable mod_pagespeed, or adjust its settings to not take effect in the wp-admin directories. You may need to ask your hosting service for help on how to do this.

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

  7. HelenNovice
    Member
    Posted 1 year ago #

    I don't understand any of this, so I will connect with my host server. I just don't understand how this theme would do this on only this site. It also does it no matter what theme I have. I finally added security after the brute attacks coming through just so I can keep them from my main website. I'll let you know how this goes.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    I just don't understand how this theme would do this on only this site. It also does it no matter what theme I have.

    Then the theme isn't the issue, is it? It's a hosting issue.

  9. HelenNovice
    Member
    Posted 1 year ago #

    I am in a chat right now with my host server. Thanks.

  10. HelenNovice
    Member
    Posted 1 year ago #

    I worked with my Host Server and even after removing the code define("SCRIPT_DEBUG",true);

    the editor worked. I don't know why but it is working, even without the debug code.

Topic Closed

This topic has been closed to new replies.

About this Topic