WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editor appears as HTML in 2.9 (23 posts)

  1. lince4i
    Member
    Posted 4 years ago #

    When I try to edit a post, the Visual Editor opens appearing exactly as the HTML Editor. (screen shot at http://www.eye4image.com/vnf/) If I then open the HTML editor there is NO apparent change. When I then return to the Visual Editor the only change is that the HTML button disappears - the display still shows HTML.
    On Dec 21 we experienced a problem where all of the editor screens lost formatting (as if the CSS file had been changed or deleted). I then upgraded to 2.9, which fixed that problem. For the next week everything appeared normal.
    On Dec 28 this problem appeared, (without any changes made to version or plugins).
    I have tried the following - testing (and refreshing browser cache) after each:

    • Upgraded all plugins
    • Deactivated all plugins
    • Deactivated and deleted plugins (reinstalled after did not fix)
    • Edited user - checked "Disable the visual editor when writing" and then unchecked again
    • Changed to a different Theme
    • Reinstalled Core software using Tools > Upgrade > Re-Install Automatically

    Installation is on http://valleynaturalfoods.com/wordpress/.
    We are using the WordPress Default Theme 1.6
    We are not using Gears.
    The same problem appears in Firefox and IE (multiple versions).
    Other installations on different servers (with different themes) but the same WordPress version are not experiencing this problem.
    Any insights would be appreciated.

  2. jrandomh
    Member
    Posted 4 years ago #

    Exact same issue on WP 2.9.1. Haven't found many other reports.

    This is a showstopper issue for us - is it possible to downgrade to WP 2.8.6 and use the same database (as it "upgraded" when installing 2.9)?

  3. nastycreatures
    Member
    Posted 4 years ago #

    I'm having the same exact problem only it all started yesterday after I did a Vista update. Though I can't see how that would be the source.
    I was fine in 2.8.6 before the Vista Update. Afterwards the visual editor, the whole thing stopped working in all browsers. IE, Firefox, Chrome. It was stuck on HTML edit mode and all the drop down menu icons stopped working as well. The text in the edit window disappeared (actually white)and to make matters worse everytime I tried updating it lost all permissions and couldn't even do that.

    back to the visual editor... I have tried this on several different blogs I have on all browsers with the same result. I have done all of the suggested work around, deactivate plugins, remove plugins, clear cache, log out log in I have looked back at all the work around from previous versions as well...even did 2 reinstalls of both 2.8.6 and 2.9.1 and nothing. I am at a complete standstill and my site is totally fragged from being able to update it.

    What is going on? Does anyone have a clue?

  4. Sorin
    Member
    Posted 4 years ago #

    Some problem (white text on white background) reproduces on latest Chrome and Firefox and Internet Explorer 8.

    superuser.com/wordpress-showing-white-text

  5. jrandomh
    Member
    Posted 4 years ago #

    Hi guys,

    update for me - issue was local - TinyMCE files were corrupted in upload, I deleted and re-uploaded wp-includes and it all working 100% now.

    Cheers,
    J. Random. H.

  6. tschoah
    Member
    Posted 4 years ago #

    Hello everybody,

    I had the same problem and I did all the things lince4i did more than once. When I saw jrandomh's posting I had a last idea.

    Following my idea in short descriptive steps:
    - Login on your server over ssh
    - Download the latest wordpress zip file
    - Unzip the file
    - Delete the contents of your wp-includes folder
    - Copy the contents of the recently unzipped wp-includes folder to the wp-includes folder in which you have deleted all the files
    - Check that every file of the wp-includes folder has the user and group owners like the rest of your wordpress installation has

    Where is the differnce? Each of my previous tries to install wordpress on my web server had the following installation procedure. I have downloaded the wordpress zip archive, I have unpacked it on my local machine and after that I have uploaded it with the help of a ftp client to my web server. I do not know where the tinymce files where damaged but the fact is, that they where corrupted and that's why the visual editor was not working correctly.

    Best regards,
    Marcel

  7. consultores.vercav
    Member
    Posted 4 years ago #

    thanks Marce (tschoah).

    following your steps i coul fix it.
    After upload the files, just change the permisssions to 755 to files and directories inside the wp-includes folder.

    "todo vuelve a la normalidad" we say in our country.
    regards

    Jorge

  8. ohbrooke
    Member
    Posted 4 years ago #

    I'm having the same problem: HTML code showing up in Visual editor. I followed tschoah's instructions -

    (although I'm not sure what he means by "Check that every file of the wp-includes folder has the user and group owners like the rest of your wordpress installation has")

    - and logged out and back in and it still appears to be broken.

  9. ohbrooke
    Member
    Posted 4 years ago #

    SOLVED the problem - it seems I had too many page revisions on this particular page so the page wouldn't finish loading. I downloaded this plugin: http://wordpress.org/extend/plugins/delete-revision/, dumped all the old revisions and it worked.

  10. teckinno
    Member
    Posted 4 years ago #

    The above steps did not work for me. It is obviously a WordPress issue.
    I installed WordPress on a brand new dedicated server, using the exact same setup as I have on my current 2 servers. On the new server, the MCE works perfectly with 2.9.1 version.

    Wgetting the WP tarball, extracting it locally deleting the /wp-includes dir and copying the new files into live site did absolutely nothing (as I was expecting), beside that it made me waste 20min. :)
    I said, it was worth a try. I'm glad at least it worked for some of you. I had MCE working perfectly on WP 2.9 version.

    What is shocking for me is the fact that installing a fresh version (empty db) will work perfectly. Go figure...

  11. teckinno
    Member
    Posted 4 years ago #

    Just in case you wonder about perms... I deal with Linux for years.
    chown -R fpm:root ${DIR}
    find ${DIR} -type d -print | xargs chmod 0755
    find ${DIR} -type f -print0 | xargs -0 chmod 0644

  12. Asuka_Aki
    Member
    Posted 4 years ago #

    I like so many uhad the same issue and it was none of the things mentionned...

    Then the thought dawned upon me! I had an htacces file in my wp-include folder that used to be fine but after the upgrade I had to edit it and the buttons came back!

  13. zbyseknadenik
    Member
    Posted 4 years ago #

    I have the same issue and I tried everything with no change.

    If I install wordpress on my localhost or another webhostign, visual editor is working fine. I have this problem just with one webhosting.

    Any ideas what should they change in their settings to fix this?

  14. zbyseknadenik
    Member
    Posted 4 years ago #

    I solved it.

    For some reason, when I uploaded the whole wordpress directory, the wp-tinymce.js file uploaded only 1/3 size of this file. I had to overwrite it and then the editor works fine.

  15. madis
    Member
    Posted 3 years ago #

    I had the same issue as ohbrooke (thanks!!) and deleting revisions solved it. To prevent that situation in future, you could set the limit to posts, for example with Revision Diet plugin: http://wordpress.org/extend/plugins/revision-diet/

  16. dougrek
    Member
    Posted 3 years ago #

    I'm a huge fan of WordPress but this is a big problem that nobody seems to have a UNIFORM answer to. I have tried EVERYTHING from an endless number of posts on this subject and nothing works. It is really a maddening issue.

  17. nicadmin75
    Member
    Posted 3 years ago #

    Deleting revisions worked for me, too.

    Thanks so much! :*

  18. ashleighdickins
    Member
    Posted 3 years ago #

    I just had this problem, and re-uploading the wp-includes folder totally worked. Thanks so much!

  19. limenet
    Member
    Posted 3 years ago #

    Hi Guys,

    I had this problem, too. And re-uploading of the wp-includes folder worked prefectly!

    Thanks so much,
    limenet

  20. reales
    Member
    Posted 3 years ago #

    I had this problem on WordPress 3 and it came down to the memory being exhausted through too many plugins. I have cleaned up my plugins (deleted unused ones and deactivated ones that I don't use all the time) and now the memory limit errors on the dashboard have disappeared and the editor is working correctly again.

  21. rolandogomez
    Member
    Posted 3 years ago #

    I had this same issue when I moved my blog from /blog/ directory to the main root as I switched from WP 3.0 to multi-site. I downloaded the delete revision plugin mentioned above, http://wordpress.org/extend/plugins/delete-revision/ which I might add is not only nice and easy to use, but deleted almost 500 unecessary revision files and also does a beautiful database check (always back up your data base first, then export a copy of your site through "tools" in the admin section.

    I then re-uploaded the entire wp-includes directory, but still had the same problem. So then I re-uploaded only the "tinymce" directory, then it all worked well again. Bottom line, I think you have to FTP the tinymce folder by itself as something gets lost if you do the entire wp-includes directory at once. That's my belief as it all works well now at http://www.lensdiaries.com Thanks, rg.

  22. shazza007
    Member
    Posted 3 years ago #

    Thank you for this post. I deleted and reuploaded the tinymce directory. Totally did the trick.

    Working in WP 3.0.1 and had lost kitchen sink and all visibility on posts! So thank you to whoever figured this out.

    Oh, incidentally I tried the revisions diet plug in first as that seemed simpler. But no luck with that although it's a nice plug in.

  23. SheldonNesdale
    Member
    Posted 3 years ago #

    You guys are awesome! I was scratching my head of this one. The solution that worked for me was replacing the wp-includes folder via ftp.

Topic Closed

This topic has been closed to new replies.

About this Topic