WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Visual Editor and Image Upload Not Working after Upgrade (5 posts)

  1. tankard
    Member
    Posted 3 years ago #

    Hi,

    I recently upgraded all my blogs to the latest version and one of the blogs (all the rest are fine!) lost its visual editor and I cannot upload images with my posts.

    The visitor side looks ok, it's just the admin side that has problems.

    I tried disabling all plugins - no change

    I tried re-installing the 3.1.2. via Automatic Update - no change

    I completely wiped out the site and did a manual re-upload - no change

    I am totally puzzled. Please help!

  2. pakos
    Member
    Posted 3 years ago #

    Hi, i've updatet my wp to newest version today. Manually but i'm having similar problems like you. Can't use visual edit, upload images, hide/unhide left menubar in admin mode, looks like all js (or whatever its used for such things) elements are broken. Any ideas?

  3. esmi
    Forum Moderator
    Posted 3 years ago #

    Try:
    - switching to the Twenty Ten theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - re-running the upgrade manually using wp-admin/upgrade.php.

  4. tankard
    Member
    Posted 3 years ago #

    Wow, esmi, you're a real diva. Thank you very much. Although the manual upgrade told me there's nothing to upgrade, the previous steps actually did a treat and my site is fully functional once again. Thanks again!!!

    It would be interesting to understand what it is that breaks the Java...

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    Sounds like some of the wp-includes folders didn't upgrade fully or became corrupted.

Topic Closed

This topic has been closed to new replies.

About this Topic