WordPress.org

Ready to get started?Download WordPress

Forums

Visual editor (5 posts)

  1. johnetta
    Member
    Posted 4 years ago #

    Cannot access the visual editor and its menu bar.
    the visual editor box is not checked.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems.

    - renaming the plugins folder via FTP

    - reading http://wordpress.org/support/topic/279132

    - disabling Google Gears if you have that running/installed within Firefox.

  3. johnetta
    Member
    Posted 4 years ago #

    Thanks for the feedback and referral to support/topic/279132

    -deactivated plugins-->no visual toolbar

    -switching to default theme--->fear of doing as it would be my first time
    -renaming plugins-->same fear
    _didn't find google gears installed/running

    -automatic upgrade to 2.8.1-->visual editor/tool bar is now visible!

  4. PBP_Editor
    Member
    Posted 4 years ago #

    Hello

    I was having the same issue - the visual editor tab was visible but could not be selected. The visual editor disabled checkbox was unchecked.

    I tried in IE and saw the following error.

    Message: Object expected
    Line: 2
    Char: 1
    Code: 0
    URI: /load-scripts.php?c=1&load=utils,editor&ver=2f8adb7975702d291df76afc40b144cd

    Message: 'switchEditors' is null or not an object
    Line: 1122
    Char: 1
    Code: 0
    URI: /wp-admin/post.php?action=edit&post=32758

    So my developer Axel looked into the hooks on load_scripts.php and figured out that 2.8.4 is concatenating scripts

    2.8 added concatenation for scripts... the concatenation needed to be disabled for everything to work stable as before.

    This is a minor performance enhancement on this release that does not cooperate will all web servers. We are on the Rackspace Cloud and it doesn't seem to like that.

    Do this to stop concatenation

    You can add a setting in the wp-config.php file
    define('CONCATENATE_SCRIPTS', false );

    Cheers

  5. derrickteam
    Member
    Posted 4 years ago #

    You can add a setting in the wp-config.php file
    define('CONCATENATE_SCRIPTS', false );

    Thank YOU!

    I've tried everything I could find for days and could not fix this. Added that line an whoa, it all suddenly works.

    Thank YOU again
    Dennis

Topic Closed

This topic has been closed to new replies.

About this Topic