WordPress.org

Ready to get started?Download WordPress

Forums

Visual Editing Tools Not Showing (36 posts)

  1. mseliga
    Member
    Posted 5 years ago #

    This happened with beta 2 as well. I tired a reinstall of wp-include and wp-admin, I deactivated all plugins..not sure what else to try. The only tools that show are the embed buttons for images, audio, video, and media.

  2. Jen Mylo
    Key Master
    Posted 5 years ago #

    The upload buttons are not part of the Visual Editor, and display in HTML mode as well. I know this probably sounds like an obvious question, but is the "disable Visual Editor" box checked in your Profile?

  3. mseliga
    Member
    Posted 5 years ago #

    No it's enabled. I'm running it on xtreemhost, but I don't think that would cause any problems. 2.6 worked fine. Are there any files in wp-content that I could try and replace with "clean" ones without messing everything up?

  4. infected
    Member
    Posted 5 years ago #

    Same here. No visual editor or quicktag editor available. :(

  5. beachbum
    Member
    Posted 5 years ago #

    im only getting the html editor.

  6. minoofar
    Member
    Posted 5 years ago #

    I am having the same problem. The visual editor never shows up. Even when I spoof as another browser or use another browser (I use Safari on Mac and Windows) on Mac or Windows, the visual editor fails to show up. I just upgraded to today's nightly build, and still nothing. When I click on the visual editor tab, I get a non-functional page. Upon reloading, the page reverts to html editor.

    Which is fine, but I like the convenience of the visual editor.

    Payam

  7. mseliga
    Member
    Posted 5 years ago #

    Oh yeah, forgot to add that bit by minoofar. Clicking on the "visual" to change the editor type essentially crashes the editor, requiring a refresh.

  8. mseliga
    Member
    Posted 5 years ago #

    BUMP
    Any new ideas/thoughts on this?

  9. minoofar
    Member
    Posted 5 years ago #

    None. I just upgraded, and the symptoms are still there. I'm wondering if this is a feature that they have disabled until its integration is complete. I wish they would say something about it.

  10. mseliga
    Member
    Posted 5 years ago #

    What did you upgrade to? Is a Beta 3 out?

    EDIT

    Beta 4

  11. minoofar
    Member
    Posted 5 years ago #

    This problem has been solved. Problem is with kimili flash plugin.
    http://wordpress.org/support/topic/215600?replies=2

  12. Familiar
    Member
    Posted 5 years ago #

    @minoofar: The first post here mentions that he has tried a clean install with no plug-ins.

    @mseliga: I am going to suggest something I suggested in another thread for speeding up post page load-times. Install the following stripped TinyMCE install, and let me know if it makes any difference. It sounds to me like the TinyMCE init is not working for you. One of the frustrating things about TinyMCE is it's caching mechanism. Anyway, here's the code, it won't do anything except strip all extraneous TinyMCE features. Clear your cache and refresh a few times after installing the plugin:

    <?php
        /*	Plugin Name: Stripped TinyMCE
        	Plugin URI: http://www.wearefamiliar.com/
        	Description: Stripped TinyMCE
        	Version: 1.0
        	Author: Familiar
        	Author URI: http://www.wearefamiliar.com/
        	Tags: wordpress tinymce
    
        	-- Released under GPL --
    
    	Copyright 2008 Familiar
    
    	This program is free software; you can redistribute it and/or modify
    	it under the terms of the GNU General Public License as published by
    	the Free Software Foundation; either version 2 of the License, or
    	(at your option) any later version.
    
    	This program is distributed in the hope that it will be useful,
    	but WITHOUT ANY WARRANTY; without even the implied warranty of
    	MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
    	GNU General Public License for more details.
    
    	You should have received a copy of the GNU General Public License
    	along with this program; if not, write to the Free Software
    	Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
    
    	-- A word of caution --
    
    	As TinyMCE is the primary editor for WordPress, losing necessary
    	functionality is not fun.  So unless you know what you're doing, don't
    	change this code.
    	*/
    
    	add_filter('mce_buttons', 'familiar_mce_buttons', 0);
    	add_filter('mce_buttons_2', 'familiar_mce_buttons_2', 0);
    
    	add_filter('htmledit_pre', 'familiar_mce_htmledit', 999);
    
    	add_filter('tiny_mce_before_init', 'familiar_mce_before_init', 0);    
    
    	function familiar_mce_buttons($buttons) {
    		$buttons = array('bold', 'italic', 'strikethrough', '|', 'bullist', 'numlist', '|', 'blockquote', '|', 'justifyleft', '|', 'link', 'unlink', '|', 'wp_more', '|', 'wp_adv', '|', 'removeformat', 'code');
    		return $buttons;
    	}
    
    	function familiar_mce_buttons_2($buttons_2) {
    		$buttons_2 = array('undo', 'redo', '|', 'cut', 'copy', 'paste', '|', 'help');
    		return $buttons_2;
    	}
    
    	/* Strip unnecessary plugins */
    
    	function familiar_mce_before_init($initarray) {
    		$initarray['plugins'] = 'safari,inlinepopups,wordpress';
    		$initarray['spellchecker_languages'] = '';
    		return $initarray;
    	}
    
    	function familiar_mce_htmledit($c) {
    		$c = preg_replace( array('/&amp;/','/</','/>/'), array('&','<','>'), $c );
    		$c = wpautop($c);
    		$c = htmlspecialchars($c, ENT_NOQUOTES);
    		return $c;
    	}
    ?>
  13. minoofar
    Member
    Posted 5 years ago #

    Well, the symptoms were identical, FWIW. I have yet to use Kimili. So, I will just live it disabled until it is fixed. I will try to give the tinymce code above a try.

  14. Familiar
    Member
    Posted 5 years ago #

    @minoofar: Yes, try re-activating Kimili, then activating my plug-in, and see if your visual editor comes back. Could be one of the TinyMCE plug-ins not behaving with Kimili. I have left three plug-ins loading, which - aside from the Safari fixes - are both essential to TinyMCE working well with WordPress. But for the sake of testing, you could remove those as well by changing this line:

    $initarray['plugins'] = 'safari,inlinepopups,wordpress';

    to this:

    $initarray['plugins'] = '';
  15. minoofar
    Member
    Posted 5 years ago #

    @Familiar: no can do. Tinymce breaks as soon as I activate kimili. Where do I find this line of code?

  16. Familiar
    Member
    Posted 5 years ago #

    It's here:
    http://www.wearefamiliar.com/imageshare/65a3bb1acedd290c4a18632ed2f6aaef.png

    Just below the "strip plug-ins" comment.

    EDIT: OK I am looking at the Kimili code for you. He has it add the plug-in before init. The code above may remove his plug-in entirely. If it does, try this:

    $plugins['kfe'] = WP_PLUGIN_URL.'/kimili-flash-embed/kfe/editor_plugin_tmce3.js';
    $initarray['plugins'] = 'kfe';

    This should load only his plugin, which he defines as 'kfe' in his code.

  17. mseliga
    Member
    Posted 5 years ago #

    @familiar Ok a added that plugin. I'm still getting nothing. I don't have this kimili plugin either. The current plugins I have running are Twitter Tools, Paranoid911, NextGen Gallery, and WP Digg. I cleared the firefox cache, refreshed my page multiple times. Still no go.

  18. mseliga
    Member
    Posted 5 years ago #

    @Familiar I changed the line from

    $initarray['plugins'] = 'safari,inlinepopups,wordpress';

    to

    $initarray['plugins'] = '';

    I see a flash of the editor for a second before it goes away.

  19. Familiar
    Member
    Posted 5 years ago #

    OK, so you see the editor for a second now, before it disappears. Interesting. Is this with my test plugin enabled, and all your others disabled?

  20. mseliga
    Member
    Posted 5 years ago #

    @Familiar. I have your plugin activated right now and all my others deactivated. Shows for a sec, then disappears.

  21. Familiar
    Member
    Posted 5 years ago #

    Sounds like a Javascript problem -- it's too bad it wasn't caused by one of the scripts. There is more than one place where it might be failing; trying to guess where over the internet is painful. TinyMCE can be a really finicky thing.

  22. mseliga
    Member
    Posted 5 years ago #

    @Familiar I don't suppose updating Java would help. Seems to easy though.

    EDIT

    For no reason I tired it in IE to make sure it wasn't just Firefox. It's present over there to.

  23. graphics-coop
    Member
    Posted 5 years ago #

    @mseliga: Java and Javascript are two very different things. The TinyMCE problem does seem to be Javascript related.

    It has plagued our users for months on WordPress 2.6 - 2.6.3 (haven't got round to 2.6.5 yet and haven't tried the 2.7 beta).

    Our workaround is to switch to the default theme, go to the editor, then change back to our working theme and go back to the editor, which then usually loads OK. The problem keeps recurring. Maybe it's something in our edited theme?

  24. mseliga
    Member
    Posted 5 years ago #

    @graphics-ccop Which themes are you talking about?

  25. graphics-coop
    Member
    Posted 5 years ago #

    @mseliga: We've built/adapted a few themes for various WordPress-based websites that we are working on.

    If we run into the visual editor problem, we switch to the WordPress default theme, then back to again. This temporarily fixes it.

  26. mseliga
    Member
    Posted 5 years ago #

    I just tired a awitch back to the defualt. It still didn't work.

  27. graphics-coop
    Member
    Posted 5 years ago #

    @mseliga: It only work for us if we switch to default then go to the editor before switching back. Sorry if it doesn't help you.

  28. mseliga
    Member
    Posted 5 years ago #

    Ok, so the consensus seem to be that it's a javascript error? What file does the editor sit in? I figure I'll try and replace that again.

  29. bobdavidson
    Member
    Posted 5 years ago #

    Been discussing this problem on a different thread... just in case someone is reading and uses FileZilla - the problem is with the upload (weird I know)... something about file/tree structures... Anyway, if you download the 3.6.1 RC1 version from here: http://filezilla-project.org/download.php?type=client&beta=1
    ...and rewrite over your old install...things should be back to normal (I had to reselect "use visual editor" out of my user account and refresh a couple of times by the way)

    Just in case...

    Bob

  30. doog
    Member
    Posted 5 years ago #

    I concur that disabling the Kimli Flash embed plugin solves the problem. My issue has cleared.

    THANK YOU FORUM MEMBERS! YAY TEAM!

Topic Closed

This topic has been closed to new replies.

About this Topic