WordPress.org

Ready to get started?Download WordPress

Forums

Visual editing mode not working on ONE page (8 posts)

  1. kranmars
    Member
    Posted 3 years ago #

    I just edited a page on my WordPress site, saved it (saved perfectly fine), but when switching back to "visual" mode, I still see the HTML. The "visual" editing bar & tools are missing too. When I click on HTML I see the HTML and HTML toolbar .When I click "visual", the HTML toolbar is gone, but I still only see HTML.

    I double-checked, thinking maybe I saved in the wrong mode, but no. The page is displaying fine. I saved it correctly and it displays correctly. But I cannot edit in "visual" Mode, which I need to do for part of the page.

    Tried refreshing browser, and recently updated WordPress version. Even other pages within the same site work fine in "visual" mode...!

    Any help out there for me? Thanks

  2. rescogitans
    Member
    Posted 3 years ago #

    Experiencing the same issue here, suddenly it seems the visual editor is no longer accessible. I'm on the 3.1.2 update. Perhaps an installed plugin is now incompatible?
    I would love to corroborate this experience with others to see whether it's due to the update.

  3. CaroleLynne
    Member
    Posted 3 years ago #

    Same problem on all the pages with new update. Help?

  4. kranmars
    Member
    Posted 3 years ago #

    I just de-Activated my Tierra Audio Playlist and visual seems to be working so far...will get back on here if this changes again.

  5. kranmars
    Member
    Posted 3 years ago #

    Lost it again, randomly. Even after de-activating some other plugins and refreshing, etc...ugh!

  6. k_nitin_r
    Member
    Posted 3 years ago #

    @kranmars

    Some WordPress plugins provide functionality for the admin pages and you may have a broken plugin. Try disabling all plugins and see if that helps.

  7. rescogitans
    Member
    Posted 3 years ago #

    I experienced this problem after a 3.1.2 update. None of the common solutions above have helped. Deactivating/Reactivating plugins, nor a host of other attempts. What HAS worked is looking into the folder permissions. I have changed the wp-includes to 775 access and the visual editor returned. Everyone seems to have various factors that contribute to their problems, try the folder permissions.

  8. Cole_IMC
    Member
    Posted 3 years ago #

    In your wp-config.php file:
    below- define ('WPLANG', '');
    add- define( 'CONCATENATE_SCRIPTS', false );

    This has been a fix for the visual editor since version 2.8

    Immediately after I updated a new clients WordPress to 3.1.2 and noticed the error with the visual editor I applied this setting and it was fixed.

Topic Closed

This topic has been closed to new replies.

About this Topic