WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Visual and html editors not working (5 posts)

  1. TriciaB
    Member
    Posted 1 year ago #

    I'm having real problems with this version of WordPress. The neither visual nor html editors are working properly. The visual editor has no toolbar and the text is html and in a white font. The html editor has a tab but is not available. I've done a lot of research and found various suggestions on this one. I've reinstalled it at least twice. I've cleared the cache. I've checked with my host that there's no problem with Java. I've disabled plugins (there were none installed) and I've installed 'use Google Libraries'. I've tried accessing the dashboard on a PC as well as my Mac but to no avail. Suggestions on how to fix this would be welcome.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

  3. TriciaB
    Member
    Posted 1 year ago #

    Yes, I've tried all of that. I'm just trying installing an older version of WordPress to see if that works. I have several other sites using WordPress without problems. This is the first time I've come across something I can't fix.

  4. I develop plugins for the editor, and I know it very well.

    When the visual editor goes blank.. and the text is white... and there are no buttons... it's because of a javascript conflict.

    99% of the time... this comes in the form of a plugin conflict.

    Also.. if you have two different plugins (or a plugin and a theme) each trying to modify one of the buttons in the editor... it will break.

    Again... plugin or theme conflict.

    Trust me... this is NOT a WP issue. It is a conflict with one of your plugins... or your theme... period.

  5. esmi
    Forum Moderator
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Topic