WordPress.org

Ready to get started?Download WordPress

Forums

Visual and HTML Editor are missing (25 posts)

  1. Friction5
    Member
    Posted 3 years ago #

    Hi,

    My visual and HTML Editor toolbars are missing, I've looked extensively throughout the support forum to only come across unsolved posts or solutions that don't work for me. I have gone to the User panel and checked and unchecked the "Disable the visual editor when writing"...I've deactivated all my plug-ins with no luck. I've viewed the Dashboard on both Firefox and Safari with the same results. I check to make sure my host/server uses php 5 (which is good) and I've re-uploaded WP 3.1.3 TWICE! So I'm really quite dumbfounded. Here's the kicker, I have another site I created using the same theme on the same server and the Visual and HTML editor toolbars are there...what the?

    The theme I'm using is called "inFocus" which I purchased from Theme Forest, it's had over 5000 downloads and is the number one theme on Theme Forest. I asked the developer and he said it's a WordPress issue.

    Please there has to be an answer to this issue by now since this problem has been around for several years now, at least from the dates on this forum. I would appreciate any help on this.

    Thanks in advance.

  2. orladuncan
    Member
    Posted 3 years ago #

    Hi

    Same here, I have just upgraded a website to WP 3.1.3 and my Visual Editor is not working correctly. In the visual pane my icons/buttons are not displaying. Also, my content is displaying as HTML code - fine for me but not fine for my non-techy client using the website.

    Any ideas on how to fix this?
    Cheers!
    Orla

  3. dustinlarimer
    Member
    Posted 3 years ago #

    I had the same problem. I found a fix but it was so specific to my specific setup that I can't imagine it being the root cause.. but perhaps a symptom?

    I found an error in my console for a missing JS file which traced back to a plugin, "Scissors for 2.9" -- I disabled the plugin and tracked down what I can only guess is its replacement: http://wordpress.org/extend/plugins/scissors-continued (great cropping utility, btw). I installed and activated the new plugin and it works great. I noticed some other quirks w/ the new 3.1.3 update, so maybe there's something deeper conflicting with plugin architectures.

    Best of luck,

    Dustin

  4. JadeGhost
    Member
    Posted 3 years ago #

    ok, I've been dealing with this too and it's been driving me crazy. some of my wp sites are fine while others are having the same issues. after everything else I ran across an older success story on this issue where they ended up deleting their browser history and closing and reloading their browser. That didn't work for me, BUT I do use Firefox a lot and so I tried using my explorer and wow... it worked... so maybe try a different browser.

    It seems that there are a lot of people with this issue and large number of ways for this problem to be created. The hard part is trying to find the problem and solution that fits yours. It's like there is one issue, 50 ways to create that issue and about 40 of them have solutions, each very specific to each problem.

    If this doesn't work, keep looking! Here are other threads with this issue and the many solutions and ideas for all of these problems that have the same issue:

    http://wordpress.org/support/topic/visual-editor-disappearing-1?replies=12

    http://wordpress.org/support/topic/visual-editor-lost-after-upgrade-to-30?replies=18

    http://wordpress.org/support/topic/visual-editor-notes-solution-for-fixing?replies=1

  5. Lanae
    Member
    Posted 3 years ago #

    Thank you so much!!! Because of this thread I deactivated one of the widgets that i wasn't even using, and my view tab is back to normal, and I'm once again able to add pictures normally, as well as add Post Tags again.

  6. Z_Everson
    Member
    Posted 3 years ago #

    Same problem here, only it's for a new site and I haven't even installed any plugins yet. And I'm using the same theme (Woo Theme's VibrantCMS) on a different site with no problems. Problem exists in both Safari 5.0.5 and Firefox 4.0.1.

  7. Dan Knauss
    Member
    Posted 3 years ago #

    I had this problem recently after an upgrade to WP 3.2.

    To fix it, first I re-installed WP but to no effect. Then I checked to see if the theme was the problem (it wasn't), updated the theme framework (no change), checked to see if NextGen Image Gallery was the problem (nope), and deleted all deactivated plugins. I got some error messages indicating that some of the deactivated plugins really don't exist anymore. After this the visual editor came back. I'd guess that the plugin records were out of whack and something in the 3.2 upgrade choked on that.

  8. ditesco
    Member
    Posted 2 years ago #

    I also had this problem right after I installed 3.2.1. After a lot of searching )including previous topics here which are now closed), I finally found out that the issue was because I was using CloudFlare's Auto Minify feature. Disable the JS auto minify and all is back up and running. Just telling you this in case anyone of you are using CloudFlare. If you are, try that one first...

    Hope this helps.

  9. totalgaz
    Member
    Posted 2 years ago #

    @ditesco Thanks so much for that. I use the Cloudflare service and unchecking the JS autominify function then purging the cache has brought back my visual editor :) I'm on wordpress 3.2.1

  10. ditesco
    Member
    Posted 2 years ago #

    @totalgaz.. welcome. Glad I could help

  11. yorgo67
    Member
    Posted 2 years ago #

    Hello. I've installed wordpress 3.2.1. I am learning this platform and I also can't see the 'visual' part of my html editor as well. I am using firefox 5.0.1. I haven't installed any plugins or anything yet. Can anyone tell me what I need to do to resolve this problem? Should I contact my host perhaps?

  12. yorgo67
    Member
    Posted 2 years ago #

    Never mind, I sifted thru all of these posts and found what was wrong. Thanks.

  13. pl2prosperity
    Member
    Posted 2 years ago #

    @ditesco...Thank you so much for your advise; I finally solved the puzzle. Like everybody else, I too tried everything that I could get my hands on all over the internet for the last 7 days, but, it was the Cloudflare Auto Minify solution that clicked for me. Yes, indeed, everyone using cloudflare should give that the first shot.

  14. ditesco
    Member
    Posted 2 years ago #

    @pl2proseperity That0s great. Glad it helped...

  15. greggh3
    Member
    Posted 2 years ago #

    I'm not sure if this applies to any of you, but a client had the same problem, but it was related to their user settings. If you go to your profile, the top checkbox is to disable the visual/html editor.

    It could be this for some of you.

  16. jonasll
    Member
    Posted 2 years ago #

    Quick note: make sure you go to your profile, and see if the top checkbox is ticked ( disable the visual/html editor)

  17. indysmith82
    Member
    Posted 2 years ago #

    I have a similar problem with my editors on some of my accounts. it seems to be related to installations done on 123 reg, but the visual editor just shows html, which is fine for me, but I am building a site for a writer who needs a WYSIWYG editor.

    I would like to try disabling auto-minify, but I have looked in all the tabs for my settings and cannot seem to find anywhere that has the option for it and I cannot find any information online. @dietsco, where did you find the option to disable it?

  18. helzebub
    Member
    Posted 2 years ago #

    @indysmith82...I've just installed a WordPress site at 123 reg with the same problem, no visual editor only HTML.

    I managed to resolve it by going to the Admin screen, under Settings click on General, if there is an extra/stray colon ':' at the end of either URL fields - remove it, save it and all should be fine.

    It's some conflict between 123 reg and WordPress. This could be the same for you.

  19. poddys
    Member
    Posted 2 years ago #

    None of these seem to apply to me, but all of my WordPress hosted sites have the same problem with the Visual Editor not working.

    I don't have Minify or the other plugins mentioned, but I wonder if my Theme might be giving problems with JQuery.

    Hoping I can get this resolved soon, very frustrating.

  20. Eagle Rock
    Member
    Posted 2 years ago #

    Jonasll - you rock !

  21. poddys
    Member
    Posted 2 years ago #

    Beware of adding a ";" to the url and saving, because then your site will not work! You will have to patch the url in the database tables using SQL.

    Got my site back, but still no solution to my Visual Editor problem.

  22. luckylasagne
    Member
    Posted 2 years ago #

    Great Jonasll - that worked perfectly thanks.

  23. rosemary8
    Member
    Posted 2 years ago #

    Thanks profile greggh3, your tip hasn't retuned everything to normal, but now I can post. Been struggling for over a week.

  24. Moe Tahir
    Member
    Posted 2 years ago #

    I have also the same problem with Visual editor, plus that I can't see the text since they became white letters in white background (only in edit mode) and None of the above seem to apply to me..

    so far i have done all these and none of them worked

    - de-activated all my plugins.
    - re-activated Twenty Ten
    - installed/activated Use Google Libraries plugin
    - added define( 'CONCATENATE_SCRIPTS', false ); on my wp-config file
    as advised here ( http://wordpress.org/support/topic/visual-post-editor-not-working-only-html-post-editor )

    - Checked whether it's disabled in my user's profile. It's not as the option " Disable the visual editor when writing" is unchecked.

    - Re-installed the WP-admin and WP-includes folder as advised in the WordPress forums.

  25. Donquiweb
    Member
    Posted 2 years ago #

    Hi,

    I fixed this issue on WP 3.3.1 when I deactivated the deflate_module on my Wamp installation. I activated it to test a PHP application few days before and remember this when I found the error :

    Erreur : missing ) after argument list
    Fichier Source : http://www.mysite.com/wp-admin/load-scripts.php?c=1&load=admin-bar,hoverIntent,common,jquery-color,thickbox,theme-preview,theme&ver=2bb4e45d240f389d99fab9f4c89db532
    Ligne : 3, Colonne : 3942

    Hope it will help you.

    Best,
    D.

Topic Closed

This topic has been closed to new replies.

About this Topic