WordPress.org

Ready to get started?Download WordPress

Forums

WP Slimstat
[resolved] Visits not tracked, shows 0 visits! (42 posts)

  1. JoseVega
    Member
    Posted 1 year ago #

    Hi, I just updated slimstat to the last version, and since I did that, slimstat is not tracking visitors.

    I´ve checked all the settings, and everything is configured fine. So, Slimstats shows 0 visits since the update.

    What do I do to fix it?

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. carbeck
    Member
    Posted 1 year ago #

    I updated to the most recent version of WP SlimStat (2.9, on WP 3.5) yesterday evening and since then it doesn't appear to count visitors for me anymore either. Those records aren't even added to the database.

  3. TechnoViel
    Member
    Posted 1 year ago #

    Same here since updating to 2.9 on WP3.5. Please help!

  4. carbeck
    Member
    Posted 1 year ago #

    Hm, inspecting the "Network" tab in Firebug, it says that wp-slimstat.js is loaded for me. But if I look at my server logs, it seems that there is no POST to wp-slimstat-js.php as usual.

  5. bibiebibo
    Member
    Posted 1 year ago #

    same thing
    it's a great plugin but the last updates had a lot of problems.
    it's a pity but i'm looking for a plugin that help me not give me troubles

  6. carbeck
    Member
    Posted 1 year ago #

    I've manually downgraded for the time being by downloading v. 2.8.7 of the plugin and overwriting the plugin folder on my server with that. Now it counts visitors again.

  7. bibiebibo
    Member
    Posted 1 year ago #

    Well..where can i find the v. 2.8.7?
    thanks

    P.S. stupid question sorry..too rush..i find it

  8. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Okay, no panic :) Please post the URL of your website or contact me at

    http://www.duechiacchiere.it/contatto

    to troubleshoot your issue!

    Thanks
    Camu

  9. TechnoViel
    Member
    Posted 1 year ago #

    My URL is:
    http://www.technoviel.de
    As mentioned above, WP3.5 and after updating to SlimStat 2.9 last night no more data is written / shown as of today.
    I would appreciate if you could have a look into this, I love SlimStat

    PS: How about the possibility to track external pages? You once mentioned it is a planned feature, but I don't see it on the list...

  10. pepe
    Member
    Posted 1 year ago #

    I've got the same problem with http://mundschenk.at. When the "Use CDN" feature is enabled, the URL used by the plugin gives a 404.

    I've disabled the feature (to use the local copy of the script) and visitors are tracked again in the Spy View, but not the Right Now tab. A manual call to wp-slimstat-js.php gives the expected "-105 : invalid data format" error message.

  11. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, apparently the JavaScript hasn't fully propagated in the CDN, yet. Those of you using that feature may want to temporarily disable it, and see how it goes.

    Can you guys contact me, I have a new file that I would like you to test.

    Cheers
    Camu

  12. pepe
    Member
    Posted 1 year ago #

    As I wrote, I get new visits in the Spy View, but NOT the Right Now tab. Visits are not tracked correctly.

  13. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Pepe, I would need a little more information to try and understand what the problem is:

    * PHP version
    * MySQL error logs
    * Javascript Mode active or not

    I'm working on a hotfix, contact me if you're interested in testing it.

    Thanks

  14. TechnoViel
    Member
    Posted 1 year ago #

    BTW: I am NOT using CDN (default config) and have this problem.

  15. camu
    Member
    Plugin Author

    Posted 1 year ago #

    TechnoViel,

    I'd like you to test my hotfix, as I believe I was able to address the issue.

    Cheers,
    Camu

  16. TechnoViel
    Member
    Posted 1 year ago #

    Hi Camu,
    feel free to send it to me... you have my email, I contacted you via http://www.duechiacchiere.it/contatto
    ~2h ago.
    But I am not familiar with manually updating plugins, hope this is not too tricky (WP spoiled me offering everything I need in the web interface ;-)

  17. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Patch sent :) You will only need basic FTP access to upload the new files, nothing else.

  18. JoseVega
    Member
    Posted 1 year ago #

    My website is http://blogueaygana.com/, and slimstat is not counting visitors.

    Can you send me the patch to my email?
    josevega@blogueaygana.com

  19. camu
    Member
    Plugin Author

    Posted 1 year ago #

    @JoseVega, files sent :)

  20. TechnoViel
    Member
    Posted 1 year ago #

    It did not work here - any ideas, Camu?

  21. pastore80
    Member
    Posted 1 year ago #

    i have the same problems! after the update..dont' tracking

  22. FidoSysop
    Member
    Posted 1 year ago #

    Yep.. Mine quit after upgrading to 2.9. http://www.fidosysop.org

    BTW: Dang nice plugin! Finally a good reason to dump Jetpack!

    Doc

  23. camu
    Member
    Plugin Author

    Posted 1 year ago #

    TechnoVial, on this site

    http://www.technoviel.de/

    I still see the old javascript being executed, are you sure you replaced all the files I sent you?

  24. camu
    Member
    Plugin Author

    Posted 1 year ago #

    All right everybody, to those who are experiencing this issue:

    1) temporarily disable the CDN
    2) manually download WP SlimStat again and overwrite the files on your server, I just pushed a bugfix which might help...

    Please post here your feedback once you've done both!

  25. pastore80
    Member
    Posted 1 year ago #

    if i can help you...
    i have disabled the javascript mode in general setting ("Turn this feature on if you are using a caching plugin (W3 Total Cache and friends). WP SlimStat will behave pretty much like Google Analytics, and visitors whose browser does not support Javascript will be ignored. A nice side effect is that most spammers, search engines and other crawlers will not be tracked."
    And now WORK!! tracking is ok!
    For now i bring the mode turn off
    Thank you!

  26. camu
    Member
    Plugin Author

    Posted 1 year ago #

    @pastore80 that's what I though, the hotfix I just pushed to the repository should resolve that issue. Can you follow the steps here above and see if the problem is solved?

  27. TechnoViel
    Member
    Posted 1 year ago #

    I checked files on the FTP, they're the new ones.
    in wp-slimstat-js.php only line 178 is changed, right?
    I also tried deactivating and activating the plugin, but no change.
    Could this be a caching issue?
    How do I best check if my browser shows the new version?

  28. pastore80
    Member
    Posted 1 year ago #

    i have downloaded the plugin from http://wordpress.org/extend/plugins/wp-slimstat/

    and don't work!

  29. FidoSysop
    Member
    Posted 1 year ago #

    CDN on or off makes no difference here. I'm not using any cache either. Last recorded stats were at 03:30 EST.

    Will wait for the update and try that.

  30. JoseVega
    Member
    Posted 1 year ago #

    Thanks for the files Camu, but It didn´t work.

    I already uploaded the new files via ftp, then I deactivated the CDN option, but the visitors count is still zero.

    Slimstat is not counting visitors yet.

    Another idea?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic