WordPress.org

Ready to get started?Download WordPress

Forums

"Visit Site" produces a blank screen - AGAIN and STILL (6 posts)

  1. jspringr
    Member
    Posted 5 years ago #

    I have increased php memory up to 512M by modifying the php.ini in /usr/local/lib along with .htaccess, php.ini and cache.php in blog/wp-includes. Following these mods I stopped and restarted Apache. None of this changed anything: there are still no php errors in the Apache error log, and all I get is a blank screen although many other WordPress functions (e.g., blog entry) work.

    I also get an error when launching wp-settings.php:

    Warning: require(ABSPATHwp-includes/compat.php) [function.require]: failed to open stream: No such file or directory in /usr/local/apache2/stock-compass/htdocs/blog/wp-settings.php on line 238

    Fatal error: require() [function.require]: Failed opening required 'ABSPATHwp-includes/compat.php' (include_path='.:/usr/local/lib/php') in /usr/local/apache2/stock-compass/htdocs/blog/wp-settings.php on line 238

    What can I do that will make this work?

  2. Is it actually spitting out ABSPATH? Sounds like that's not being picked up from your wp-config.

    NM, Apache. Uh. What's in your wp-config file?

  3. jspringr
    Member
    Posted 5 years ago #

    Thanks for getting back to me! Here's the wp-config file (without some of the comments).

    <?php

    /**The name of the database for WordPress */
    define('DB_NAME', 'main');

    /** MySQL database username */
    define('DB_USER', 'jeff');

    /** MySQL database password */

    define('DB_PASSWORD', '????????');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    define('AUTH_KEY', 'oI,=`8H^>j0*]Ux+~g&e?rD>//=))4]FM^Mc C[m66/aFNOln+Yx*>)=i9d;#OD;');
    define('SECURE_AUTH_KEY', '6q|U{[`qsKCFb|#-g2d7aZ9NQ|J{4AQe>/h[Sv0+D?nWcw@iUFkCbU9XqKG)^4XN');
    define('LOGGED_IN_KEY', 'a //hQR,N8u+;mU~*ovr,[T&D|`[RP=/Y*Lq_0B31t6mV=7k-Yqo]v8QZ|:MsJ0T');
    define('NONCE_KEY', '8g-8jd/@00N8=svH1Q+crS#Y<w[AIF=k7o7%@B3,%^S*QFRC5CyM<tL.X4,Q!3C_');

    $table_prefix = 'wp_';

    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    /** WordPress absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */

    require_once(ABSPATH . 'wp-settings.php');
    ?>

  4. FYI, you should keep your KEYs secret (AUTH, Secure, etc).

    This:

    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    require_once(ABSPATH . 'wp-settings.php');

    is correct, but it looks like it's not being parsed for some reason. Assuming this is a new install, make sure you copied up everything.

    What version of PHP is on your server? I doubt it matters at this point, and I'm poking around for this error message.

    Related post: Fatal error on installation

  5. jspringr
    Member
    Posted 5 years ago #

    php-5.2.8 - I downloaded it and installed it as part of the WordPress install. I think I will try re-installing everything (i.e., WordPress) again.

    Do you think this is related to the blank screen problem?

    Thanks again,
    - Jeff

  6. I'm not sure. I see mention of how it's related to SQL and PHP, or a config file not having spaces.

    PHP 5.2.8 is what I have, so I know that's okay. It could be a server setup issue, but I can't think of why that would show itself that way. I need someone smarter...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags