WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
virtualhost ssl page not found (1 post)

  1. rosevp
    Member
    Posted 1 year ago #

    Not sure if HTTPS is the problem, but I set up virtual host for 443 and can get to root fine and wp-admin but can't get to any of the other folders/pages

    http://mysite.example.com - 200
    http://mysite.example.com/shop - 200

    https://mysite.example.com - 200
    https://mysite.example.com/wp-admin - 200
    https://mysite.example.com/shop - 404

    Can't figure why I can get to virtualhost main index using HTTPS but not any other pages

    Been working on this for hours. Any help would be appreciated

    Here is my SSL config

    <IfModule mod_ssl.c>
    <VirtualHost _default_:443>
    ServerAdmin webmaster@localhost
    #ServerName mysite.example.com

    DocumentRoot /var/www/mysite/wordpress-live
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/ssl_access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
    # Enable/Disable SSL for this virtual host.
    SSLEngine on

    # A self-signed (snakeoil) certificate can be created by installing
    # the ssl-cert package. See
    # /usr/share/doc/apache2.2-common/README.Debian.gz for more info.
    # If both key and certificate are stored in the same file, only the
    # SSLCertificateFile directive is needed.
    SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
    SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

    http://wordpress.org/extend/plugins/wordpress-https/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags